these patches add upx and libucl packages.

From http://upx.sourceforge.net/

UPX is a free, portable, extendable, high-performance executable packer
for several different executable formats. It achieves an excellent
compression ratio and offers very fast decompression. Your executables
suffer no memory overhead or other drawbacks for most of the formats
supported, because of in-place decompression.

-Raphael

git-svn-id: svn://svn.openwrt.org/openwrt/packages@19768 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
thepeople 2010-02-20 04:43:27 +00:00
parent 306b2278b7
commit 5d602b2a3a
3 changed files with 122 additions and 0 deletions

57
libs/ucl/Makefile Normal file
View File

@ -0,0 +1,57 @@
#
# Copyright (C) 2006-2010 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
include $(TOPDIR)/rules.mk
PKG_NAME:=ucl
PKG_VERSION:=1.03
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.oberhumer.com/opensource/ucl/download/
PKG_MD5SUM:=852bd691d8abc75b52053465846fba34
PKG_FIXUP:=libtool
PKG_INSTALL:=1
include $(INCLUDE_DIR)/package.mk
define Package/libucl
SECTION:=libs
CATEGORY:=Libraries
DEPENDS:=
TITLE:=The Ultimate Packer for eXecutables
URL:=http://upx.sourceforge.net/
endef
define Package/libucl/description
UCL is a portable lossless data compression library written in ANSI C. UCL
implements a number of compression algorithms that achieve an excellent
compression ratio while allowing *very* fast decompression. Decompression
requires no additional memory.
endef
CONFIGURE_ARGS += \
--enable-static \
--enable-shared \
--disable-asm
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include/ucl
$(CP) $(PKG_INSTALL_DIR)/usr/include/ucl/ucl{,conf}.h $(1)/usr/include/ucl/
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libucl.{a,so*} $(1)/usr/lib/
endef
define Package/libucl/install
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libucl.so* $(1)/usr/lib/
endef
$(eval $(call BuildPackage,libucl))

53
utils/upx/Makefile Normal file
View File

@ -0,0 +1,53 @@
#
# Copyright (C) 2006-2010 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
include $(TOPDIR)/rules.mk
PKG_NAME:=upx
PKG_VERSION:=3.04
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-src.tar.bz2
PKG_SOURCE_URL:=http://upx.sourceforge.net/download/
PKG_MD5SUM:=68d662b1f831335460f9bfdbf632c6ce
TAR_OPTIONS+=--transform='s,$(PKG_NAME)-$(PKG_VERSION)-src,$(PKG_NAME)-$(PKG_VERSION),'
include $(INCLUDE_DIR)/package.mk
define Package/upx
SECTION:=utils
CATEGORY:=Utilities
DEPENDS:=+libucl
TITLE:=The Ultimate Packer for eXecutables
URL:=http://upx.sourceforge.net/
endef
define Package/upx/description
UPX is a free, portable, extendable, high-performance executable packer for
several different executable formats. It achieves an excellent compression ratio
and offers very fast decompression. Your executables suffer no memory overhead
or other drawbacks for most of the formats supported, because of in-place
decompression.
endef
MAKE_VARS += \
UPX_UCLDIR="$(STAGING_DIR)/usr/include/ucl" \
exeext=""
define Build/Compile
$(call Build/Compile/Default, \
all \
)
endef
define Package/upx/install
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/upx $(1)/usr/bin/
endef
$(eval $(call BuildPackage,upx))

View File

@ -0,0 +1,12 @@
diff -pruN upx-3.04.orig//Makefile upx-3.04/Makefile
--- upx-3.04.orig//Makefile 2010-02-18 15:07:46.894410571 +0100
+++ upx-3.04/Makefile 2010-02-18 15:08:32.758657685 +0100
@@ -35,7 +35,7 @@ ifeq ($(BUILD_STUB),1)
$(MAKE) -C src/stub $@
endif
$(MAKE) -C src $@
- $(MAKE) -C doc $@
+# $(MAKE) -C doc $@
ifneq ($(wildcard .hg/.),)