[packages] spandsp: every dead autoconf macro is a good autoconf macro

- Remove AC_FUNC_MALLOC and AC_FUNC_REALLOC, they cause bogus rpl_* symbols
 - Apply autoreconf fixup to get a sane libtool
 - Get rid of rpath-link, this is now uneeded after latest toolchain reworks
 - Bump pkg revision

git-svn-id: svn://svn.openwrt.org/openwrt/packages@29792 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
jow 2012-01-19 02:38:54 +00:00
parent 23b8d48d5e
commit 5e1b592729
2 changed files with 18 additions and 9 deletions

View File

@ -1,5 +1,5 @@
#
# Copyright (C) 2010 OpenWrt.org
# Copyright (C) 2010-2012 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@ -11,7 +11,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=spandsp
PKG_VERSION:=0.0.6
PKG_VERSION_SUFFIX:=pre17
PKG_RELEASE:=1
PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)$(PKG_VERSION_SUFFIX).tgz
PKG_SOURCE_URL:=http://www.soft-switch.org/downloads/spandsp/
@ -19,6 +19,7 @@ PKG_MD5SUM:=cc860f77270cf3b881f8ccd42d2d0238
PKG_INSTALL:=1
PKG_BUILD_PARALLEL:=1
PKG_FIXUP:=autoreconf
include $(INCLUDE_DIR)/package.mk
@ -29,8 +30,6 @@ define Package/libspandsp
DEPENDS:=+libtiff
endef
CONFIGURE_ARGS+= LIBS="-Wl,-rpath-link=$(STAGING_DIR)/usr/lib"
TARGET_CFLAGS += $(FPIC)
define Build/InstallDev

View File

@ -1,8 +1,6 @@
Index: spandsp-0.0.6/src/spandsp/fast_convert.h
===================================================================
--- spandsp-0.0.6.orig/src/spandsp/fast_convert.h 2010-10-24 12:20:25.000000000 +0200
+++ spandsp-0.0.6/src/spandsp/fast_convert.h 2010-10-24 12:21:39.000000000 +0200
@@ -197,7 +197,7 @@
--- a/src/spandsp/fast_convert.h
+++ b/src/spandsp/fast_convert.h
@@ -197,7 +197,7 @@ extern "C"
{
return (long int) (x);
}
@ -11,3 +9,15 @@ Index: spandsp-0.0.6/src/spandsp/fast_convert.h
static __inline__ long int lfastrint(register double x)
{
int res[2];
--- a/configure.ac
+++ b/configure.ac
@@ -152,9 +152,7 @@ AC_ARG_ENABLE(builtin_tiff,
AC_FUNC_ERROR_AT_LINE
AC_FUNC_VPRINTF
-AC_FUNC_MALLOC
AC_FUNC_MEMCMP
-AC_FUNC_REALLOC
AC_FUNC_SELECT_ARGTYPES
AX_C99_FUNC_LRINT