dsl-qos-queue: remove from /packages
No longer functional (libipq is no longer supported), and abandoned by upstream as well. Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/packages@37494 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
1ea09c53e9
commit
5e5e314b6f
@ -1,49 +0,0 @@
|
||||
#
|
||||
# Copyright (C) 2006-2010 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=dsl_qos_queue
|
||||
PKG_VERSION:=0.9.3
|
||||
PKG_RELEASE:=3
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://www.sonicspike.net/software/download/
|
||||
PKG_MD5SUM:=ccbe8d28c3508c67f669fe98532533be
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/dsl-qos-queue
|
||||
SECTION:=net
|
||||
CATEGORY:=Network
|
||||
DEPENDS:=+iptables +kmod-ipt-queue +iptables-mod-ipopt +libipq
|
||||
TITLE:=ADSL/ATM Bandwith management
|
||||
URL:=http://www.sonicspike.net/software/
|
||||
endef
|
||||
|
||||
define Build/Configure
|
||||
endef
|
||||
|
||||
define Build/Compile
|
||||
$(call Build/Compile/Default, \
|
||||
CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include/libipq $(TARGET_CPPFLAGS)" \
|
||||
LDFLAGS="$(TARGET_LDFLAGS)" \
|
||||
LIBIPQ="-lipq" \
|
||||
all \
|
||||
)
|
||||
endef
|
||||
|
||||
define Package/dsl-qos-queue/install
|
||||
$(INSTALL_DIR) $(1)/usr/sbin
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/usr/sbin/
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/dsl_qos_train $(1)/usr/sbin
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/ipt_rules $(1)/usr/sbin
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,dsl-qos-queue))
|
@ -1,40 +0,0 @@
|
||||
--- a/dsl_qos_queue.c
|
||||
+++ b/dsl_qos_queue.c
|
||||
@@ -552,12 +552,12 @@
|
||||
|
||||
syslog(LOG_INFO, "setup()");
|
||||
|
||||
- rval=system("modprobe ip_queue");
|
||||
+/* rval=system("modprobe ip_queue");
|
||||
if (WEXITSTATUS(rval)!=0)
|
||||
{
|
||||
printf("Unable to install ip_queue module.\n");
|
||||
exit(1);
|
||||
- }
|
||||
+ }*/
|
||||
|
||||
for (i=0;i<MAX_QDEV;i++) if (_qdev[i]) hook_iptables(_qdev[i]);
|
||||
|
||||
--- a/makefile
|
||||
+++ b/makefile
|
||||
@@ -4,14 +4,14 @@
|
||||
all: dsl_qos_queue dsl_qos_train
|
||||
clean:
|
||||
rm *.o
|
||||
-dsl_qos_queue: dsl_qos_queue.o daemon.o $(LIBIPQ)
|
||||
- $(CC) -o dsl_qos_queue dsl_qos_queue.o daemon.o -lipq
|
||||
+dsl_qos_queue: dsl_qos_queue.o daemon.o
|
||||
+ $(CC) $(CFLAGS) $(LDFLAGS) -o dsl_qos_queue dsl_qos_queue.o daemon.o $(LIBIPQ)
|
||||
dsl_qos_queue.o: dsl_qos_queue.c
|
||||
- $(CC) -c dsl_qos_queue.c
|
||||
+ $(CC) $(CFLAGS) -c dsl_qos_queue.c
|
||||
daemon.o: daemon.c
|
||||
- $(CC) -c daemon.c
|
||||
+ $(CC) $(CFLAGS) -c daemon.c
|
||||
|
||||
dsl_qos_train: dsl_qos_train.o
|
||||
- $(CC) -o dsl_qos_train dsl_qos_train.o
|
||||
+ $(CC) $(CFLAGS) -o dsl_qos_train dsl_qos_train.o
|
||||
dsl_qos_train.o: dsl_qos_train.c
|
||||
- $(CC) -c dsl_qos_train.c
|
||||
+ $(CC) $(CFLAGS) -c dsl_qos_train.c
|
@ -1,20 +0,0 @@
|
||||
--- a/dsl_qos_queue.c
|
||||
+++ b/dsl_qos_queue.c
|
||||
@@ -12,8 +12,6 @@
|
||||
// more accurate way to prevent packet queueing in the network
|
||||
// device (in this case, ADSL modem).
|
||||
//
|
||||
-#include <linux/netfilter.h>
|
||||
-#include <libipq.h>
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
||||
#include <netinet/in.h>
|
||||
@@ -25,6 +23,8 @@
|
||||
#include <unistd.h>
|
||||
#include <syslog.h>
|
||||
#include <string.h>
|
||||
+#include <linux/netfilter.h>
|
||||
+#include <libipq.h>
|
||||
|
||||
#include "daemon.h"
|
||||
|
@ -1,22 +0,0 @@
|
||||
--- a/ipt_rules
|
||||
+++ b/ipt_rules
|
||||
@@ -26,14 +26,14 @@ iptables -t mangle -A MYSHAPER-OUT -p tc
|
||||
iptables -t mangle -A MYSHAPER-OUT -p icmp -j MARK --set-mark 20 # ICMP (ping) - high prio, impress friends
|
||||
iptables -t mangle -A MYSHAPER-OUT -p udp --dport 123 -j MARK --set-mark 20 # NTP should be low-lag
|
||||
iptables -t mangle -A MYSHAPER-OUT -p udp --dport 53 -j MARK --set-mark 21 # DNS name resolution (small packets)
|
||||
-iptables -t mangle -A MYSHAPER-OUT -p tcp --dport ssh -j MARK --set-mark 22 # secure shell
|
||||
-iptables -t mangle -A MYSHAPER-OUT -p tcp --sport ssh -j MARK --set-mark 22 # secure shell
|
||||
-iptables -t mangle -A MYSHAPER-OUT -p tcp --dport telnet -j MARK --set-mark 22 # telnet (ew...)
|
||||
-iptables -t mangle -A MYSHAPER-OUT -p tcp --sport telnet -j MARK --set-mark 22 # telnet (ew...)
|
||||
+iptables -t mangle -A MYSHAPER-OUT -p tcp --dport 22 -j MARK --set-mark 22 # secure shell
|
||||
+iptables -t mangle -A MYSHAPER-OUT -p tcp --sport 22 -j MARK --set-mark 22 # secure shell
|
||||
+iptables -t mangle -A MYSHAPER-OUT -p tcp --dport 23 -j MARK --set-mark 22 # telnet (ew...)
|
||||
+iptables -t mangle -A MYSHAPER-OUT -p tcp --sport 23 -j MARK --set-mark 22 # telnet (ew...)
|
||||
iptables -t mangle -A MYSHAPER-OUT -p ipv6-crypt -j MARK --set-mark 24 # IPSec - we dont know what the payload is though...
|
||||
iptables -t mangle -A MYSHAPER-OUT -p udp --dport 10000 -j MARK --set-mark 24 # IPSec (udp tunnel) - we dont know what the payload is though...
|
||||
|
||||
-iptables -t mangle -A MYSHAPER-OUT -p tcp --sport http -j MARK --set-mark 25 # Local web server
|
||||
+iptables -t mangle -A MYSHAPER-OUT -p tcp --sport 80 -j MARK --set-mark 25 # Local web server
|
||||
iptables -t mangle -A MYSHAPER-OUT -p tcp -m length --length :64 -j MARK --set-mark 21 # small packets (probably just ACKs)
|
||||
iptables -t mangle -A MYSHAPER-OUT -p tcp --sport 3389 -j MARK --set-mark 23 # windows remote computer connection
|
||||
iptables -t mangle -A MYSHAPER-OUT -m mark --mark 0 -j MARK --set-mark 26 # redundant- mark any unmarked packets as 26 (low pri
|
@ -1,8 +0,0 @@
|
||||
--- a/ipt_rules
|
||||
+++ b/ipt_rules
|
||||
@@ -1,4 +1,4 @@
|
||||
-#!/bin/bash
|
||||
+#!/bin/sh
|
||||
# add MYSHAPER-OUT chain to the mangle table in iptables - this sets up the table we'll use
|
||||
# to filter and mark packets.
|
||||
|
Loading…
x
Reference in New Issue
Block a user