bluez-utils: remove
Superseeded by bluez recently added to github repo git-svn-id: svn://svn.openwrt.org/openwrt/packages@43902 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
6a5bfd760a
commit
5fc871012e
@ -1,75 +0,0 @@
|
||||
#
|
||||
# Copyright (C) 2006-2012 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=bluez-utils
|
||||
PKG_VERSION:=3.36
|
||||
PKG_RELEASE:=12
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://bluez.sourceforge.net/download
|
||||
PKG_MD5SUM:=4fc292b635ba7b442c7aaf5680199012
|
||||
|
||||
PKG_FIXUP:=autoreconf
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
include $(INCLUDE_DIR)/nls.mk
|
||||
|
||||
define Package/bluez-utils
|
||||
SECTION:=utils
|
||||
CATEGORY:=Utilities
|
||||
DEPENDS:=+bluez-libs +libpthread +dbus $(INTL_DEPENDS) $(ICONV_DEPENDS)
|
||||
TITLE:=Bluetooth utilities
|
||||
URL:=http://www.bluez.org/
|
||||
endef
|
||||
|
||||
define Package/bluez-utils/conffiles
|
||||
/etc/bluetooth/hcid.conf
|
||||
/etc/bluetooth/rfcomm.conf
|
||||
/etc/config/bluetooth
|
||||
endef
|
||||
|
||||
CONFIGURE_ARGS += \
|
||||
--disable-glib \
|
||||
--enable-pand \
|
||||
--enable-rfcomm \
|
||||
--enable-dund \
|
||||
--enable-serial \
|
||||
--enable-network \
|
||||
--enable-usb \
|
||||
--enable-input \
|
||||
--disable-audio \
|
||||
--with-bluez="$(STAGING_DIR)/usr/include" \
|
||||
--with-usb=yes \
|
||||
|
||||
define Build/Compile
|
||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||
LDFLAGS="$(TARGET_LDFLAGS) \
|
||||
-L$(ICONV_PREFIX)/lib \
|
||||
-L$(INTL_PREFIX)/lib -lm" \
|
||||
DESTDIR="$(PKG_INSTALL_DIR)" \
|
||||
all install
|
||||
endef
|
||||
|
||||
define Package/bluez-utils/install
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
|
||||
$(INSTALL_DIR) $(1)/usr/sbin
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/sbin/* $(1)/usr/sbin/
|
||||
$(INSTALL_DIR) $(1)/etc/bluetooth
|
||||
$(CP) $(PKG_INSTALL_DIR)/etc/bluetooth/hcid.conf $(1)/etc/bluetooth/
|
||||
$(CP) $(PKG_INSTALL_DIR)/etc/bluetooth/rfcomm.conf $(1)/etc/bluetooth/
|
||||
$(INSTALL_DIR) $(1)/etc/config
|
||||
$(INSTALL_DATA) ./files/bluetooth.config $(1)/etc/config/bluetooth
|
||||
$(INSTALL_DIR) $(1)/etc/dbus-1/system.d/
|
||||
$(INSTALL_DATA) ./files/bluetooth.dbus $(1)/etc/dbus-1/system.d/bluetooth.conf
|
||||
$(INSTALL_DIR) $(1)/etc/init.d
|
||||
$(INSTALL_BIN) ./files/bluez-utils.init $(1)/etc/init.d/bluez-utils
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,bluez-utils))
|
@ -1,32 +0,0 @@
|
||||
config hcid
|
||||
# option config /etc/bluetooth/hcid.conf
|
||||
option enabled 1
|
||||
|
||||
config hciattach
|
||||
option initspeed 115200
|
||||
option tty ttyS1
|
||||
option type csr
|
||||
option speed 115200
|
||||
option flow noflow
|
||||
option enabled 0
|
||||
|
||||
config rfcomm
|
||||
# option config /etc/bluetooth/rfcomm.conf
|
||||
option enabled 0
|
||||
|
||||
config dund
|
||||
option listen true
|
||||
option persist true
|
||||
option msdun true
|
||||
option interface dund
|
||||
option unit 1
|
||||
option pppdopts "ktune proxyarp 192.168.1.1:192.168.1.2 ms-dns 192.168.1.1"
|
||||
option enabled 0
|
||||
|
||||
config pand
|
||||
option listen true
|
||||
option autozap true
|
||||
option role "NAP"
|
||||
option master true
|
||||
option persist true
|
||||
option enabled 0
|
@ -1,37 +0,0 @@
|
||||
<!-- This configuration file specifies the required security policies
|
||||
for Bluetooth core daemon to work. -->
|
||||
|
||||
<!DOCTYPE busconfig PUBLIC "-//freedesktop//DTD D-BUS Bus Configuration 1.0//EN"
|
||||
"http://www.freedesktop.org/standards/dbus/1.0/busconfig.dtd">
|
||||
<busconfig>
|
||||
|
||||
<!-- ../system.conf have denied everything, so we just punch some holes -->
|
||||
|
||||
<policy user="root">
|
||||
<allow own="org.bluez"/>
|
||||
</policy>
|
||||
|
||||
<policy at_console="true">
|
||||
<allow send_path="/"/>
|
||||
<allow send_path="/org/bluez"/>
|
||||
|
||||
<allow send_destination="org.bluez.Manager"/>
|
||||
<allow receive_sender="org.bluez.Manager"/>
|
||||
|
||||
<allow send_destination="org.bluez.Adapter"/>
|
||||
<allow receive_sender="org.bluez.Adapter"/>
|
||||
|
||||
<allow send_destination="org.bluez.Device"/>
|
||||
<allow receive_sender="org.bluez.Device"/>
|
||||
|
||||
<allow send_destination="org.bluez.Service"/>
|
||||
<allow receive_sender="org.bluez.Service"/>
|
||||
|
||||
<allow send_destination="org.bluez.Database"/>
|
||||
<allow receive_sender="org.bluez.Database"/>
|
||||
|
||||
<allow send_destination="org.bluez.Security"/>
|
||||
<allow receive_sender="org.bluez.Security"/>
|
||||
</policy>
|
||||
|
||||
</busconfig>
|
@ -1,131 +0,0 @@
|
||||
#!/bin/sh /etc/rc.common
|
||||
# Copyright (C) 2007 OpenWrt.org
|
||||
|
||||
#start after dbus (60)
|
||||
START=62
|
||||
|
||||
append_bool() {
|
||||
local section="$1"
|
||||
local option="$2"
|
||||
local value="$3"
|
||||
local _val
|
||||
config_get_bool _val "$section" "$option" '0'
|
||||
[ $_val -gt 0 ] && append args "$3"
|
||||
}
|
||||
|
||||
append_string() {
|
||||
local section="$1"
|
||||
local option="$2"
|
||||
local value="$3"
|
||||
local default="$4"
|
||||
local _val
|
||||
config_get _val "$section" "$option" "$default"
|
||||
[ -n "$_val" ] && append args "$3 $_val"
|
||||
}
|
||||
|
||||
hcid_config() {
|
||||
local cfg="$1"
|
||||
config_get_bool enabled "$cfg" "enabled" '1'
|
||||
[ $enabled -gt 0 ] || return 1
|
||||
args=""
|
||||
append_bool "$cfg" nodaemon "-n"
|
||||
append_string "$cfg" config "-f"
|
||||
service_start /usr/sbin/hcid $args
|
||||
}
|
||||
|
||||
hciattach_config() {
|
||||
local cfg="$1"
|
||||
config_get_bool enabled "$cfg" "enabled" '1'
|
||||
[ $enabled -gt 0 ] || return 1
|
||||
args=""
|
||||
append_string "$cfg" initspeed "-s" "115200"
|
||||
append_string "$cfg" tty " " "ttyS1"
|
||||
append_string "$cfg" type " " "csr"
|
||||
append_string "$cfg" speed " " "115200"
|
||||
append_string "$cfg" flow " " "noflow"
|
||||
service_start /usr/sbin/hciattach $args
|
||||
}
|
||||
|
||||
rfcomm_config() {
|
||||
local cfg="$1"
|
||||
config_get_bool enabled "$cfg" "enabled" '1'
|
||||
[ $enabled -gt 0 ] || return 1
|
||||
args=""
|
||||
append_string "$cfg" config "-f"
|
||||
/usr/bin/rfcomm $args bind all
|
||||
}
|
||||
|
||||
dund_config() {
|
||||
local cfg="$1"
|
||||
config_get_bool enabled "$cfg" "enabled" '1'
|
||||
[ $enabled -gt 0 ] || return 1
|
||||
args=""
|
||||
append_bool "$cfg" listen "--listen"
|
||||
append_string "$cfg" connect "--connect"
|
||||
append_string "$cfg" mrouter "--mrouter"
|
||||
append_bool "$cfg" search "--search"
|
||||
append_string "$cfg" channel "--channel"
|
||||
append_string "$cfg" device "--device"
|
||||
append_bool "$cfg" nosdp "--nosdp"
|
||||
append_bool "$cfg" auth "--auth"
|
||||
append_bool "$cfg" encrypt "--encrypt"
|
||||
append_bool "$cfg" secure "--secure"
|
||||
append_bool "$cfg" master "--master"
|
||||
append_bool "$cfg" nodetach "--nodetach"
|
||||
append_bool "$cfg" persist "--persist"
|
||||
append_string "$cfg" pppd "--pppd"
|
||||
append_bool "$cfg" msdun "--msdun"
|
||||
append_bool "$cfg" activesync "--activesync"
|
||||
append_bool "$cfg" cache "--cache"
|
||||
|
||||
append_string "$cfg" pppdopts ""
|
||||
config_get ifn "$cfg" interface
|
||||
if [ -n "$ifn" ]; then
|
||||
config_get unit "$cfg" unit
|
||||
[ -z "$unit" ] || append args "unit $unit ipparam $ifn linkname $ifn"
|
||||
fi
|
||||
|
||||
service_start /usr/bin/dund $args
|
||||
}
|
||||
|
||||
pand_config() {
|
||||
local cfg="$1"
|
||||
config_get_bool enabled "$cfg" "enabled" '1'
|
||||
[ $enabled -gt 0 ] || return 1
|
||||
args=""
|
||||
append_bool "$cfg" listen "--listen"
|
||||
append_string "$cfg" connect "--connect"
|
||||
append_bool "$cfg" autozap "--autozap"
|
||||
append_bool "$cfg" search "--search"
|
||||
append_string "$cfg" role "--role"
|
||||
append_string "$cfg" service "--service"
|
||||
append_string "$cfg" ethernet "--ethernet"
|
||||
append_string "$cfg" device "--device"
|
||||
append_bool "$cfg" nosdp "-D"
|
||||
append_bool "$cfg" auth "-A"
|
||||
append_bool "$cfg" encrypt "-E"
|
||||
append_bool "$cfg" secure "-S"
|
||||
append_bool "$cfg" master "-M"
|
||||
append_bool "$cfg" nodetach "-n"
|
||||
append_bool "$cfg" persist "--persist"
|
||||
append_bool "$cfg" cache "--cache"
|
||||
append_string "$cfg" pidfile "--pidfile"
|
||||
service_start /usr/bin/pand $args
|
||||
}
|
||||
|
||||
start() {
|
||||
config_load bluetooth
|
||||
config_foreach hcid_config hcid
|
||||
config_foreach hciattach_config hciattach
|
||||
config_foreach rfcomm_config rfcomm
|
||||
config_foreach dund_config dund
|
||||
config_foreach pand_config pand
|
||||
}
|
||||
|
||||
stop() {
|
||||
service_stop /usr/bin/dund
|
||||
service_stop /usr/bin/pand
|
||||
/usr/bin/rfcomm release all
|
||||
service_stop /usr/sbin/hciattach
|
||||
service_stop /usr/sbin/hcid
|
||||
}
|
@ -1,14 +0,0 @@
|
||||
#!/bin/sh
|
||||
|
||||
# Write bluetooth PIN number here:
|
||||
pin=
|
||||
|
||||
if [ -z "$pin" ]; then
|
||||
msg="Set bluetooth PIN in file $0"
|
||||
logger -p user.err "$msg"
|
||||
for i in /dev/pts/* ; do
|
||||
[ -w $i ] && echo "$msg" > $i
|
||||
done
|
||||
else
|
||||
echo "PIN:$pin"
|
||||
fi
|
@ -1,20 +0,0 @@
|
||||
--- a/hidd/sdp.c
|
||||
+++ b/hidd/sdp.c
|
||||
@@ -34,6 +34,7 @@
|
||||
#include <sys/stat.h>
|
||||
#include <sys/param.h>
|
||||
#include <sys/socket.h>
|
||||
+#include <linux/limits.h>
|
||||
|
||||
#include <bluetooth/bluetooth.h>
|
||||
#include <bluetooth/l2cap.h>
|
||||
--- a/tools/hciconfig.c
|
||||
+++ b/tools/hciconfig.c
|
||||
@@ -37,6 +37,7 @@
|
||||
#include <sys/param.h>
|
||||
#include <sys/ioctl.h>
|
||||
#include <sys/socket.h>
|
||||
+#include <linux/limits.h>
|
||||
|
||||
#include <bluetooth/bluetooth.h>
|
||||
#include <bluetooth/hci.h>
|
@ -1,20 +0,0 @@
|
||||
--- a/hcid/hcid.conf
|
||||
+++ b/hcid/hcid.conf
|
||||
@@ -12,7 +12,7 @@
|
||||
# auto - Use local PIN for incoming connections
|
||||
# user - Always ask user for a PIN
|
||||
#
|
||||
- security user;
|
||||
+ security auto;
|
||||
|
||||
# Pairing mode
|
||||
# none - Pairing disabled
|
||||
@@ -29,7 +29,7 @@
|
||||
# Local device name
|
||||
# %d - device id
|
||||
# %h - host name
|
||||
- name "BlueZ (%d)";
|
||||
+ name "%h";
|
||||
|
||||
# Local device class
|
||||
class 0x000100;
|
@ -1,22 +0,0 @@
|
||||
--- a/input/device.c
|
||||
+++ b/input/device.c
|
||||
@@ -25,6 +25,8 @@
|
||||
#include <config.h>
|
||||
#endif
|
||||
|
||||
+#define ENOKEY 161 /* Required key not available */
|
||||
+
|
||||
#include <stdlib.h>
|
||||
#include <errno.h>
|
||||
#include <fcntl.h>
|
||||
--- a/input/storage.c
|
||||
+++ b/input/storage.c
|
||||
@@ -25,6 +25,8 @@
|
||||
#include <config.h>
|
||||
#endif
|
||||
|
||||
+#define ENOKEY 161 /* Required key not available */
|
||||
+
|
||||
#include <stdio.h>
|
||||
#include <errno.h>
|
||||
#include <ctype.h>
|
@ -1,40 +0,0 @@
|
||||
--- a/tools/hciattach.c
|
||||
+++ b/tools/hciattach.c
|
||||
@@ -111,20 +111,37 @@
|
||||
return B230400;
|
||||
case 460800:
|
||||
return B460800;
|
||||
+/* FIX: Not all platform support this high serial speed
|
||||
+ claudyus84 @gamil.com
|
||||
+*/
|
||||
+#ifdef B500000
|
||||
case 500000:
|
||||
return B500000;
|
||||
+#endif
|
||||
+#ifdef B576000
|
||||
case 576000:
|
||||
return B576000;
|
||||
+#endif
|
||||
+#ifdef B921600
|
||||
case 921600:
|
||||
return B921600;
|
||||
+#endif
|
||||
+#ifdef B1000000
|
||||
case 1000000:
|
||||
return B1000000;
|
||||
+#endif
|
||||
+#ifdef B1152000
|
||||
case 1152000:
|
||||
return B1152000;
|
||||
+#endif
|
||||
+#ifdef B1500000
|
||||
case 1500000:
|
||||
return B1500000;
|
||||
+#endif
|
||||
+#ifdef B2000000
|
||||
case 2000000:
|
||||
return B2000000;
|
||||
+#endif
|
||||
#ifdef B2500000
|
||||
case 2500000:
|
||||
return B2500000;
|
Loading…
x
Reference in New Issue
Block a user