[packages] radsecproxy: add missing return statements to fix compilation on Backfire
git-svn-id: svn://svn.openwrt.org/openwrt/packages@30360 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
3a2c6b46e4
commit
618aa9516c
@ -1,5 +1,5 @@
|
|||||||
#
|
#
|
||||||
# Copyright (C) 2008-20211 OpenWrt.org
|
# Copyright (C) 2008-2012 OpenWrt.org
|
||||||
#
|
#
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
# See /LICENSE for more information.
|
# See /LICENSE for more information.
|
||||||
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||||||
|
|
||||||
PKG_NAME:=radsecproxy
|
PKG_NAME:=radsecproxy
|
||||||
PKG_VERSION:=1.5
|
PKG_VERSION:=1.5
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=2
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=http://software.uninett.no/radsecproxy/
|
PKG_SOURCE_URL:=http://software.uninett.no/radsecproxy/
|
||||||
|
58
net/radsecproxy/patches/100-missing-return.patch
Normal file
58
net/radsecproxy/patches/100-missing-return.patch
Normal file
@ -0,0 +1,58 @@
|
|||||||
|
--- a/dtls.c
|
||||||
|
+++ b/dtls.c
|
||||||
|
@@ -523,6 +523,7 @@ void *udpdtlsserverrd(void *arg) {
|
||||||
|
free(params);
|
||||||
|
cacheexpire(sessioncache, &lastexpiry);
|
||||||
|
}
|
||||||
|
+ return NULL;
|
||||||
|
}
|
||||||
|
|
||||||
|
int dtlsconnect(struct server *server, struct timeval *when, int timeout, char *text) {
|
||||||
|
@@ -642,6 +643,7 @@ void *udpdtlsclientrd(void *arg) {
|
||||||
|
if (udp2bio(s, conf->servers->rbios, cnt))
|
||||||
|
debug(DBG_DBG, "radudpget: got DTLS in UDP from %s", addr2string((struct sockaddr *)&from));
|
||||||
|
}
|
||||||
|
+ return NULL;
|
||||||
|
}
|
||||||
|
|
||||||
|
void *dtlsclientrd(void *arg) {
|
||||||
|
--- a/radsecproxy.c
|
||||||
|
+++ b/radsecproxy.c
|
||||||
|
@@ -3203,6 +3203,8 @@ void *sighandler(void *arg) {
|
||||||
|
debug(DBG_WARN, "sighandler: ignoring signal %d", sig);
|
||||||
|
}
|
||||||
|
}
|
||||||
|
+
|
||||||
|
+ return NULL;
|
||||||
|
}
|
||||||
|
|
||||||
|
int createpidfile(const char *pidfile) {
|
||||||
|
@@ -3289,6 +3291,8 @@ int radsecproxy_main(int argc, char **ar
|
||||||
|
/* just hang around doing nothing, anything to do here? */
|
||||||
|
for (;;)
|
||||||
|
sleep(1000);
|
||||||
|
+
|
||||||
|
+ return 0;
|
||||||
|
}
|
||||||
|
|
||||||
|
/* Local Variables: */
|
||||||
|
--- a/udp.c
|
||||||
|
+++ b/udp.c
|
||||||
|
@@ -266,6 +266,8 @@ void *udpclientrd(void *arg) {
|
||||||
|
buf = radudpget(*s, NULL, &server, NULL);
|
||||||
|
replyh(server, buf);
|
||||||
|
}
|
||||||
|
+
|
||||||
|
+ return NULL;
|
||||||
|
}
|
||||||
|
|
||||||
|
void *udpserverrd(void *arg) {
|
||||||
|
@@ -310,6 +312,8 @@ void *udpserverwr(void *arg) {
|
||||||
|
debug(DBG_DBG, "udpserverwr: refcount %d", reply->refcount);
|
||||||
|
freerq(reply);
|
||||||
|
}
|
||||||
|
+
|
||||||
|
+ return NULL;
|
||||||
|
}
|
||||||
|
|
||||||
|
void addclientudp(struct client *client) {
|
Loading…
x
Reference in New Issue
Block a user