[packages] tinyproxy: update to v1.6.5, set default timeout to 600 (closes: #5951), cleanup
git-svn-id: svn://svn.openwrt.org/openwrt/packages@17874 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
312c696dfd
commit
62b26ed020
@ -1,5 +1,5 @@
|
|||||||
#
|
#
|
||||||
# Copyright (C) 2006 OpenWrt.org
|
# Copyright (C) 2006-2009 OpenWrt.org
|
||||||
#
|
#
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
# See /LICENSE for more information.
|
# See /LICENSE for more information.
|
||||||
@ -8,18 +8,19 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=tinyproxy
|
PKG_NAME:=tinyproxy
|
||||||
PKG_VERSION:=1.6.4
|
PKG_VERSION:=1.6.5
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=http://www.banu.com/pub/tinyproxy/1.6/
|
PKG_SOURCE_URL:=http://www.banu.com/pub/tinyproxy/1.6/
|
||||||
PKG_MD5SUM:=3157b9159a8d005f4248cf4d4d6c65e2
|
PKG_MD5SUM:=2b2862ba33d2939e4572688d442ba415
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
define Package/tinyproxy
|
define Package/tinyproxy
|
||||||
SECTION:=net
|
SECTION:=net
|
||||||
CATEGORY:=Network
|
CATEGORY:=Network
|
||||||
|
SUBMENU:=Proxy Servers
|
||||||
TITLE:=Tinyproxy is a lightweight HTTP and HTTPS proxy.
|
TITLE:=Tinyproxy is a lightweight HTTP and HTTPS proxy.
|
||||||
URL:=http://tinyproxy.sourceforge.net/
|
URL:=http://tinyproxy.sourceforge.net/
|
||||||
endef
|
endef
|
||||||
@ -28,12 +29,9 @@ define Package/tinyproxy/conffiles
|
|||||||
/etc/config/tinyproxy
|
/etc/config/tinyproxy
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Build/Configure
|
CONFIGURE_ARGS+= \
|
||||||
$(call Build/Configure/Default,\
|
--enable-filter \
|
||||||
--enable-filter \
|
--enable-transparent-proxy \
|
||||||
--enable-transparent-proxy \
|
|
||||||
)
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Build/Compile
|
define Build/Compile
|
||||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||||
@ -47,7 +45,7 @@ define Package/tinyproxy/install
|
|||||||
$(INSTALL_DIR) $(1)/usr/share/tinyproxy
|
$(INSTALL_DIR) $(1)/usr/share/tinyproxy
|
||||||
$(CP) $(PKG_INSTALL_DIR)/usr/share/tinyproxy/*.html $(1)/usr/share/tinyproxy/
|
$(CP) $(PKG_INSTALL_DIR)/usr/share/tinyproxy/*.html $(1)/usr/share/tinyproxy/
|
||||||
$(INSTALL_DIR) $(1)/etc/config
|
$(INSTALL_DIR) $(1)/etc/config
|
||||||
$(CP) ./files/tinyproxy.config $(1)/etc/config/tinyproxy
|
$(INSTALL_CONF) ./files/tinyproxy.config $(1)/etc/config/tinyproxy
|
||||||
$(INSTALL_DIR) $(1)/etc/init.d
|
$(INSTALL_DIR) $(1)/etc/init.d
|
||||||
$(INSTALL_BIN) ./files/tinyproxy.init $(1)/etc/init.d/tinyproxy
|
$(INSTALL_BIN) ./files/tinyproxy.init $(1)/etc/init.d/tinyproxy
|
||||||
endef
|
endef
|
||||||
|
@ -33,7 +33,7 @@ option Port 8888
|
|||||||
# Timeout: The number of seconds of inactivity a connection is allowed to
|
# Timeout: The number of seconds of inactivity a connection is allowed to
|
||||||
# have before it closed by tinyproxy.
|
# have before it closed by tinyproxy.
|
||||||
#
|
#
|
||||||
#option Timeout 600
|
option Timeout 600
|
||||||
|
|
||||||
#
|
#
|
||||||
# ErrorFile: Defines the HTML file to send when a given HTTP error
|
# ErrorFile: Defines the HTML file to send when a given HTTP error
|
||||||
|
@ -1,7 +1,6 @@
|
|||||||
diff -urN tinyproxy-1.6.3/src/reqs.c tinyproxy-1.6.3.new/src/reqs.c
|
--- a/src/reqs.c
|
||||||
--- tinyproxy-1.6.3/src/reqs.c 2004-08-06 18:56:55.000000000 +0200
|
+++ b/src/reqs.c
|
||||||
+++ tinyproxy-1.6.3.new/src/reqs.c 2007-08-30 16:50:31.000000000 +0200
|
@@ -726,7 +726,7 @@ process_request(struct conn_s *connptr,
|
||||||
@@ -726,7 +726,7 @@
|
|
||||||
request->host);
|
request->host);
|
||||||
|
|
||||||
indicate_http_error(connptr, 403, "Filtered",
|
indicate_http_error(connptr, 403, "Filtered",
|
||||||
|
Loading…
x
Reference in New Issue
Block a user