dialog: fix configure test against ncurses

When building on x86_64 hosts, the configure script will try to add /lib64 from
the host to the linker command, which will usually result in failing the
ncurses library test, fix this by checking whether we are cross-compiling or
not.

Signed-off-by: Florian Fainelli <florian@openwrt.org>

git-svn-id: svn://svn.openwrt.org/openwrt/packages@39802 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
florian 2014-03-08 00:56:42 +00:00
parent 46c2e926d1
commit 632b8c1325
2 changed files with 13 additions and 2 deletions

View File

@ -1,5 +1,5 @@
#
# Copyright (C) 2006-2012 OpenWrt.org
# Copyright (C) 2006-2014 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=dialog
PKG_VERSION:=1.1-20120706
PKG_RELEASE:=1
PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
PKG_SOURCE_URL:=ftp://invisible-island.net/dialog

View File

@ -0,0 +1,11 @@
--- a/configure
+++ b/configure
@@ -11827,7 +11827,7 @@ linux*)
if test -d /lib64
then
-if test -n "/lib64" ; then
+if test -n "/lib64" -a test $cross_compiling = "no"; then
for cf_add_libdir in /lib64
do
if test $cf_add_libdir = /usr/lib ; then