[package] update mtr to 0.75 (#5400)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@16553 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
0dd1f7bcf7
commit
633e9f9455
@ -8,12 +8,12 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=mtr
|
||||
PKG_VERSION:=0.73
|
||||
PKG_VERSION:=0.75
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=ftp://ftp.bitwizard.nl/mtr/
|
||||
PKG_MD5SUM:=52223cc34c72092a0392865356a3dc76
|
||||
PKG_MD5SUM:=23baca52d0922c2ecba7eba05317868c
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
@ -53,13 +53,13 @@ define Build/Configure
|
||||
)
|
||||
endef
|
||||
|
||||
define Build/Compile
|
||||
define Build/Compile
|
||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||
DESTDIR="$(PKG_INSTALL_DIR)" \
|
||||
all install
|
||||
endef
|
||||
|
||||
define Package/mtr/install
|
||||
define Package/mtr/install
|
||||
$(INSTALL_DIR) $(1)/usr/sbin
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/mtr $(1)/usr/sbin/
|
||||
endef
|
||||
|
@ -1,19 +0,0 @@
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -6739,15 +6739,13 @@
|
||||
rm -f conf.gtktest
|
||||
|
||||
else
|
||||
- AM_PATH_GTK(1.0.0, CFLAGS="$CFLAGS $GTK_CFLAGS"
|
||||
- LIBS="$LIBS $GTK_LIBS",
|
||||
{ echo "$as_me:$LINENO: WARNING: Building without GTK+ display support" >&5
|
||||
echo "$as_me: WARNING: Building without GTK+ display support" >&2;}
|
||||
cat >>confdefs.h <<\_ACEOF
|
||||
#define NO_GTK 1
|
||||
_ACEOF
|
||||
|
||||
- GTK_OBJ="")
|
||||
+ GTK_OBJ=""
|
||||
fi
|
||||
else
|
||||
cat >>confdefs.h <<\_ACEOF
|
@ -1,54 +0,0 @@
|
||||
diff -urN mtr-0.73/split.c.rej mtr-0.73.new/split.c.rej
|
||||
--- mtr-0.73/split.c.rej 2006-11-18 12:04:44.000000000 +0100
|
||||
+++ mtr-0.73.new/split.c.rej 1970-01-01 01:00:00.000000000 +0100
|
||||
@@ -1,29 +0,0 @@
|
||||
-***************
|
||||
-*** 103,115 ****
|
||||
- name = dns_lookup(addr);
|
||||
- if(name != NULL) {
|
||||
- /* May be we should test name's length */
|
||||
-- sprintf(newLine, "%s %d %d %d %d %d %d", name,
|
||||
- net_loss(at),
|
||||
- net_returned(at), net_xmit(at),
|
||||
- net_best(at) /1000, net_avg(at)/1000,
|
||||
- net_worst(at)/1000);
|
||||
- } else {
|
||||
-- sprintf(newLine, "%s %d %d %d %d %d %d",
|
||||
- strlongip( addr ),
|
||||
- net_loss(at),
|
||||
- net_returned(at), net_xmit(at),
|
||||
---- 103,115 ----
|
||||
- name = dns_lookup(addr);
|
||||
- if(name != NULL) {
|
||||
- /* May be we should test name's length */
|
||||
-+ snprintf(newLine,sizeof(newLine), "%s %d %d %d %d %d %d", name,
|
||||
- net_loss(at),
|
||||
- net_returned(at), net_xmit(at),
|
||||
- net_best(at) /1000, net_avg(at)/1000,
|
||||
- net_worst(at)/1000);
|
||||
- } else {
|
||||
-+ snprintf(newLine,sizeof(newLine), "%s %d %d %d %d %d %d",
|
||||
- strlongip( addr ),
|
||||
- net_loss(at),
|
||||
- net_returned(at), net_xmit(at),
|
||||
diff -urN mtr-0.73/dns.c.rej mtr-0.73.new/dns.c.rej
|
||||
--- mtr-0.73/dns.c.rej 2006-06-14 07:00:56.000000000 +0200
|
||||
+++ mtr-0.73.new/dns.c.rej 1970-01-01 01:00:00.000000000 +0100
|
||||
@@ -1,17 +0,0 @@
|
||||
-***************
|
||||
-*** 1357,1363 ****
|
||||
- #ifdef ENABLE_IPV6
|
||||
- /* Returns an ip6.arpa character string. */
|
||||
- void addr2ip6arpa( ip_t * ip, char * buf ) {
|
||||
-- char * p = (char *) ip;
|
||||
- char * b = buf;
|
||||
- int i;
|
||||
-
|
||||
---- 1357,1363 ----
|
||||
- #ifdef ENABLE_IPV6
|
||||
- /* Returns an ip6.arpa character string. */
|
||||
- void addr2ip6arpa( ip_t * ip, char * buf ) {
|
||||
-+ unsigned char * p = (unsigned char *) ip;
|
||||
- char * b = buf;
|
||||
- int i;
|
||||
-
|
@ -1,6 +1,6 @@
|
||||
--- a/dns.c
|
||||
+++ b/dns.c
|
||||
@@ -859,6 +859,507 @@
|
||||
@@ -869,6 +869,507 @@ void restell(char *s)
|
||||
fputs("\r",stderr);
|
||||
}
|
||||
|
||||
|
Loading…
x
Reference in New Issue
Block a user