sound/mpd: update to mpd 0.16.8

updating to latest mpd requres more work on dependencies
(libmms,libaudiofile,libstdcpp)

- mpd isn't hosted on sourceforge anymore

- fix: #14422
Issue 1: could not replicate
Issue 2: update to last mpd 0.16 series fixes compile,
its linked to ffmpeg version

Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de>


git-svn-id: svn://svn.openwrt.org/openwrt/packages@39540 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
hauke 2014-02-08 18:04:03 +00:00
parent a3a96573b3
commit 63626f93cd
2 changed files with 9 additions and 13 deletions

View File

@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk include $(TOPDIR)/rules.mk
PKG_NAME:=mpd PKG_NAME:=mpd
PKG_VERSION:=0.16.5 PKG_VERSION:=0.16.8
PKG_RELEASE:=2 PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=@SF/musicpd PKG_SOURCE_URL:=http://www.musicpd.org/download/mpd/0.16/
PKG_MD5SUM:=f7564cff12035f6a1112cce770655df7 PKG_MD5SUM:=b412a9d0b3457bea1bb87904a8f80c04
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION) PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
PKG_BUILD_PARALLEL:=1 PKG_BUILD_PARALLEL:=1

View File

@ -1,8 +1,6 @@
Index: mpd-0.16.1/configure --- a/configure
=================================================================== +++ b/configure
--- mpd-0.16.1.orig/configure 2011-01-10 02:58:36.000000000 +0100 @@ -8803,6 +8803,7 @@ fi
+++ mpd-0.16.1/configure 2011-03-10 13:01:31.000000000 +0100
@@ -8718,6 +8718,7 @@
# Check whether --with-faad was given. # Check whether --with-faad was given.
if test "${with_faad+set}" = set; then : if test "${with_faad+set}" = set; then :
withval=$with_faad; withval=$with_faad;
@ -10,11 +8,9 @@ Index: mpd-0.16.1/configure
else else
faad_prefix="" faad_prefix=""
fi fi
Index: mpd-0.16.1/src/input/file_input_plugin.c --- a/src/input/file_input_plugin.c
=================================================================== +++ b/src/input/file_input_plugin.c
--- mpd-0.16.1.orig/src/input/file_input_plugin.c 2011-01-10 02:58:08.000000000 +0100 @@ -79,10 +79,6 @@ input_file_open(const char *filename, GE
+++ mpd-0.16.1/src/input/file_input_plugin.c 2011-03-10 13:02:15.000000000 +0100
@@ -79,10 +79,6 @@
return false; return false;
} }