[packages] cups: reenable libusb support, refresh patches (#11768)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@32519 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
a76cd44ea7
commit
6386ddbeda
@ -1,5 +1,5 @@
|
||||
#
|
||||
# Copyright (C) 2006-2011 OpenWrt.org
|
||||
# Copyright (C) 2006-2012 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=cups
|
||||
PKG_VERSION:=1.4.4
|
||||
PKG_RELEASE:=2
|
||||
PKG_RELEASE:=3
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-source.tar.bz2
|
||||
PKG_SOURCE_URL:= \
|
||||
@ -25,7 +25,7 @@ include $(INCLUDE_DIR)/package.mk
|
||||
define Package/cups
|
||||
SECTION:=net
|
||||
CATEGORY:=Network
|
||||
DEPENDS:=+zlib +libpthread +libpng +libjpeg +libstdcpp
|
||||
DEPENDS:=+zlib +libpthread +libpng +libjpeg +libstdcpp +libusb
|
||||
TITLE:=Common UNIX Printing System
|
||||
URL:=http://www.cups.org/
|
||||
endef
|
||||
@ -50,7 +50,7 @@ define Build/Configure
|
||||
--without-php \
|
||||
--enable-shared \
|
||||
--enable-image \
|
||||
--disable-libusb \
|
||||
--enable-libusb \
|
||||
--disable-dbus \
|
||||
--disable-dnssd \
|
||||
--disable-launchd \
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -19,8 +19,8 @@ include Makedefs
|
||||
@@ -20,8 +20,8 @@ include Makedefs
|
||||
# Directories to make...
|
||||
#
|
||||
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -1926,7 +1926,7 @@ ac_compiler_gnu=$ac_cv_c_compiler_gnu
|
||||
@@ -1966,7 +1966,7 @@ ac_compiler_gnu=$ac_cv_c_compiler_gnu
|
||||
|
||||
|
||||
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- a/cups-config.in
|
||||
+++ b/cups-config.in
|
||||
@@ -53,7 +53,7 @@ else
|
||||
@@ -54,7 +54,7 @@ else
|
||||
CFLAGS="$CFLAGS -I$includedir"
|
||||
fi
|
||||
|
||||
@ -33,7 +33,7 @@
|
||||
HP-UX*)
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -9254,7 +9254,7 @@ if test "$libdir" = "\${exec_prefix}/lib
|
||||
@@ -10003,7 +10003,7 @@ if test "$libdir" = "\${exec_prefix}/lib
|
||||
;;
|
||||
Linux*)
|
||||
if test -d /usr/lib64; then
|
||||
@ -42,7 +42,7 @@
|
||||
fi
|
||||
;;
|
||||
HP-UX*)
|
||||
@@ -9792,9 +9792,6 @@ case "$uname" in
|
||||
@@ -10626,9 +10626,6 @@ case "$uname" in
|
||||
LIB32CUPS="32bit/libcups.so.2"
|
||||
LIB32CUPSIMAGE="32bit/libcupsimage.so.2"
|
||||
LIB32DIR="$exec_prefix/lib"
|
||||
@ -52,7 +52,7 @@
|
||||
UNINSTALL32="uninstall32bit"
|
||||
fi
|
||||
|
||||
@@ -9804,9 +9801,6 @@ case "$uname" in
|
||||
@@ -10638,9 +10635,6 @@ case "$uname" in
|
||||
LIB64CUPS="64bit/libcups.so.2"
|
||||
LIB64CUPSIMAGE="64bit/libcupsimage.so.2"
|
||||
LIB64DIR="$exec_prefix/lib"
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- cups-1.4.2.orig/ppdc/Makefile 2010-01-28 18:06:41.000000000 +0100
|
||||
+++ cups-1.4.2/ppdc/Makefile 2010-01-28 20:25:09.000000000 +0100
|
||||
@@ -239,12 +239,7 @@
|
||||
--- a/ppdc/Makefile
|
||||
+++ b/ppdc/Makefile
|
||||
@@ -239,12 +239,7 @@ framedhelp:
|
||||
|
||||
genstrings: genstrings.o libcupsppdc.a ../cups/libcups.a \
|
||||
sample.drv ../data/media.defs
|
||||
|
Loading…
x
Reference in New Issue
Block a user