Add pure-ftpd (#1012)

git-svn-id: svn://svn.openwrt.org/openwrt/packages@5756 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
florian 2006-12-11 15:26:08 +00:00
parent 441a51ef84
commit 642a2b9486
3 changed files with 179 additions and 0 deletions

49
net/pure-ftpd/Makefile Normal file
View File

@ -0,0 +1,49 @@
#
# Copyright (C) 2006 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
include $(TOPDIR)/rules.mk
PKG_NAME:=pure-ftpd
PKG_VERSION:=1.0.21
PKG_RELEASE:=1
PKG_MD5SUM:=ca8a8dbec0cd9c8ea92fc4c37ea9c410
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
PKG_SOURCE_URL:=http://download.pureftpd.org/pub/pure-ftpd/releases/
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_CAT:=bzcat
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
include $(INCLUDE_DIR)/package.mk
define Package/pure-ftpd
SECTION:=net
CATEGORY:=Network
DEPENDS:=+libelf
TITLE:=Secure FTP made easy!
DESCRIPTION:=\
Pure-FTPd is a free (BSD), secure, production-quality and standard-conformant FTP server.\
It doesn't provide useless bells and whistles, but focuses on efficiency and ease of use.\
It provides simple answers to common needs, plus unique useful features for personal users\
as well as hosting providers.
URL:=http://www.pureftpd.org/project/pure-ftpd
endef
define Build/Configure
$(call Build/Configure/Default,--with-everything)
endef
define Package/pure-ftpd/install
$(INSTALL_DIR) $(1)/etc/init.d $(1)/usr/sbin
install -m0755 ./files/$(PKG_NAME).init $(1)/etc/init.d/$(PKG_NAME)
$(CP) $(PKG_BUILD_DIR)/src/pure-{ftpd,pw,ftpwho,mrtginfo,pwconvert,quotacheck,statsdecode,uploadscript,authd} $(1)/usr/sbin/
$(CP) $(PKG_BUILD_DIR)/src/ptracetest $(1)/usr/sbin/
endef
$(eval $(call BuildPackage,pure-ftpd))

View File

@ -0,0 +1,20 @@
#!/bin/sh /etc/rc.common
# Copyright (C) 2006 OpenWrt.org
BIN=pure-ftpd
DEFAULT=/etc/default/$BIN
LOG_D=/var/log/$BIN
RUN_D=/var/run
PID_F=$RUN_D/$BIN.pid
OPTIONS="-A -B -c 10 -C 4 -E -lunix -U 133:022 -g $PID_F -y 3:4"
[ -f $DEFAULT ] && . $DEFAULT
start() {
mkdir -p $LOG_D
mkdir -p $RUN_D
$BIN $OPTIONS
}
stop() {
[ -f $PID_F ] && kill $(cat $PID_F)
}

View File

@ -0,0 +1,110 @@
--- pure-ftpd-1.0.21/configure 2006-02-19 15:33:05.000000000 +0100
+++ pure-ftpd-1.0.21.new/configure 2006-12-11 16:07:29.000000000 +0100
@@ -9273,7 +9273,7 @@
if test "$cross_compiling" = yes; then
{ { echo "$as_me:$LINENO: error: internal error: not reached in cross-compile" >&5
echo "$as_me: error: internal error: not reached in cross-compile" >&2;}
- { (exit 1); exit 1; }; }
+ }
else
cat >conftest.$ac_ext <<_ACEOF
/* confdefs.h. */
@@ -9679,7 +9679,7 @@
if test "$cross_compiling" = yes; then
{ { echo "$as_me:$LINENO: error: internal error: not reached in cross-compile" >&5
echo "$as_me: error: internal error: not reached in cross-compile" >&2;}
- { (exit 1); exit 1; }; }
+ }
else
cat >conftest.$ac_ext <<_ACEOF
/* confdefs.h. */
@@ -10085,7 +10085,7 @@
if test "$cross_compiling" = yes; then
{ { echo "$as_me:$LINENO: error: internal error: not reached in cross-compile" >&5
echo "$as_me: error: internal error: not reached in cross-compile" >&2;}
- { (exit 1); exit 1; }; }
+ }
else
cat >conftest.$ac_ext <<_ACEOF
/* confdefs.h. */
@@ -10491,7 +10491,7 @@
if test "$cross_compiling" = yes; then
{ { echo "$as_me:$LINENO: error: internal error: not reached in cross-compile" >&5
echo "$as_me: error: internal error: not reached in cross-compile" >&2;}
- { (exit 1); exit 1; }; }
+ }
else
cat >conftest.$ac_ext <<_ACEOF
/* confdefs.h. */
@@ -10897,7 +10897,7 @@
if test "$cross_compiling" = yes; then
{ { echo "$as_me:$LINENO: error: internal error: not reached in cross-compile" >&5
echo "$as_me: error: internal error: not reached in cross-compile" >&2;}
- { (exit 1); exit 1; }; }
+ }
else
cat >conftest.$ac_ext <<_ACEOF
/* confdefs.h. */
@@ -21379,7 +21379,7 @@
See \`config.log' for more details." >&5
echo "$as_me: error: cannot run test program while cross compiling
See \`config.log' for more details." >&2;}
- { (exit 1); exit 1; }; }
+ }
else
cat >conftest.$ac_ext <<_ACEOF
/* confdefs.h. */
@@ -21453,7 +21453,7 @@
See \`config.log' for more details." >&5
echo "$as_me: error: cannot run test program while cross compiling
See \`config.log' for more details." >&2;}
- { (exit 1); exit 1; }; }
+ }
else
cat >conftest.$ac_ext <<_ACEOF
/* confdefs.h. */
@@ -21521,7 +21521,7 @@
See \`config.log' for more details." >&5
echo "$as_me: error: cannot run test program while cross compiling
See \`config.log' for more details." >&2;}
- { (exit 1); exit 1; }; }
+ }
else
cat >conftest.$ac_ext <<_ACEOF
/* confdefs.h. */
@@ -21627,7 +21627,7 @@
See \`config.log' for more details." >&5
echo "$as_me: error: cannot run test program while cross compiling
See \`config.log' for more details." >&2;}
- { (exit 1); exit 1; }; }
+ }
else
cat >conftest.$ac_ext <<_ACEOF
/* confdefs.h. */
@@ -21696,7 +21696,7 @@
See \`config.log' for more details." >&5
echo "$as_me: error: cannot run test program while cross compiling
See \`config.log' for more details." >&2;}
- { (exit 1); exit 1; }; }
+ }
else
cat >conftest.$ac_ext <<_ACEOF
/* confdefs.h. */
@@ -22483,7 +22483,7 @@
See \`config.log' for more details." >&5
echo "$as_me: error: cannot run test program while cross compiling
See \`config.log' for more details." >&2;}
- { (exit 1); exit 1; }; }
+ }
else
cat >conftest.$ac_ext <<_ACEOF
/* confdefs.h. */
@@ -22886,7 +22886,7 @@
See \`config.log' for more details." >&5
echo "$as_me: error: cannot run test program while cross compiling
See \`config.log' for more details." >&2;}
- { (exit 1); exit 1; }; }
+ }
else
cat >conftest.$ac_ext <<_ACEOF
/* confdefs.h. */