fix lcd4linux compile error

git-svn-id: svn://svn.openwrt.org/openwrt/packages@6672 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
nbd 2007-03-24 17:16:55 +00:00
parent f1ea4c9756
commit 6614125046
2 changed files with 27 additions and 10 deletions

View File

@ -36,8 +36,13 @@ endef
# commas are interpreted by the $(call ...) macro, so define an intermediate variable holding our drivers spec
PKG_CONFIGURE_DRIVERS:=all,!PNG,!RouterBoard,!X11
CONFIGURE_ARGS += \
--without-x \
--with-drivers="$(PKG_CONFIGURE_DRIVERS)" \
--with-plugins=wireless
define Build/Configure
(cd $(PKG_BUILD_DIR); touch \
(cd $(PKG_BUILD_DIR); touch \
configure.in \
aclocal.m4 \
Makefile.in \
@ -45,15 +50,7 @@ define Build/Configure
stamp-h.in \
config.h.in \
);
$(call Build/Configure/Default, \
--without-x \
--with-drivers="$(PKG_CONFIGURE_DRIVERS)" \
--with-plugins=wireless \
)
endef
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR)
$(call Build/Configure/Default)
endef
define Package/lcd4linux/install

View File

@ -13,3 +13,23 @@ diff -urN lcd4linux.old/drv_generic_parport.c lcd4linux.dev/drv_generic_parport.
#if !defined(WITH_OUTB) && !defined(WITH_PPDEV)
#error neither outb() nor ppdev() possible
#error cannot compile parallel port driver
diff -ur lcd4linux.old/drv_generic_parport.c lcd4linux.dev/drv_generic_parport.c
--- lcd4linux.old/drv_generic_parport.c 2007-03-24 18:14:55.706590000 +0100
+++ lcd4linux.dev/drv_generic_parport.c 2007-03-24 18:15:20.036891568 +0100
@@ -117,16 +117,6 @@
#include <sys/stat.h>
#include <sys/ioctl.h>
-#ifdef HAVE_SYS_IO_H
-#include <sys/io.h>
-#define WITH_OUTB
-#else
-#ifdef HAVE_ASM_IO_H
-#include <asm/io.h>
-#define WITH_OUTB
-#endif
-#endif
-
#if defined (HAVE_LINUX_PARPORT_H) && defined (HAVE_LINUX_PPDEV_H)
#define WITH_PPDEV
#include <linux/parport.h>