[packages] libs/zaptel-1.4: Fix compilation on 64-bit hosts and clean up makefile

git-svn-id: svn://svn.openwrt.org/openwrt/packages@12796 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
agb 2008-09-29 03:38:01 +00:00
parent cbee4e0946
commit 66640bbb7e
2 changed files with 33 additions and 15 deletions

View File

@ -62,30 +62,34 @@ define Package/zaptel14-libtonezone/description
This package contains the libraries for accessing zaptel/dummy drivers. This package contains the libraries for accessing zaptel/dummy drivers.
endef endef
define Build/Compile/zaptel14 define Build/Compile/zaptel14-template
$(MAKE) -C $(PKG_BUILD_DIR) \ $(MAKE) -C $(PKG_BUILD_DIR) \
DESTDIR="$(PKG_INSTALL_DIR)" \ DESTDIR="$(PKG_INSTALL_DIR)" \
ARCH="$(LINUX_KARCH)" \ ARCH="$(LINUX_KARCH)" \
CC=$(KERNEL_CC) \ LD="$(TARGET_CROSS)ld" \
LD=$(TARGET_CROSS)ld \ AR="$(TARGET_CROSS)ar" \
HOSTCC=$(HOSTCC) \ HOSTCC="$(HOSTCC)" \
KVERS=$(LINUX_VERSION) \ DEB_HOST_GNU_TYPE="$(ARCH)" \
KSRC=$(LINUX_DIR) \ KVERS="$(LINUX_VERSION)" \
KSRC="$(LINUX_DIR)" \
$(1)
endef
define Build/Compile/zaptel14
$(call Build/Compile/zaptel14-template, \
CC="$(KERNEL_CC)" \
KFLAGS_PPC="-G 0 -mno-abicalls -fno-pic -pipe -finline-limit=100000 -mabi=32 $(TARGET_CFLAGS) -mlong-calls -fno-common -nostdinc -iwithprefix include" \ KFLAGS_PPC="-G 0 -mno-abicalls -fno-pic -pipe -finline-limit=100000 -mabi=32 $(TARGET_CFLAGS) -mlong-calls -fno-common -nostdinc -iwithprefix include" \
TOPDIR_MODULES="zaptel ztdummy" \ TOPDIR_MODULES="zaptel ztdummy" \
SUBDIR_MODULES="" \ SUBDIR_MODULES="" \
modules zttest modules zttest \
)
endef endef
define Build/Compile/zaptel14-libtonezone define Build/Compile/zaptel14-libtonezone
$(MAKE) -C $(PKG_BUILD_DIR) \ $(call Build/Compile/zaptel14-template, \
DESTDIR="$(PKG_INSTALL_DIR)" \ CC="$(TARGET_CC)" \
CC=$(TARGET_CC) \ install-libs install-include \
LD=$(TARGET_CROSS)ld \ )
AR=$(TARGET_CROSS)ar \
KSRC=$(LINUX_DIR) \
HOSTCC=$(HOSTCC) \
install-libs install-include
endef endef
define Build/Compile define Build/Compile

View File

@ -0,0 +1,14 @@
Index: zaptel-1.4.9.2/Makefile
===================================================================
--- zaptel-1.4.9.2.orig/Makefile 2008-08-15 01:42:26.000000000 -0700
+++ zaptel-1.4.9.2/Makefile 2008-08-15 01:42:43.000000000 -0700
@@ -18,7 +18,9 @@
PWD:=$(shell pwd)
endif
+ifndef ARCH
ARCH:=$(shell uname -m | sed -e s/i.86/i386/)
+endif
ifeq ($(DEB_HOST_GNU_TYPE),)
UNAME_M:=$(shell uname -m)