[packages] libtheora: avoid libSDL build dependency by removing call to AM_PATH_SDL in configure.ac

git-svn-id: svn://svn.openwrt.org/openwrt/packages@24875 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
jow 2011-01-02 00:22:32 +00:00
parent 10b7e46d88
commit 67b2564ce9

View File

@ -1,7 +1,6 @@
diff -ruN libtheora-1.0.orig/Makefile.am libtheora-1.0/Makefile.am
--- libtheora-1.0.orig/Makefile.am 2009-02-23 19:49:49.000000000 +0100
+++ libtheora-1.0/Makefile.am 2009-02-23 20:17:23.000000000 +0100
@@ -8,7 +8,7 @@
--- a/Makefile.am
+++ b/Makefile.am
@@ -8,7 +8,7 @@ else
EXAMPLES_DIR =
endif
@ -10,10 +9,9 @@ diff -ruN libtheora-1.0.orig/Makefile.am libtheora-1.0/Makefile.am
# we include the whole debian/ dir in EXTRA_DIST because there's a problem
diff -ruN libtheora-1.0.orig/Makefile.in libtheora-1.0/Makefile.in
--- libtheora-1.0.orig/Makefile.in 2009-02-23 19:49:49.000000000 +0100
+++ libtheora-1.0/Makefile.in 2009-02-23 20:17:14.000000000 +0100
@@ -80,7 +80,7 @@
--- a/Makefile.in
+++ b/Makefile.in
@@ -80,7 +80,7 @@ pkgconfigDATA_INSTALL = $(INSTALL_DATA)
DATA = $(pkgconfig_DATA)
ETAGS = etags
CTAGS = ctags
@ -22,7 +20,7 @@ diff -ruN libtheora-1.0.orig/Makefile.in libtheora-1.0/Makefile.in
DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
distdir = $(PACKAGE)-$(VERSION)
top_distdir = $(distdir)
@@ -262,7 +262,7 @@
@@ -262,7 +262,7 @@ target_vendor = @target_vendor@
AUTOMAKE_OPTIONS = foreign 1.6 dist-zip dist-bzip2
@THEORA_ENABLE_EXAMPLES_FALSE@EXAMPLES_DIR =
@THEORA_ENABLE_EXAMPLES_TRUE@EXAMPLES_DIR = examples
@ -31,3 +29,17 @@ diff -ruN libtheora-1.0.orig/Makefile.in libtheora-1.0/Makefile.in
# we include the whole debian/ dir in EXTRA_DIST because there's a problem
# with autotools and HFS+ MacOSX file systems that caused debian/Makefile.am
--- a/configure.ac
+++ b/configure.ac
@@ -310,11 +310,6 @@ fi
dnl check for SDL
HAVE_SDL=no
-AM_PATH_SDL(,[
- HAVE_SDL=yes
- SDL_LIBS=`$SDL_CONFIG --libs`
-],AC_MSG_WARN([*** Unable to find SDL -- Not compiling example players ***]))
-
dnl check for OSS
HAVE_OSS=no