remove ov51x-jpeg, it is obsolete
git-svn-id: svn://svn.openwrt.org/openwrt/packages@31795 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
db69f53c3a
commit
681992c475
@ -1,75 +0,0 @@
|
|||||||
#
|
|
||||||
# Copyright (C) 2007-2008 OpenWrt.org
|
|
||||||
#
|
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
|
||||||
# See /LICENSE for more information.
|
|
||||||
#
|
|
||||||
|
|
||||||
include $(TOPDIR)/rules.mk
|
|
||||||
include $(INCLUDE_DIR)/kernel.mk
|
|
||||||
|
|
||||||
PKG_NAME:=ov51x-jpeg
|
|
||||||
PKG_VERSION:=1.5.9
|
|
||||||
PKG_RELEASE:=1
|
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
|
||||||
PKG_SOURCE_URL:=http://www.rastageeks.org/downloads/ov51x-jpeg/ \
|
|
||||||
http://www.rastageeks.org/downloads/ov51x-jpeg/old-releases/
|
|
||||||
PKG_MD5SUM:=95041de8e908f1548df3d4e1f6ed2a94
|
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
|
||||||
|
|
||||||
define Package/ov51x-jpeg/Default
|
|
||||||
URL:=http://www.rastageeks.org/ov51x-jpeg/
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/ov51x-jpeg-utils
|
|
||||||
$(call Package/ov51x-jpeg/Default)
|
|
||||||
SECTION:=utils
|
|
||||||
CATEGORY:=Utilities
|
|
||||||
TITLE:=OV51x based USB webcam utilities
|
|
||||||
DEPENDS:=+kmod-video-ov51x-jpeg
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/ov51x-jpeg-utils/description
|
|
||||||
Utility programs for the video-ov51x kernel module
|
|
||||||
endef
|
|
||||||
|
|
||||||
define KernelPackage/video-ov51x-jpeg
|
|
||||||
$(call Package/ov51x-jpeg/Default)
|
|
||||||
SUBMENU:=Video Support
|
|
||||||
TITLE:=OV51x based USB webcam support (JPEG)
|
|
||||||
DEPENDS:=@LINUX_2_6_25||LINUX_2_6_27||LINUX_2_6_28 @USB_SUPPORT +kmod-usb-core +kmod-video-core
|
|
||||||
FILES:=$(PKG_BUILD_DIR)/ov51x-jpeg.$(LINUX_KMOD_SUFFIX)
|
|
||||||
AUTOLOAD:=$(call AutoLoad,70,ov51x-jpeg)
|
|
||||||
endef
|
|
||||||
|
|
||||||
define KernelPackage/video-ov51x-jpeg/description
|
|
||||||
Kernel module for OV51x based USB cameras, with in-driver JPEG support.
|
|
||||||
endef
|
|
||||||
|
|
||||||
ifneq ($(CONFIG_PACKAGE_kmod-video-ov51x-jpeg),)
|
|
||||||
define Build/Compile/kmod
|
|
||||||
$(MAKE) -C $(LINUX_DIR) \
|
|
||||||
ARCH="$(LINUX_KARCH)" \
|
|
||||||
CROSS_COMPILE="$(TARGET_CROSS)" \
|
|
||||||
SUBDIRS="$(PKG_BUILD_DIR)" \
|
|
||||||
modules
|
|
||||||
endef
|
|
||||||
endif
|
|
||||||
|
|
||||||
define Build/Compile
|
|
||||||
$(call Build/Compile/kmod)
|
|
||||||
$(MAKE) -C $(PKG_BUILD_DIR)/test \
|
|
||||||
CFLAGS="$(TARGET_CFLAGS)" \
|
|
||||||
CC="$(TARGET_CC)" \
|
|
||||||
getjpeg
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/ov51x-jpeg-utils/install
|
|
||||||
$(INSTALL_DIR) $(1)/usr/bin
|
|
||||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/test/getjpeg $(1)/usr/bin/
|
|
||||||
endef
|
|
||||||
|
|
||||||
$(eval $(call BuildPackage,ov51x-jpeg-utils))
|
|
||||||
$(eval $(call KernelPackage,video-ov51x-jpeg))
|
|
@ -1,20 +0,0 @@
|
|||||||
--- a/ov51x-jpeg-core.c
|
|
||||||
+++ b/ov51x-jpeg-core.c
|
|
||||||
@@ -753,7 +753,7 @@
|
|
||||||
* -claudio
|
|
||||||
*/
|
|
||||||
|
|
||||||
- ov51x_jpeg_proc_entry = create_proc_entry("ov51x-jpeg", S_IFDIR, &proc_root);
|
|
||||||
+ ov51x_jpeg_proc_entry = create_proc_entry("ov51x-jpeg", S_IFDIR, NULL);
|
|
||||||
if (ov51x_jpeg_proc_entry)
|
|
||||||
ov51x_jpeg_proc_entry->owner = THIS_MODULE;
|
|
||||||
else
|
|
||||||
@@ -771,7 +771,7 @@
|
|
||||||
|
|
||||||
/* Destroy proc entry */
|
|
||||||
PDEBUG(4, "destroying /proc/ov51x-jpeg");
|
|
||||||
- remove_proc_entry("ov51x-jpeg", &proc_root);
|
|
||||||
+ remove_proc_entry("ov51x-jpeg", NULL);
|
|
||||||
ov51x_jpeg_proc_entry = NULL;
|
|
||||||
|
|
||||||
}
|
|
Loading…
x
Reference in New Issue
Block a user