[package] unbreak iptables-snmp compilation (#5549)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@17090 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
ff84dddecb
commit
68f8e91686
@ -20,7 +20,7 @@ include $(INCLUDE_DIR)/package.mk
|
|||||||
define Package/iptables-snmp
|
define Package/iptables-snmp
|
||||||
SECTION:=net
|
SECTION:=net
|
||||||
CATEGORY:=Network
|
CATEGORY:=Network
|
||||||
DEPENDS:=+snmpd @BROKEN
|
DEPENDS:=+snmpd +libiptc
|
||||||
TITLE:=An snmpd plugin to access iptables rules
|
TITLE:=An snmpd plugin to access iptables rules
|
||||||
URL:=http://www.nobiscuit.com/iptables-snmp/
|
URL:=http://www.nobiscuit.com/iptables-snmp/
|
||||||
SUBMENU:=firewall
|
SUBMENU:=firewall
|
||||||
@ -33,6 +33,7 @@ endef
|
|||||||
define Build/Compile
|
define Build/Compile
|
||||||
$(call Build/Compile/Default, \
|
$(call Build/Compile/Default, \
|
||||||
INSTALL_PREFIX="$(PKG_INSTALL_DIR)" \
|
INSTALL_PREFIX="$(PKG_INSTALL_DIR)" \
|
||||||
|
LDFLAGS="$(TARGET_LDFLAGS)" \
|
||||||
all install \
|
all install \
|
||||||
)
|
)
|
||||||
endef
|
endef
|
||||||
|
25
net/iptables-snmp/patches/001-use_libiptc.patch
Normal file
25
net/iptables-snmp/patches/001-use_libiptc.patch
Normal file
@ -0,0 +1,25 @@
|
|||||||
|
diff -urN iptables-snmp-0.1/Makefile.in iptables-snmp-0.1.new/Makefile.in
|
||||||
|
--- iptables-snmp-0.1/Makefile.in 2005-11-02 13:00:10.000000000 +0100
|
||||||
|
+++ iptables-snmp-0.1.new/Makefile.in 2009-08-02 01:13:40.000000000 +0200
|
||||||
|
@@ -67,7 +67,7 @@
|
||||||
|
|
||||||
|
all: iptables-snmp.so
|
||||||
|
|
||||||
|
-iptables-snmp.so: $(OBJS) libiptc.a Makefile
|
||||||
|
+iptables-snmp.so: $(OBJS) Makefile
|
||||||
|
$(CC) $(CFLAGS) $(OTHER) $(DFLAGS) -shared -o $@ $(OBJS) $(LDFLAGS)
|
||||||
|
|
||||||
|
libiptc.a: $(LIBIPTC_OBJS) Makefile
|
||||||
|
diff -urN iptables-snmp-0.1/iptables-snmp.c iptables-snmp-0.1.new/iptables-snmp.c
|
||||||
|
--- iptables-snmp-0.1/iptables-snmp.c 2005-11-02 12:10:54.000000000 +0100
|
||||||
|
+++ iptables-snmp-0.1.new/iptables-snmp.c 2009-08-02 01:13:30.000000000 +0200
|
||||||
|
@@ -37,6 +37,9 @@
|
||||||
|
|
||||||
|
#include "libiptc/libiptc.h"
|
||||||
|
|
||||||
|
+/* For backward compatibility */
|
||||||
|
+typedef struct iptc_handle *iptc_handle_t;
|
||||||
|
+
|
||||||
|
static oid agent_version_oid[] = {
|
||||||
|
BASE_OID, 1, 0, AGENT_VERSION_INDEX
|
||||||
|
};
|
Loading…
x
Reference in New Issue
Block a user