upgrade git package
git-svn-id: svn://svn.openwrt.org/openwrt/packages@26688 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
c1b01ab41a
commit
696d4becec
@ -4,19 +4,19 @@
|
|||||||
# This is free software, licensed under the GNU General Public License v2.
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
# See /LICENSE for more information.
|
# See /LICENSE for more information.
|
||||||
#
|
#
|
||||||
# Alessandro Di Marco <dmr-wrt@ethzero.com>
|
|
||||||
|
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=git
|
PKG_NAME:=git
|
||||||
PKG_VERSION:=1.7.3.4
|
PKG_VERSION:=1.7.4.4
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||||
PKG_SOURCE_URL:=@KERNEL/software/scm/git
|
PKG_SOURCE_URL:=@KERNEL/software/scm/git
|
||||||
PKG_MD5SUM:=3a2602016f98c529cda7b9fad1a6e216
|
PKG_MD5SUM:=1313f71d62fa100b32fa313769a85f2a
|
||||||
|
|
||||||
PKG_INSTALL:=1
|
PKG_INSTALL:=1
|
||||||
|
PKG_BUILD_PARALLEL:=1
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
@ -27,6 +27,7 @@ define Package/git
|
|||||||
DEPENDS:=+libopenssl +libpthread
|
DEPENDS:=+libopenssl +libpthread
|
||||||
TITLE:=The fast version control system
|
TITLE:=The fast version control system
|
||||||
URL:=http://git-scm.com
|
URL:=http://git-scm.com
|
||||||
|
MAINTAINER:=Luka Perkov <openwrt@lukaperkov.net>
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Package/git/description
|
define Package/git/description
|
||||||
@ -55,9 +56,8 @@ define Build/Configure
|
|||||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||||
configure
|
configure
|
||||||
|
|
||||||
(cd $(PKG_BUILD_DIR); \
|
( cd $(PKG_BUILD_DIR); \
|
||||||
./configure \
|
./configure --prefix=/usr \
|
||||||
--prefix=/usr \
|
|
||||||
);
|
);
|
||||||
endef
|
endef
|
||||||
|
|
||||||
|
@ -1,30 +1,44 @@
|
|||||||
--- /dev/null
|
Index: git-1.7.4.4/builtin/daemon.c
|
||||||
+++ b/builtin/daemon.c
|
===================================================================
|
||||||
|
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
|
||||||
|
+++ git-1.7.4.4/builtin/daemon.c 2011-04-08 15:33:59.605465617 +0200
|
||||||
@@ -0,0 +1 @@
|
@@ -0,0 +1 @@
|
||||||
+#include "../daemon.c"
|
+#include "../daemon.c"
|
||||||
--- /dev/null
|
Index: git-1.7.4.4/builtin/fast-import.c
|
||||||
+++ b/builtin/fast-import.c
|
===================================================================
|
||||||
|
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
|
||||||
|
+++ git-1.7.4.4/builtin/fast-import.c 2011-04-08 15:33:59.605465617 +0200
|
||||||
@@ -0,0 +1 @@
|
@@ -0,0 +1 @@
|
||||||
+#include "../fast-import.c"
|
+#include "../fast-import.c"
|
||||||
--- /dev/null
|
Index: git-1.7.4.4/builtin/http-backend.c
|
||||||
+++ b/builtin/http-backend.c
|
===================================================================
|
||||||
|
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
|
||||||
|
+++ git-1.7.4.4/builtin/http-backend.c 2011-04-08 15:33:59.605465617 +0200
|
||||||
@@ -0,0 +1 @@
|
@@ -0,0 +1 @@
|
||||||
+#include "../http-backend.c"
|
+#include "../http-backend.c"
|
||||||
--- /dev/null
|
Index: git-1.7.4.4/builtin/imap-send.c
|
||||||
+++ b/builtin/imap-send.c
|
===================================================================
|
||||||
|
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
|
||||||
|
+++ git-1.7.4.4/builtin/imap-send.c 2011-04-08 15:33:59.605465617 +0200
|
||||||
@@ -0,0 +1 @@
|
@@ -0,0 +1 @@
|
||||||
+#include "../imap-send.c"
|
+#include "../imap-send.c"
|
||||||
--- /dev/null
|
Index: git-1.7.4.4/builtin/shell.c
|
||||||
+++ b/builtin/shell.c
|
===================================================================
|
||||||
|
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
|
||||||
|
+++ git-1.7.4.4/builtin/shell.c 2011-04-08 15:33:59.605465617 +0200
|
||||||
@@ -0,0 +1 @@
|
@@ -0,0 +1 @@
|
||||||
+#include "../shell.c"
|
+#include "../shell.c"
|
||||||
--- /dev/null
|
Index: git-1.7.4.4/builtin/upload-pack.c
|
||||||
+++ b/builtin/upload-pack.c
|
===================================================================
|
||||||
|
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
|
||||||
|
+++ git-1.7.4.4/builtin/upload-pack.c 2011-04-08 15:33:59.605465617 +0200
|
||||||
@@ -0,0 +1 @@
|
@@ -0,0 +1 @@
|
||||||
+#include "../upload-pack.c"
|
+#include "../upload-pack.c"
|
||||||
--- a/builtin.h
|
Index: git-1.7.4.4/builtin.h
|
||||||
+++ b/builtin.h
|
===================================================================
|
||||||
@@ -139,5 +139,11 @@ extern int cmd_verify_pack(int argc, con
|
--- git-1.7.4.4/builtin.h 2011-04-03 10:22:36.000000000 +0200
|
||||||
|
+++ git-1.7.4.4/builtin.h 2011-04-08 15:33:59.605465617 +0200
|
||||||
|
@@ -142,5 +142,11 @@
|
||||||
extern int cmd_show_ref(int argc, const char **argv, const char *prefix);
|
extern int cmd_show_ref(int argc, const char **argv, const char *prefix);
|
||||||
extern int cmd_pack_refs(int argc, const char **argv, const char *prefix);
|
extern int cmd_pack_refs(int argc, const char **argv, const char *prefix);
|
||||||
extern int cmd_replace(int argc, const char **argv, const char *prefix);
|
extern int cmd_replace(int argc, const char **argv, const char *prefix);
|
||||||
@ -36,20 +50,24 @@
|
|||||||
+extern int cmd_fast_import(int argc, const char **argv, const char *prefix);
|
+extern int cmd_fast_import(int argc, const char **argv, const char *prefix);
|
||||||
|
|
||||||
#endif
|
#endif
|
||||||
--- a/daemon.c
|
Index: git-1.7.4.4/daemon.c
|
||||||
+++ b/daemon.c
|
===================================================================
|
||||||
@@ -963,7 +963,7 @@ static int serve(char *listen_addr, int
|
--- git-1.7.4.4/daemon.c 2011-04-03 10:22:36.000000000 +0200
|
||||||
return service_loop(socknum, socklist);
|
+++ git-1.7.4.4/daemon.c 2011-04-08 15:33:59.605465617 +0200
|
||||||
|
@@ -1043,7 +1043,7 @@
|
||||||
|
return service_loop(&socklist);
|
||||||
}
|
}
|
||||||
|
|
||||||
-int main(int argc, char **argv)
|
-int main(int argc, char **argv)
|
||||||
+int cmd_daemon(int argc, char **argv, const char *prefix)
|
+int cmd_daemon(int argc, char **argv, const char *prefix)
|
||||||
{
|
{
|
||||||
int listen_port = 0;
|
int listen_port = 0;
|
||||||
char *listen_addr = NULL;
|
struct string_list listen_addr = STRING_LIST_INIT_NODUP;
|
||||||
--- a/fast-import.c
|
Index: git-1.7.4.4/fast-import.c
|
||||||
+++ b/fast-import.c
|
===================================================================
|
||||||
@@ -2912,7 +2912,7 @@ static void parse_argv(void)
|
--- git-1.7.4.4/fast-import.c 2011-04-03 10:22:36.000000000 +0200
|
||||||
|
+++ git-1.7.4.4/fast-import.c 2011-04-08 15:33:59.609465154 +0200
|
||||||
|
@@ -3083,7 +3083,7 @@
|
||||||
read_marks();
|
read_marks();
|
||||||
}
|
}
|
||||||
|
|
||||||
@ -58,9 +76,11 @@
|
|||||||
{
|
{
|
||||||
unsigned int i;
|
unsigned int i;
|
||||||
|
|
||||||
--- a/git.c
|
Index: git-1.7.4.4/git.c
|
||||||
+++ b/git.c
|
===================================================================
|
||||||
@@ -240,11 +240,11 @@ const char git_version_string[] = GIT_VE
|
--- git-1.7.4.4/git.c 2011-04-03 10:22:36.000000000 +0200
|
||||||
|
+++ git-1.7.4.4/git.c 2011-04-08 15:33:59.609465154 +0200
|
||||||
|
@@ -251,11 +251,11 @@
|
||||||
|
|
||||||
struct cmd_struct {
|
struct cmd_struct {
|
||||||
const char *cmd;
|
const char *cmd;
|
||||||
@ -74,7 +94,7 @@
|
|||||||
{
|
{
|
||||||
int status, help;
|
int status, help;
|
||||||
struct stat st;
|
struct stat st;
|
||||||
@@ -293,7 +293,7 @@ static int run_builtin(struct cmd_struct
|
@@ -308,7 +308,7 @@
|
||||||
return 0;
|
return 0;
|
||||||
}
|
}
|
||||||
|
|
||||||
@ -83,7 +103,7 @@
|
|||||||
{
|
{
|
||||||
const char *cmd = argv[0];
|
const char *cmd = argv[0];
|
||||||
static struct cmd_struct commands[] = {
|
static struct cmd_struct commands[] = {
|
||||||
@@ -405,6 +405,12 @@ static void handle_internal_command(int
|
@@ -422,6 +422,12 @@
|
||||||
{ "verify-pack", cmd_verify_pack },
|
{ "verify-pack", cmd_verify_pack },
|
||||||
{ "show-ref", cmd_show_ref, RUN_SETUP },
|
{ "show-ref", cmd_show_ref, RUN_SETUP },
|
||||||
{ "pack-refs", cmd_pack_refs, RUN_SETUP },
|
{ "pack-refs", cmd_pack_refs, RUN_SETUP },
|
||||||
@ -96,9 +116,11 @@
|
|||||||
};
|
};
|
||||||
int i;
|
int i;
|
||||||
static const char ext[] = STRIP_EXTENSION;
|
static const char ext[] = STRIP_EXTENSION;
|
||||||
--- a/http-backend.c
|
Index: git-1.7.4.4/http-backend.c
|
||||||
+++ b/http-backend.c
|
===================================================================
|
||||||
@@ -540,7 +540,7 @@ static struct service_cmd {
|
--- git-1.7.4.4/http-backend.c 2011-04-03 10:22:36.000000000 +0200
|
||||||
|
+++ git-1.7.4.4/http-backend.c 2011-04-08 15:33:59.609465154 +0200
|
||||||
|
@@ -540,7 +540,7 @@
|
||||||
{"POST", "/git-receive-pack$", service_rpc}
|
{"POST", "/git-receive-pack$", service_rpc}
|
||||||
};
|
};
|
||||||
|
|
||||||
@ -107,9 +129,11 @@
|
|||||||
{
|
{
|
||||||
char *method = getenv("REQUEST_METHOD");
|
char *method = getenv("REQUEST_METHOD");
|
||||||
char *dir;
|
char *dir;
|
||||||
--- a/imap-send.c
|
Index: git-1.7.4.4/imap-send.c
|
||||||
+++ b/imap-send.c
|
===================================================================
|
||||||
@@ -1528,7 +1528,7 @@ static int git_imap_config(const char *k
|
--- git-1.7.4.4/imap-send.c 2011-04-03 10:22:36.000000000 +0200
|
||||||
|
+++ git-1.7.4.4/imap-send.c 2011-04-08 15:33:59.609465154 +0200
|
||||||
|
@@ -1528,7 +1528,7 @@
|
||||||
return 0;
|
return 0;
|
||||||
}
|
}
|
||||||
|
|
||||||
@ -118,12 +142,15 @@
|
|||||||
{
|
{
|
||||||
struct msg_data all_msgs, msg;
|
struct msg_data all_msgs, msg;
|
||||||
struct store *ctx = NULL;
|
struct store *ctx = NULL;
|
||||||
--- a/Makefile
|
Index: git-1.7.4.4/Makefile
|
||||||
+++ b/Makefile
|
===================================================================
|
||||||
@@ -398,12 +398,7 @@ EXTRA_PROGRAMS =
|
--- git-1.7.4.4/Makefile 2011-04-03 10:22:36.000000000 +0200
|
||||||
|
+++ git-1.7.4.4/Makefile 2011-04-08 15:38:21.489032460 +0200
|
||||||
|
@@ -406,13 +406,7 @@
|
||||||
# ... and all the rest that could be moved out of bindir to gitexecdir
|
# ... and all the rest that could be moved out of bindir to gitexecdir
|
||||||
PROGRAMS += $(EXTRA_PROGRAMS)
|
PROGRAMS += $(EXTRA_PROGRAMS)
|
||||||
|
|
||||||
|
-PROGRAM_OBJS += daemon.o
|
||||||
-PROGRAM_OBJS += fast-import.o
|
-PROGRAM_OBJS += fast-import.o
|
||||||
-PROGRAM_OBJS += imap-send.o
|
-PROGRAM_OBJS += imap-send.o
|
||||||
-PROGRAM_OBJS += shell.o
|
-PROGRAM_OBJS += shell.o
|
||||||
@ -133,7 +160,7 @@
|
|||||||
|
|
||||||
PROGRAMS += $(patsubst %.o,git-%$X,$(PROGRAM_OBJS))
|
PROGRAMS += $(patsubst %.o,git-%$X,$(PROGRAM_OBJS))
|
||||||
|
|
||||||
@@ -750,6 +745,12 @@ BUILTIN_OBJS += builtin/var.o
|
@@ -769,6 +763,12 @@
|
||||||
BUILTIN_OBJS += builtin/verify-pack.o
|
BUILTIN_OBJS += builtin/verify-pack.o
|
||||||
BUILTIN_OBJS += builtin/verify-tag.o
|
BUILTIN_OBJS += builtin/verify-tag.o
|
||||||
BUILTIN_OBJS += builtin/write-tree.o
|
BUILTIN_OBJS += builtin/write-tree.o
|
||||||
@ -146,19 +173,16 @@
|
|||||||
|
|
||||||
GITLIBS = $(LIB_FILE) $(XDIFF_LIB)
|
GITLIBS = $(LIB_FILE) $(XDIFF_LIB)
|
||||||
EXTLIBS =
|
EXTLIBS =
|
||||||
@@ -1244,10 +1245,9 @@ endif
|
@@ -1293,7 +1293,7 @@
|
||||||
EXTLIBS += -lz
|
EXTLIBS += -lz
|
||||||
|
|
||||||
ifndef NO_POSIX_ONLY_PROGRAMS
|
|
||||||
- PROGRAM_OBJS += daemon.o
|
|
||||||
endif
|
|
||||||
ifndef NO_OPENSSL
|
ifndef NO_OPENSSL
|
||||||
- OPENSSL_LIBSSL = -lssl
|
- OPENSSL_LIBSSL = -lssl
|
||||||
+ EXTLIBS += -lssl
|
+ EXTLIBS += -lssl
|
||||||
ifdef OPENSSLDIR
|
ifdef OPENSSLDIR
|
||||||
BASIC_CFLAGS += -I$(OPENSSLDIR)/include
|
BASIC_CFLAGS += -I$(OPENSSLDIR)/include
|
||||||
OPENSSL_LINK = -L$(OPENSSLDIR)/$(lib) $(CC_LD_DYNPATH)$(OPENSSLDIR)/$(lib)
|
OPENSSL_LINK = -L$(OPENSSLDIR)/$(lib) $(CC_LD_DYNPATH)$(OPENSSLDIR)/$(lib)
|
||||||
@@ -1923,10 +1923,6 @@ endif
|
@@ -2003,10 +2003,6 @@
|
||||||
git-%$X: %.o $(GITLIBS)
|
git-%$X: %.o $(GITLIBS)
|
||||||
$(QUIET_LINK)$(CC) $(ALL_CFLAGS) -o $@ $(ALL_LDFLAGS) $(filter %.o,$^) $(LIBS)
|
$(QUIET_LINK)$(CC) $(ALL_CFLAGS) -o $@ $(ALL_LDFLAGS) $(filter %.o,$^) $(LIBS)
|
||||||
|
|
||||||
@ -169,7 +193,7 @@
|
|||||||
git-http-fetch$X: revision.o http.o http-walker.o http-fetch.o $(GITLIBS)
|
git-http-fetch$X: revision.o http.o http-walker.o http-fetch.o $(GITLIBS)
|
||||||
$(QUIET_LINK)$(CC) $(ALL_CFLAGS) -o $@ $(ALL_LDFLAGS) $(filter %.o,$^) \
|
$(QUIET_LINK)$(CC) $(ALL_CFLAGS) -o $@ $(ALL_LDFLAGS) $(filter %.o,$^) \
|
||||||
$(LIBS) $(CURL_LIBCURL)
|
$(LIBS) $(CURL_LIBCURL)
|
||||||
@@ -2124,23 +2120,22 @@ endif
|
@@ -2204,23 +2200,22 @@
|
||||||
|
|
||||||
bindir=$$(cd '$(DESTDIR_SQ)$(bindir_SQ)' && pwd) && \
|
bindir=$$(cd '$(DESTDIR_SQ)$(bindir_SQ)' && pwd) && \
|
||||||
execdir=$$(cd '$(DESTDIR_SQ)$(gitexec_instdir_SQ)' && pwd) && \
|
execdir=$$(cd '$(DESTDIR_SQ)$(gitexec_instdir_SQ)' && pwd) && \
|
||||||
@ -196,9 +220,11 @@
|
|||||||
ln -s "git$X" "$$execdir/$$p" 2>/dev/null || \
|
ln -s "git$X" "$$execdir/$$p" 2>/dev/null || \
|
||||||
cp "$$execdir/git$X" "$$execdir/$$p" || exit; \
|
cp "$$execdir/git$X" "$$execdir/$$p" || exit; \
|
||||||
done && \
|
done && \
|
||||||
--- a/shell.c
|
Index: git-1.7.4.4/shell.c
|
||||||
+++ b/shell.c
|
===================================================================
|
||||||
@@ -45,7 +45,7 @@ static struct commands {
|
--- git-1.7.4.4/shell.c 2011-04-03 10:22:36.000000000 +0200
|
||||||
|
+++ git-1.7.4.4/shell.c 2011-04-08 15:33:59.613464996 +0200
|
||||||
|
@@ -129,7 +129,7 @@
|
||||||
{ NULL },
|
{ NULL },
|
||||||
};
|
};
|
||||||
|
|
||||||
@ -206,10 +232,12 @@
|
|||||||
+int cmd_shell(int argc, char **argv, const char *prefix)
|
+int cmd_shell(int argc, char **argv, const char *prefix)
|
||||||
{
|
{
|
||||||
char *prog;
|
char *prog;
|
||||||
struct commands *cmd;
|
const char **user_argv;
|
||||||
--- a/upload-pack.c
|
Index: git-1.7.4.4/upload-pack.c
|
||||||
+++ b/upload-pack.c
|
===================================================================
|
||||||
@@ -676,7 +676,7 @@ static void upload_pack(void)
|
--- git-1.7.4.4/upload-pack.c 2011-04-03 10:22:36.000000000 +0200
|
||||||
|
+++ git-1.7.4.4/upload-pack.c 2011-04-08 15:33:59.613464996 +0200
|
||||||
|
@@ -676,7 +676,7 @@
|
||||||
}
|
}
|
||||||
}
|
}
|
||||||
|
|
||||||
|
Loading…
x
Reference in New Issue
Block a user