Port weechat to -ng, and upgrade it to 0.2.0, closes #740
git-svn-id: svn://svn.openwrt.org/openwrt/packages@4799 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
e1d0b95797
commit
6a717fe247
65
net/weechat/Makefile
Normal file
65
net/weechat/Makefile
Normal file
@ -0,0 +1,65 @@
|
||||
#
|
||||
# Copyright (C) 2006 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
# $Id: $
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=weechat
|
||||
PKG_VERSION:=0.2.0
|
||||
PKG_RELEASE:=1
|
||||
PKG_MD5SUM:=69c292237bebd4b7a1ff29c0f9c76380
|
||||
|
||||
PKG_SOURCE_URL:=http://weechat.flashtux.org/download/
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_CAT:=bzcat
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/weechat
|
||||
SECTION:=net
|
||||
CATEGORY:=Network
|
||||
DEPENDS:=+libncurses +liblua +gnutls +libiconv
|
||||
TITLE:=Lightweight IRC client
|
||||
DESCRIPTION:=Fast, light & extensible IRC client\\\
|
||||
URL:=http://weechat.flashtux.org
|
||||
endef
|
||||
|
||||
define Build/Configure
|
||||
(cd $(PKG_BUILD_DIR); \
|
||||
$(TARGET_CONFIGURE_OPTS) \
|
||||
CFLAGS="$(TARGET_CFLAGS)" \
|
||||
CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
|
||||
LDFLAGS="-L$(STAGING_DIR)/usr/lib -liconv" \
|
||||
./configure \
|
||||
--target=$(GNU_TARGET_NAME) \
|
||||
--host=$(GNU_TARGET_NAME) \
|
||||
--build=$(GNU_HOST_NAME) \
|
||||
--prefix=/usr \
|
||||
--sysconfdir=/etc \
|
||||
--disable-nls \
|
||||
--with-libgnutls-prefix=$(STAGING_DIR)/usr \
|
||||
--with-debug=0 \
|
||||
--disable-perl \
|
||||
--disable-python \
|
||||
--disable-ruby \
|
||||
);
|
||||
endef
|
||||
|
||||
define Build/Compile
|
||||
$(call Build/Compile/Default,DESTDIR="$(PKG_INSTALL_DIR)" \
|
||||
all install)
|
||||
endef
|
||||
|
||||
define Package/weechat/install
|
||||
install -d -m0755 $(1)/usr/bin
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/bin/weechat-curses $(1)/usr/bin
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,weechat))
|
31
net/weechat/patches/01-cross_compiling.patch
Normal file
31
net/weechat/patches/01-cross_compiling.patch
Normal file
@ -0,0 +1,31 @@
|
||||
diff -urN weechat-0.2.0/configure weechat-0.2.0.new/configure
|
||||
--- weechat-0.2.0/configure 2006-08-19 13:22:12.000000000 +0200
|
||||
+++ weechat-0.2.0.new/configure 2006-09-17 13:51:42.000000000 +0200
|
||||
@@ -29801,8 +29801,7 @@
|
||||
{ { echo "$as_me:$LINENO: error: cannot run test program while cross compiling
|
||||
See \`config.log' for more details." >&5
|
||||
echo "$as_me: error: cannot run test program while cross compiling
|
||||
-See \`config.log' for more details." >&2;}
|
||||
- { (exit 1); exit 1; }; }
|
||||
+See \`config.log' for more details." >&2;} }
|
||||
else
|
||||
cat >conftest.$ac_ext <<_ACEOF
|
||||
/* confdefs.h. */
|
||||
@@ -29859,7 +29858,6 @@
|
||||
echo "${ECHO_T}yes" >&6; }
|
||||
fi
|
||||
fi
|
||||
-
|
||||
if test "x$iconv_found" = "xno" ; then
|
||||
{ { echo "$as_me:$LINENO: error:
|
||||
*** Iconv headers and/or libraries couldn't be found in your system.
|
||||
@@ -29868,8 +29866,7 @@
|
||||
echo "$as_me: error:
|
||||
*** Iconv headers and/or libraries couldn't be found in your system.
|
||||
*** Try to install them with your software package manager.
|
||||
-*** WeeChat can't be built without Iconv support." >&2;}
|
||||
- { (exit 1); exit 1; }; }
|
||||
+*** WeeChat can't be built without Iconv support." >&2;} }
|
||||
fi
|
||||
|
||||
# ------------------------------------------------------------------------------
|
Loading…
x
Reference in New Issue
Block a user