[packages] tinyproxy: update to 1.8.1

git-svn-id: svn://svn.openwrt.org/openwrt/packages@21018 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
nico 2010-04-19 05:44:20 +00:00
parent d1902ac136
commit 6a8c97a99c
3 changed files with 12 additions and 21 deletions

View File

@ -8,22 +8,22 @@
include $(TOPDIR)/rules.mk include $(TOPDIR)/rules.mk
PKG_NAME:=tinyproxy PKG_NAME:=tinyproxy
PKG_VERSION:=1.8.0 PKG_VERSION:=1.8.1
PKG_RELEASE:=1 PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.banu.com/pub/tinyproxy/1.8/ PKG_SOURCE_URL:=http://www.banu.com/pub/tinyproxy/1.8/
PKG_MD5SUM:=09843d47828261394d0a30af0b058997 PKG_MD5SUM:=e1f0977592f020ef509262c24c3284fb
PKG_INSTALL:=1 PKG_INSTALL:=1
include $(INCLUDE_DIR)/package.mk include $(INCLUDE_DIR)/package.mk
define Package/tinyproxy define Package/tinyproxy
SUBMENU:=Proxy Servers
SECTION:=net SECTION:=net
CATEGORY:=Network CATEGORY:=Network
SUBMENU:=Proxy Servers TITLE:=Tinyproxy is a lightweight HTTP and HTTPS proxy
TITLE:=Tinyproxy is a lightweight HTTP and HTTPS proxy.
URL:=http://tinyproxy.sourceforge.net/ URL:=http://tinyproxy.sourceforge.net/
endef endef
@ -31,17 +31,14 @@ define Package/tinyproxy/conffiles
/etc/config/tinyproxy /etc/config/tinyproxy
endef endef
define Build/Configure CONFIGURE_ARGS+= \
$(call Build/Configure/Default, \ --enable-filter \
--enable-filter \ --enable-transparent \
--enable-transparent \ --disable-regexcheck \
--enable-regexcheck=no \
)
endef
define Package/tinyproxy/install define Package/tinyproxy/install
$(INSTALL_DIR) $(1)/usr/sbin $(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/tinyproxy $(1)/usr/sbin/ $(CP) $(PKG_INSTALL_DIR)/usr/sbin/tinyproxy $(1)/usr/sbin/
$(INSTALL_DIR) $(1)/usr/share/tinyproxy $(INSTALL_DIR) $(1)/usr/share/tinyproxy
$(CP) $(PKG_INSTALL_DIR)/usr/share/tinyproxy/*.html $(1)/usr/share/tinyproxy/ $(CP) $(PKG_INSTALL_DIR)/usr/share/tinyproxy/*.html $(1)/usr/share/tinyproxy/
$(INSTALL_DIR) $(1)/etc/config $(INSTALL_DIR) $(1)/etc/config

View File

@ -1,5 +1,3 @@
diff --git a/Makefile.am b/Makefile.am
index 7de41f2..9d1f99b 100644
--- a/Makefile.am --- a/Makefile.am
+++ b/Makefile.am +++ b/Makefile.am
@@ -2,9 +2,7 @@ SUBDIRS = \ @@ -2,9 +2,7 @@ SUBDIRS = \
@ -12,8 +10,6 @@ index 7de41f2..9d1f99b 100644
# tools want this on a single line # tools want this on a single line
ACLOCAL_AMFLAGS = -I m4macros ACLOCAL_AMFLAGS = -I m4macros
diff --git a/Makefile.in b/Makefile.in
index d0ec918..5be49d4 100644
--- a/Makefile.in --- a/Makefile.in
+++ b/Makefile.in +++ b/Makefile.in
@@ -221,9 +221,7 @@ SUBDIRS = \ @@ -221,9 +221,7 @@ SUBDIRS = \
@ -26,11 +22,9 @@ index d0ec918..5be49d4 100644
# tools want this on a single line # tools want this on a single line
diff --git a/configure b/configure
index 01d6883..facfadd 100755
--- a/configure --- a/configure
+++ b/configure +++ b/configure
@@ -9012,67 +9012,8 @@ $as_echo "$as_me: error: Your system's regexec() function is broken." >&2;} @@ -9012,67 +9012,8 @@ $as_echo "$as_me: error: Your system's r
fi fi

View File

@ -10,7 +10,7 @@
{ {
struct addrinfo hints, *res, *ressave; struct addrinfo hints, *res, *ressave;
@@ -48,7 +47,7 @@ bind_socket (int sockfd, const char *addr, int family) @@ -48,7 +47,7 @@ bind_socket (int sockfd, const char *add
assert (addr != NULL && strlen (addr) != 0); assert (addr != NULL && strlen (addr) != 0);
memset (&hints, 0, sizeof (struct addrinfo)); memset (&hints, 0, sizeof (struct addrinfo));
@ -19,7 +19,7 @@
hints.ai_socktype = SOCK_STREAM; hints.ai_socktype = SOCK_STREAM;
/* The local port it not important */ /* The local port it not important */
@@ -106,14 +105,12 @@ int opensock (const char *host, int port, const char *bind_to) @@ -106,14 +105,12 @@ int opensock (const char *host, int port
/* Bind to the specified address */ /* Bind to the specified address */
if (bind_to) { if (bind_to) {