update radiusclient-ng to 0.5.6 (closes: #3589), fix package descriptions and formatting
git-svn-id: svn://svn.openwrt.org/openwrt/packages@11997 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
ab1fce523f
commit
6b56cd6da6
@ -1,5 +1,5 @@
|
|||||||
#
|
#
|
||||||
# Copyright (C) 2006 OpenWrt.org
|
# Copyright (C) 2006-2008 OpenWrt.org
|
||||||
#
|
#
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
# See /LICENSE for more information.
|
# See /LICENSE for more information.
|
||||||
@ -9,15 +9,12 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=radiusclient-ng
|
PKG_NAME:=radiusclient-ng
|
||||||
PKG_VERSION:=0.5.2
|
PKG_VERSION:=0.5.6
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=http://download.berlios.de/radiusclient-ng/
|
PKG_SOURCE_URL:=http://download.berlios.de/radiusclient-ng/
|
||||||
PKG_MD5SUM:=c54eb70e964bdd22dd44b39a9b4df8ca
|
PKG_MD5SUM:=6fb7d4d0aefafaee7385831ac46a8e9c
|
||||||
|
|
||||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
|
||||||
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
|
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
@ -25,19 +22,22 @@ define Package/radiusclient-ng/Default
|
|||||||
URL:=http://developer.berlios.de/projects/radiusclient-ng/
|
URL:=http://developer.berlios.de/projects/radiusclient-ng/
|
||||||
endef
|
endef
|
||||||
|
|
||||||
|
define Package/radiusclient-ng/Default/description
|
||||||
|
Purpose of this project is to build a portable, easy-to-use and
|
||||||
|
standard compliant library suitable for developing free and commercial
|
||||||
|
software that need support for RADIUS protocol (RFCs 2128 and 2139).
|
||||||
|
endef
|
||||||
|
|
||||||
define Package/libradiusclient-ng
|
define Package/libradiusclient-ng
|
||||||
$(call Package/radiusclient-ng/Default)
|
$(call Package/radiusclient-ng/Default)
|
||||||
SECTION:=libs
|
SECTION:=libs
|
||||||
CATEGORY:=Libraries
|
CATEGORY:=Libraries
|
||||||
TITLE:=RADIUS client library
|
TITLE:=RADIUS client library
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Package/libradiusclient-ng/description
|
define Package/libradiusclient-ng/description
|
||||||
=
|
$(call Package/radiusclient-ng/Default/description)
|
||||||
Purpose of this project is to build a portable, easy-to-use and standard
|
This package contains shared libraries, needed by other programs.
|
||||||
compliant library suitable for developing free and commercial software
|
|
||||||
that need support for RADIUS protocol (RFCs 2128 and 2139).
|
|
||||||
This package contains shared libraries, needed by other programs.
|
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Package/libradiusclient-ng/conffiles
|
define Package/libradiusclient-ng/conffiles
|
||||||
@ -56,19 +56,13 @@ define Package/radiusclient-ng
|
|||||||
endef
|
endef
|
||||||
|
|
||||||
define Package/radiusclient-ng/description
|
define Package/radiusclient-ng/description
|
||||||
=
|
$(call Package/radiusclient-ng/Default/description)
|
||||||
Purpose of this project is to build a portable, easy-to-use and standard
|
This package contains a RADIUS client.
|
||||||
compliant library suitable for developing free and commercial software
|
|
||||||
that need support for RADIUS protocol (RFCs 2128 and 2139).
|
|
||||||
This package contains a RADIUS client.
|
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Build/Configure
|
CONFIGURE_ARGS += \
|
||||||
$(call Build/Configure/Default, \
|
--enable-shared \
|
||||||
--enable-shared \
|
--enable-static \
|
||||||
--enable-static \
|
|
||||||
)
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Build/Compile
|
define Build/Compile
|
||||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||||
|
@ -1,7 +1,6 @@
|
|||||||
diff -urN radiusclient-ng-0.5.2/configure radiusclient-ng-0.5.2.new/configure
|
--- radiusclient-ng-0.5.6.orig/configure
|
||||||
--- radiusclient-ng-0.5.2/configure 2005-11-07 22:18:59.000000000 +0100
|
+++ radiusclient-ng-0.5.6/configure
|
||||||
+++ radiusclient-ng-0.5.2.new/configure 2006-03-10 01:51:59.489383320 +0100
|
@@ -23332,8 +23332,7 @@
|
||||||
@@ -23791,8 +23791,7 @@
|
|
||||||
{ { echo "$as_me:$LINENO: error: cannot run test program while cross compiling
|
{ { echo "$as_me:$LINENO: error: cannot run test program while cross compiling
|
||||||
See \`config.log' for more details." >&5
|
See \`config.log' for more details." >&5
|
||||||
echo "$as_me: error: cannot run test program while cross compiling
|
echo "$as_me: error: cannot run test program while cross compiling
|
||||||
@ -11,19 +10,3 @@ diff -urN radiusclient-ng-0.5.2/configure radiusclient-ng-0.5.2.new/configure
|
|||||||
else
|
else
|
||||||
cat >conftest.$ac_ext <<_ACEOF
|
cat >conftest.$ac_ext <<_ACEOF
|
||||||
/* confdefs.h. */
|
/* confdefs.h. */
|
||||||
diff -urN radiusclient-ng-0.5.2/etc/Makefile.in radiusclient-ng-0.5.2.new/etc/Makefile.in
|
|
||||||
--- radiusclient-ng-0.5.2/etc/Makefile.in 2005-11-08 00:15:35.000000000 +0100
|
|
||||||
+++ radiusclient-ng-0.5.2.new/etc/Makefile.in 2006-03-10 01:58:29.345116240 +0100
|
|
||||||
@@ -376,9 +376,9 @@
|
|
||||||
<$(srcdir)/radiusclient.conf.in >radiusclient.conf
|
|
||||||
|
|
||||||
install-data-local: servers
|
|
||||||
- $(mkinstalldirs) $(pkgsysconfdir); \
|
|
||||||
- echo " $(INSTALL) -m 600 $(srcdir)/servers $(pkgsysconfdir)/servers"; \
|
|
||||||
- $(INSTALL) -m 600 $(srcdir)/servers $(pkgsysconfdir)/servers
|
|
||||||
+ $(mkinstalldirs) $(DESTDIR)/$(pkgsysconfdir); \
|
|
||||||
+ echo " $(INSTALL) -m 600 $(srcdir)/servers $(DESTDIR)/$(pkgsysconfdir)/servers"; \
|
|
||||||
+ $(INSTALL) -m 600 $(srcdir)/servers $(DESTDIR)/$(pkgsysconfdir)/servers
|
|
||||||
|
|
||||||
uninstall-local:
|
|
||||||
rm -f $(pkgsysconfdir)/servers
|
|
||||||
|
Loading…
x
Reference in New Issue
Block a user