[package] update libdnet to 1.11 (#5390)

git-svn-id: svn://svn.openwrt.org/openwrt/packages@16529 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
florian 2009-06-21 11:19:59 +00:00
parent 5ab4392511
commit 6b946d0933
4 changed files with 34 additions and 30 deletions

View File

@ -8,39 +8,44 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=libdnet
PKG_VERSION:=1.10
PKG_RELEASE:=2
PKG_VERSION:=1.11
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SF/$(PKG_NAME)
PKG_MD5SUM:=416b765e9d9961501ac85e9a366fd219
PKG_MD5SUM:=04c394ed8e1e7fc455456e79e908916d
PKG_FIXUP:=libtool
include $(INCLUDE_DIR)/package.mk
define Package/libdnet
define Package/libdnet/Default
SECTION:=libs
CATEGORY:=Libraries
TITLE:=Low-level network library
URL:=http://sourceforge.net/projects/libdnet/
endef
define Package/libdnet/Default/description
libdnet is a library of simplified, portable interface to several
low-level networking routines.
endef
define Package/libdnet
$(call Package/libdnet/Default)
endef
define Package/libdnet/description
libdnet is a library of simplified, portable interface to several
low-level networking routines.
$(call Package/libdnet/Default/description)
endef
define Package/pydnet
SECTION:=libs
$(call Package/libdnet/Default)
DEPENDS:=libdnet +python-mini
CATEGORY:=Libraries
TITLE:=Low-level network library
URL:=http://sourceforge.net/projects/libdnet/
endef
define Package/pydnet/description
libdnet is a library of simplified, portable interface to several
low-level networking routines.
$(call Package/libdnet/Default/description)
This package contains the python dnet library.
endef
TARGET_CFLAGS += $(FPIC)

View File

@ -1,6 +1,6 @@
--- libdnet-1.10/dnet-config.in.orig 2001-10-19 03:29:00.000000000 +0200
+++ libdnet-1.10/dnet-config.in 2005-09-20 09:32:53.000000000 +0200
@@ -45,10 +45,18 @@
--- a/dnet-config.in
+++ b/dnet-config.in
@@ -45,10 +45,18 @@ while test $# -gt 0; do
done
if test "$echo_cflags" = "yes"; then

View File

@ -1,18 +1,18 @@
--- libdnet-1.10/config/config.sub.orig 2008-05-15 22:14:42.000000000 -0500
+++ libdnet-1.10/config/config.sub 2008-05-15 22:15:16.000000000 -0500
@@ -228,7 +228,7 @@
--- a/config/config.sub
+++ b/config/config.sub
@@ -228,7 +228,7 @@ case $basic_machine in
| a29k \
| alpha | alphaev[4-8] | alphaev56 | alphaev6[78] | alphapca5[67] \
| alpha64 | alpha64ev[4-8] | alpha64ev56 | alpha64ev6[78] | alpha64pca5[67] \
- | arc | arm | arm[bl]e | arme[lb] | armv[2345] | armv[345][lb] | avr \
+ | arc | arm | arm[bl]e | arme[lb] | armv[2345] | armv[345][lb] | avr | avr32 \
| c4x | clipper \
| d10v | d30v | dsp16xx \
| fr30 \
@@ -282,7 +282,7 @@
| d10v | d30v | dlx | dsp16xx \
| fr30 | frv \
@@ -290,7 +290,7 @@ case $basic_machine in
| alpha64-* | alpha64ev[4-8]-* | alpha64ev56-* | alpha64ev6[78]-* \
| alphapca5[67]-* | alpha64pca5[67]-* | arc-* \
| arm-* | armbe-* | armle-* | armv*-* \
| arm-* | armbe-* | armle-* | armeb-* | armv*-* \
- | avr-* \
+ | avr-* | avr32-* \
| bs2000-* \

View File

@ -1,21 +1,20 @@
diff --exclude='*~' --exclude='.*' -I '$Id:' -urN libdnet-1.10.orig/python/dnet.c libdnet-1.10/python/dnet.c
--- libdnet-1.10.orig/python/dnet.c 2005-05-16 14:47:35.000000000 -0400
+++ libdnet-1.10/python/dnet.c 2005-05-16 14:52:54.000000000 -0400
@@ -2552,7 +2552,7 @@
--- a/python/dnet.c
+++ b/python/dnet.c
@@ -2726,7 +2726,7 @@ static PyObject *__pyx_f_4dnet_15__addr_
PyObject *__pyx_3 = 0;
unsigned short __pyx_4;
Py_INCREF(__pyx_v_self);
- ((PyObject*)__pyx_v_next) = Py_None; Py_INCREF(((PyObject*)__pyx_v_next));
+ __pyx_v_next = Py_None; Py_INCREF(((PyObject*)__pyx_v_next));
/* "/misc/projects/libdnet/python/./dnet.pyx":628 */
/* "/Users/dugsong/projects/libdnet/python/./dnet.pyx":634 */
__pyx_1 = (((struct __pyx_obj_4dnet___addr_ip4_iter *)__pyx_v_self)->cur <= ((struct __pyx_obj_4dnet___addr_ip4_iter *)__pyx_v_self)->max);
@@ -2564,7 +2564,7 @@
@@ -2738,7 +2738,7 @@ static PyObject *__pyx_f_4dnet_15__addr_
Py_DECREF(__pyx_2); __pyx_2 = 0;
if (!__Pyx_TypeTest(__pyx_3, __pyx_ptype_4dnet_addr)) {__pyx_filename = __pyx_f[0]; __pyx_lineno = 629; goto __pyx_L1;}
if (!__Pyx_TypeTest(__pyx_3, __pyx_ptype_4dnet_addr)) {__pyx_filename = __pyx_f[0]; __pyx_lineno = 635; goto __pyx_L1;}
Py_DECREF(((PyObject *)__pyx_v_next));
- ((PyObject *)__pyx_v_next) = __pyx_3;
+ __pyx_v_next = __pyx_3;
__pyx_3 = 0;
/* "/misc/projects/libdnet/python/./dnet.pyx":630 */
/* "/Users/dugsong/projects/libdnet/python/./dnet.pyx":636 */