[packages] transmission: update to 2.00b2, prevent linking host libevent
git-svn-id: svn://svn.openwrt.org/openwrt/packages@21670 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
94fbef71e0
commit
6be4cdc889
@ -8,12 +8,12 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=transmission
|
||||
PKG_VERSION:=2.00b1
|
||||
PKG_VERSION:=2.00b2
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=http://mirrors.m0k.org/transmission/files
|
||||
PKG_MD5SUM:=43540a46a4eeac88e53a67573feca21a
|
||||
PKG_MD5SUM:=db1dd960d92bdc62d61dedeb1d3e3873
|
||||
|
||||
PKG_FIXUP:=libtool
|
||||
PKG_INSTALL:=1
|
||||
@ -65,14 +65,15 @@ define Package/transmission-daemon/conffiles
|
||||
/etc/config/transmission
|
||||
endef
|
||||
|
||||
CONFIGURE_VARS += \
|
||||
LIBEVENT_LIBS="$(STAGING_DIR)/usr/lib/libevent.so"
|
||||
|
||||
CONFIGURE_ARGS += \
|
||||
--enable-daemon \
|
||||
--disable-gtk \
|
||||
--disable-wx \
|
||||
--with-wx-config="$(STAGING_DIR)/usr/bin/" \
|
||||
--disable-gtk
|
||||
|
||||
MAKE_FLAGS += \
|
||||
CFLAGS="$(TARGET_CFLAGS)" \
|
||||
CFLAGS="$(TARGET_CFLAGS)"
|
||||
|
||||
define Package/transmission-daemon/install
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
|
@ -1,17 +0,0 @@
|
||||
--- transmission/libtransmission/tr-lpd.c.orig 2010-05-23 03:49:23.000000000 +0200
|
||||
+++ transmission/libtransmission/tr-lpd.c 2010-05-25 19:44:03.000000000 +0200
|
||||
@@ -439,12 +439,13 @@
|
||||
|
||||
char hashString[lengthof( t->info.hashString )];
|
||||
char query[lpd_maxDatagramLength + 1] = { };
|
||||
+ size_t i;
|
||||
|
||||
if( t == NULL )
|
||||
return FALSE;
|
||||
|
||||
/* make sure the hash string is normalized, just in case */
|
||||
- for( size_t i = 0; i < sizeof hashString; i++ )
|
||||
+ for( i = 0; i < sizeof hashString; i++ )
|
||||
hashString[i] = toupper( t->info.hashString[i] );
|
||||
|
||||
/* prepare a zero-terminated announce message */
|
Loading…
x
Reference in New Issue
Block a user