upgrade libtorrent and rtorrent
git-svn-id: svn://svn.openwrt.org/openwrt/packages@26652 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
bb67d4a921
commit
6c1fba9db9
@ -1,5 +1,5 @@
|
||||
#
|
||||
# Copyright (C) 2007-2010 OpenWrt.org
|
||||
# Copyright (C) 2007-2011 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
@ -8,9 +8,9 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=libtorrent
|
||||
PKG_REV:=1189
|
||||
PKG_REV:=1209
|
||||
PKG_VERSION:=0.12.6_r$(PKG_REV)
|
||||
PKG_RELEASE:=3
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=svn://rakshasa.no/libtorrent/trunk/libtorrent
|
||||
@ -29,6 +29,7 @@ define Package/libtorrent
|
||||
TITLE:=Rakshasa's BitTorrent library
|
||||
URL:=http://libtorrent.rakshasa.no/
|
||||
DEPENDS:=+libopenssl +libsigcxx @!LINUX_2_4
|
||||
MAINTAINER:=Luka Perkov <openwrt@lukaperkov.net>
|
||||
endef
|
||||
|
||||
define Package/libtorrent/description
|
||||
@ -39,14 +40,9 @@ define Package/libtorrent/description
|
||||
the speed of the official client.
|
||||
endef
|
||||
|
||||
ifneq ($(CONFIG_GCC_VERSION_3_4)$(CONFIG_GCC_VERSION_4_1),)
|
||||
TARGET_CPPFLAGS += -fno-strict-aliasing
|
||||
endif
|
||||
|
||||
TARGET_CPPFLAGS += -fno-inline
|
||||
TARGET_CPPFLAGS += -fno-strict-aliasing -fno-inline
|
||||
TARGET_LDFLAGS += $(LIBGCC_S)
|
||||
|
||||
# XXX: rtorrent needs encryption (--enable-openssl)
|
||||
CONFIGURE_ARGS+= \
|
||||
--enable-shared \
|
||||
--enable-static \
|
||||
|
@ -1,5 +1,7 @@
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
Index: libtorrent-0.12.6_r1209/configure.ac
|
||||
===================================================================
|
||||
--- libtorrent-0.12.6_r1209.orig/configure.ac 2011-03-27 12:23:16.000000000 +0200
|
||||
+++ libtorrent-0.12.6_r1209/configure.ac 2011-04-13 16:33:17.487339738 +0200
|
||||
@@ -17,7 +17,6 @@
|
||||
|
||||
AM_INIT_AUTOMAKE
|
||||
@ -8,14 +10,16 @@
|
||||
AC_DISABLE_STATIC
|
||||
|
||||
AM_DISABLE_STATIC
|
||||
@@ -117,5 +116,4 @@
|
||||
@@ -118,5 +117,4 @@
|
||||
src/protocol/Makefile
|
||||
src/tracker/Makefile
|
||||
src/utils/Makefile
|
||||
- test/Makefile
|
||||
])
|
||||
--- a/Makefile.am
|
||||
+++ b/Makefile.am
|
||||
Index: libtorrent-0.12.6_r1209/Makefile.am
|
||||
===================================================================
|
||||
--- libtorrent-0.12.6_r1209.orig/Makefile.am 2010-03-01 20:04:58.000000000 +0100
|
||||
+++ libtorrent-0.12.6_r1209/Makefile.am 2011-04-13 16:33:17.487339738 +0200
|
||||
@@ -1,4 +1,4 @@
|
||||
-SUBDIRS = src test
|
||||
+SUBDIRS = src
|
||||
|
@ -1,6 +1,8 @@
|
||||
--- a/rak/allocators.h
|
||||
+++ b/rak/allocators.h
|
||||
@@ -74,17 +74,13 @@ public:
|
||||
Index: libtorrent-0.12.6_r1209/rak/allocators.h
|
||||
===================================================================
|
||||
--- libtorrent-0.12.6_r1209.orig/rak/allocators.h 2010-11-10 12:40:28.000000000 +0100
|
||||
+++ libtorrent-0.12.6_r1209/rak/allocators.h 2011-04-13 16:33:28.179339669 +0200
|
||||
@@ -74,17 +74,13 @@
|
||||
size_type max_size () const throw() { return std::numeric_limits<size_t>::max() / sizeof(T); }
|
||||
|
||||
pointer allocate(size_type num, const_void_pointer hint = 0) { return alloc_size(num*sizeof(T)); }
|
||||
@ -21,7 +23,7 @@
|
||||
};
|
||||
|
||||
|
||||
@@ -98,6 +94,36 @@ bool operator!= (const cacheline_allocator<T1>&, const cacheline_allocator<T2>&)
|
||||
@@ -98,6 +94,36 @@
|
||||
return false;
|
||||
}
|
||||
|
@ -1,6 +1,8 @@
|
||||
--- a/src/net/socket_datagram.cc
|
||||
+++ b/src/net/socket_datagram.cc
|
||||
@@ -73,6 +73,23 @@ SocketDatagram::write_datagram(const voi
|
||||
Index: libtorrent-0.12.6_r1209/src/net/socket_datagram.cc
|
||||
===================================================================
|
||||
--- libtorrent-0.12.6_r1209.orig/src/net/socket_datagram.cc 2008-07-05 14:13:12.000000000 +0200
|
||||
+++ libtorrent-0.12.6_r1209/src/net/socket_datagram.cc 2011-04-13 16:33:33.266840379 +0200
|
||||
@@ -73,6 +73,23 @@
|
||||
int r;
|
||||
|
||||
if (sa != NULL) {
|
@ -1,6 +1,8 @@
|
||||
--- a/src/net/socket_set.h
|
||||
+++ b/src/net/socket_set.h
|
||||
@@ -53,12 +53,12 @@ namespace torrent {
|
||||
Index: libtorrent-0.12.6_r1209/src/net/socket_set.h
|
||||
===================================================================
|
||||
--- libtorrent-0.12.6_r1209.orig/src/net/socket_set.h 2011-02-12 13:20:09.000000000 +0100
|
||||
+++ libtorrent-0.12.6_r1209/src/net/socket_set.h 2011-04-13 16:33:38.567388959 +0200
|
||||
@@ -53,12 +53,12 @@
|
||||
|
||||
// Propably should rename to EventSet...
|
||||
|
@ -1,13 +1,7 @@
|
||||
fix the following build error on octeon & ppc
|
||||
|
||||
In file included from ../../rak/priority_queue_default.h:41,
|
||||
from ./../dht/dht_router.h:40,
|
||||
from tracker_dht.cc:42:
|
||||
../../rak/allocators.h: In static member function 'static T* rak::cacheline_allocator<T>::alloc_size(size_t)':
|
||||
../../rak/allocators.h:109: error: 'uintptr_t' was not declared in this scope
|
||||
|
||||
--- a/rak/allocators.h
|
||||
+++ b/rak/allocators.h
|
||||
Index: libtorrent-0.12.6_r1209/rak/allocators.h
|
||||
===================================================================
|
||||
--- libtorrent-0.12.6_r1209.orig/rak/allocators.h 2011-04-13 16:33:28.179339669 +0200
|
||||
+++ libtorrent-0.12.6_r1209/rak/allocators.h 2011-04-13 16:33:48.454840573 +0200
|
||||
@@ -41,6 +41,7 @@
|
||||
|
||||
#include <cstddef>
|
||||
|
@ -1,17 +1,16 @@
|
||||
#
|
||||
# Copyright (C) 2007-2010 OpenWrt.org
|
||||
# Copyright (C) 2007-2011 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
#
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=rtorrent
|
||||
PKG_REV:=1189
|
||||
PKG_REV:=1209
|
||||
PKG_VERSION:=0.8.6_r$(PKG_REV)
|
||||
PKG_RELEASE:=2
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=svn://rakshasa.no/libtorrent/trunk/rtorrent
|
||||
@ -31,6 +30,7 @@ define Package/rtorrent
|
||||
TITLE:=BitTorrent client for ncurses
|
||||
URL:=http://libtorrent.rakshasa.no/
|
||||
DEPENDS:=+libcurl +libtorrent +libncurses +libsigcxx +xmlrpc-c-server +libpthread
|
||||
MAINTAINER:=Luka Perkov <openwrt@lukaperkov.net>
|
||||
endef
|
||||
|
||||
define Package/rtorrent/description
|
||||
@ -40,10 +40,7 @@ define Package/rtorrent/description
|
||||
based clients in an ncurses client.
|
||||
endef
|
||||
|
||||
ifneq ($(CONFIG_GCC_VERSION_3_4)$(CONFIG_GCC_VERSION_4_1),)
|
||||
TARGET_CPPFLAGS += -fno-strict-aliasing
|
||||
endif
|
||||
|
||||
TARGET_CPPFLAGS += -fno-strict-aliasing -fno-inline
|
||||
TARGET_LDFLAGS += -lpthread -Wl,-rpath-link=$(STAGING_DIR)/usr/lib
|
||||
|
||||
CONFIGURE_ARGS+= \
|
||||
@ -53,7 +50,7 @@ CONFIGURE_ARGS+= \
|
||||
--with-xmlrpc-c
|
||||
|
||||
define Build/Configure
|
||||
(cd $(PKG_BUILD_DIR); ./autogen.sh );
|
||||
( cd $(PKG_BUILD_DIR); ./autogen.sh );
|
||||
$(call Build/Configure/Default)
|
||||
endef
|
||||
|
||||
|
@ -1,5 +1,7 @@
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
Index: rtorrent-0.8.6_r1209/configure.ac
|
||||
===================================================================
|
||||
--- rtorrent-0.8.6_r1209.orig/configure.ac 2010-10-05 05:36:14.000000000 +0200
|
||||
+++ rtorrent-0.8.6_r1209/configure.ac 2011-04-13 16:29:48.619340344 +0200
|
||||
@@ -2,7 +2,6 @@
|
||||
|
||||
AM_INIT_AUTOMAKE
|
||||
@ -14,8 +16,10 @@
|
||||
src/utils/Makefile
|
||||
- test/Makefile
|
||||
])
|
||||
--- a/Makefile.am
|
||||
+++ b/Makefile.am
|
||||
Index: rtorrent-0.8.6_r1209/Makefile.am
|
||||
===================================================================
|
||||
--- rtorrent-0.8.6_r1209.orig/Makefile.am 2010-03-19 10:33:25.000000000 +0100
|
||||
+++ rtorrent-0.8.6_r1209/Makefile.am 2011-04-13 16:29:48.619340344 +0200
|
||||
@@ -1,7 +1,4 @@
|
||||
-SUBDIRS = \
|
||||
- doc \
|
||||
@ -25,9 +29,11 @@
|
||||
|
||||
EXTRA_DIST= \
|
||||
autogen.sh \
|
||||
--- a/scripts/common.m4
|
||||
+++ b/scripts/common.m4
|
||||
@@ -209,7 +209,7 @@ dnl Need to fix this so that it uses t
|
||||
Index: rtorrent-0.8.6_r1209/scripts/common.m4
|
||||
===================================================================
|
||||
--- rtorrent-0.8.6_r1209.orig/scripts/common.m4 2009-12-19 22:36:44.000000000 +0100
|
||||
+++ rtorrent-0.8.6_r1209/scripts/common.m4 2011-04-13 16:29:48.619340344 +0200
|
||||
@@ -209,7 +209,7 @@
|
||||
AC_DEFUN([TORRENT_CHECK_EXECINFO], [
|
||||
AC_MSG_CHECKING(for execinfo.h)
|
||||
|
||||
|
@ -1,7 +1,7 @@
|
||||
diff --git a/rak/allocators.h b/rak/allocators.h
|
||||
index 0a1b711..2d7b98e 100644
|
||||
--- a/rak/allocators.h
|
||||
+++ b/rak/allocators.h
|
||||
Index: rtorrent-0.8.6_r1209/rak/allocators.h
|
||||
===================================================================
|
||||
--- rtorrent-0.8.6_r1209.orig/rak/allocators.h 2010-11-10 12:40:28.000000000 +0100
|
||||
+++ rtorrent-0.8.6_r1209/rak/allocators.h 2011-04-13 16:30:02.370840196 +0200
|
||||
@@ -42,6 +42,7 @@
|
||||
#include <cstddef>
|
||||
#include <limits>
|
||||
@ -10,7 +10,7 @@ index 0a1b711..2d7b98e 100644
|
||||
#include <sys/types.h>
|
||||
|
||||
namespace rak {
|
||||
@@ -74,17 +75,13 @@ public:
|
||||
@@ -74,17 +75,13 @@
|
||||
size_type max_size () const throw() { return std::numeric_limits<size_t>::max() / sizeof(T); }
|
||||
|
||||
pointer allocate(size_type num, const_void_pointer hint = 0) { return alloc_size(num*sizeof(T)); }
|
||||
@ -31,7 +31,7 @@ index 0a1b711..2d7b98e 100644
|
||||
};
|
||||
|
||||
|
||||
@@ -98,6 +95,36 @@ bool operator!= (const cacheline_allocator<T1>&, const cacheline_allocator<T2>&)
|
||||
@@ -98,6 +95,36 @@
|
||||
return false;
|
||||
}
|
||||
|
Loading…
x
Reference in New Issue
Block a user