[packages] multimedia/motion: update to 3.2.9
git-svn-id: svn://svn.openwrt.org/openwrt/packages@10155 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
c787f07860
commit
6d2dc2371e
@ -1,5 +1,5 @@
|
||||
#
|
||||
# Copyright (C) 2006 OpenWrt.org
|
||||
# Copyright (C) 2008 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
@ -9,13 +9,13 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=motion
|
||||
PKG_VERSION:=20070331-051001
|
||||
PKG_VERSION:=3.2.9
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://www.lavrsen.dk/sources/motion-daily \
|
||||
@SF/motion
|
||||
PKG_MD5SUM:=16e58186022dfee1c0dcaf03cf5393e5
|
||||
PKG_MD5SUM:=6003011b126c9b17e23e085e7fba6536
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
|
||||
@ -43,13 +43,13 @@ define Build/Configure
|
||||
)
|
||||
endef
|
||||
|
||||
define Build/Compile
|
||||
define Build/Compile
|
||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||
DESTDIR="$(PKG_INSTALL_DIR)" \
|
||||
all install
|
||||
endef
|
||||
|
||||
define Package/motion/install
|
||||
define Package/motion/install
|
||||
$(INSTALL_DIR) $(1)/etc
|
||||
$(CP) $(PKG_INSTALL_DIR)/etc/motion-dist.conf $(1)/etc/motion.conf
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
|
@ -1,7 +1,8 @@
|
||||
diff -x .svn -ruN motion-3.2.8.old/motion.c motion-3.2.8/motion.c
|
||||
--- motion-3.2.8.old/motion.c 2007-03-31 12:54:31.000000000 +0200
|
||||
+++ motion-3.2.8/motion.c 2007-03-31 13:08:27.000000000 +0200
|
||||
@@ -1282,6 +1282,7 @@
|
||||
Index: motion-3.2.9/motion.c
|
||||
===================================================================
|
||||
--- motion-3.2.9.orig/motion.c
|
||||
+++ motion-3.2.9/motion.c
|
||||
@@ -1285,6 +1285,7 @@ static void *motion_loop(void *arg)
|
||||
* httpd-control snaps are always enabled.
|
||||
*/
|
||||
|
||||
@ -9,7 +10,7 @@ diff -x .svn -ruN motion-3.2.8.old/motion.c motion-3.2.8/motion.c
|
||||
/* time_current_frame is used both for snapshot and timelapse features */
|
||||
time_current_frame = cnt->currenttime;
|
||||
|
||||
@@ -1291,7 +1292,7 @@
|
||||
@@ -1294,7 +1295,7 @@ static void *motion_loop(void *arg)
|
||||
event(cnt, EVENT_IMAGE_SNAPSHOT, newimg, NULL, NULL, cnt->currenttime_tm);
|
||||
cnt->snapshot = 0;
|
||||
}
|
||||
@ -18,7 +19,7 @@ diff -x .svn -ruN motion-3.2.8.old/motion.c motion-3.2.8/motion.c
|
||||
|
||||
/***** MOTION LOOP - TIMELAPSE FEATURE SECTION *****/
|
||||
|
||||
@@ -1366,9 +1367,9 @@
|
||||
@@ -1369,9 +1370,9 @@ static void *motion_loop(void *arg)
|
||||
event(cnt, EVENT_TIMELAPSEEND, NULL, NULL, NULL, cnt->currenttime_tm);
|
||||
|
||||
|
||||
|
@ -1,7 +1,8 @@
|
||||
diff -ruN motion-3.2.5.1-old/Makefile.in motion-3.2.5.1-new/Makefile.in
|
||||
--- motion-3.2.5.1-old/Makefile.in 2006-03-07 22:52:49.000000000 +0100
|
||||
+++ motion-3.2.5.1-new/Makefile.in 2006-03-27 22:04:34.000000000 +0200
|
||||
@@ -32,6 +32,7 @@
|
||||
Index: motion-3.2.9/Makefile.in
|
||||
===================================================================
|
||||
--- motion-3.2.9.orig/Makefile.in
|
||||
+++ motion-3.2.9/Makefile.in
|
||||
@@ -33,6 +33,7 @@ examplesdir = $(docdir)/examples
|
||||
################################################################################
|
||||
CFLAGS = @CFLAGS@ -Wall -DVERSION=\"$(VERSION)\" -D_REENTRANT \
|
||||
-Dsysconfdir=\"$(sysconfdir)\"
|
||||
@ -9,7 +10,7 @@ diff -ruN motion-3.2.5.1-old/Makefile.in motion-3.2.5.1-new/Makefile.in
|
||||
LDFLAGS = @LDFLAGS@
|
||||
LIBS = @LIBS@
|
||||
VIDEO_OBJ = @VIDEO@
|
||||
@@ -115,7 +116,7 @@
|
||||
@@ -120,7 +121,7 @@ endif
|
||||
################################################################################
|
||||
$(DEPEND_FILE): *.h $(SRC)
|
||||
@echo "Generating dependencies, please wait..."
|
||||
|
Loading…
x
Reference in New Issue
Block a user