[package] update gst-plugins-base to 0.10.25, modularize plugin building
(#6302) git-svn-id: svn://svn.openwrt.org/openwrt/packages@18680 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
b748f5ccf6
commit
6d572df28a
@ -1,5 +1,5 @@
|
||||
#
|
||||
# Copyright (C) 2008 OpenWrt.org
|
||||
# Copyright (C) 2008-2009 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
@ -8,12 +8,12 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=gst-plugins-base
|
||||
PKG_VERSION:=0.10.21
|
||||
PKG_RELEASE:=3
|
||||
PKG_VERSION:=0.10.25
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=http://gstreamer.freedesktop.org/src/gst-plugins-base/
|
||||
PKG_MD5SUM:=0e0cd485311502ad1c0c028148e3186
|
||||
PKG_MD5SUM:=d29669dd79276c5cd94e1613c03cd9ab
|
||||
PKG_FIXUP:=libtool
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
@ -33,20 +33,108 @@ EXTRA_LDFLAGS+= \
|
||||
-L$(STAGING_DIR)/usr/lib/libintl/lib \
|
||||
-L$(STAGING_DIR)/usr/lib/libiconv/lib
|
||||
|
||||
define Package/gst-plugins-base
|
||||
define Package/gst-plugins-base/Default
|
||||
SECTION:=multimedia
|
||||
CATEGORY:=Multimedia
|
||||
DEPENDS:=+gstreamer +liboil +gst-plugins-base-libs
|
||||
TITLE:=gst-plugins-base
|
||||
URL:=http://gstreamer.freedesktop.org/
|
||||
DEPENDS:=+gstreamer +liboil +pango +libXv +libogg +libvorbis +libtheora +alsa-lib
|
||||
endef
|
||||
|
||||
define Package/gst-plugins-base/description
|
||||
gstreamer base plugins
|
||||
define Package/gst-plugins-base-libs
|
||||
$(call Package/gst-plugins-base/Default)
|
||||
DEPENDS:=+gstreamer +liboil
|
||||
TITLE:=gstreamber plugins base libraries
|
||||
endef
|
||||
|
||||
define Package/gst-plugins-base-ogg
|
||||
$(call Package/gst-plugins-base/Default)
|
||||
TITLE += (ogg)
|
||||
DEPENDS += +libogg
|
||||
endef
|
||||
|
||||
define Package/gst-plugins-base-ogg/description
|
||||
gstreamer OGG plugins
|
||||
endef
|
||||
|
||||
define Package/gst-plugins-base-vorbis
|
||||
$(call Package/gst-plugins-base/Default)
|
||||
TITLE+= (vorbis)
|
||||
DEPENDS:=+gst-plugins-base-ogg +libvorbis
|
||||
endef
|
||||
|
||||
define Package/gst-plugins-base-vorbis/description
|
||||
gstreamer Vorbis plugins
|
||||
endef
|
||||
|
||||
define Package/gst-plugins-base-theora
|
||||
$(call Package/gst-plugins-base/Default)
|
||||
TITLE+= (theora)
|
||||
DEPENDS:=+gst-plugins-base-ogg +libtheora
|
||||
endef
|
||||
|
||||
define Package/gst-plugins-base-theora/description
|
||||
gstreamer Theora plugins
|
||||
endef
|
||||
|
||||
define Package/gst-plugins-base-alsa
|
||||
$(call Package/gst-plugins-base/Default)
|
||||
TITLE+= (alsa)
|
||||
endef
|
||||
|
||||
define Package/gst-plugins-base-alsa/description
|
||||
gstreamer ALSA plugins
|
||||
endef
|
||||
|
||||
define Package/gst-plugins-base-app
|
||||
$(call Package/gst-plugins-base/Default)
|
||||
TITLE+= (app)
|
||||
endef
|
||||
|
||||
define Package/gst-plugins-base-app/description
|
||||
gstreamer app plugins
|
||||
endef
|
||||
|
||||
define Package/gst-plugins-base-audioconvert
|
||||
$(call Package/gst-plugins-base/Default)
|
||||
TITLE+= (audioconvert)
|
||||
endef
|
||||
|
||||
define Package/gst-plugins-base-audioconvert/description
|
||||
gstreamer audioconvert plugins
|
||||
endef
|
||||
|
||||
define Package/gst-plugins-base-gio
|
||||
$(call Package/gst-plugins-base/Default)
|
||||
TITLE+= (gio)
|
||||
DEPENDS += +glib2
|
||||
endef
|
||||
|
||||
define Package/gst-plugins-base-gio/description
|
||||
gstreamer GIO plugins
|
||||
endef
|
||||
|
||||
define Package/gst-plugins-base-typefindfunctions
|
||||
$(call Package/gst-plugins-base/Default)
|
||||
TITLE+= (typefind)
|
||||
endef
|
||||
|
||||
define Package/gst-plugins-base-typefindfunctions/description
|
||||
gstreamer typefind plugins
|
||||
endef
|
||||
|
||||
define Package/gst-plugins-base-decodebin
|
||||
$(call Package/gst-plugins-base/Default)
|
||||
TITLE+= (decodebin)
|
||||
endef
|
||||
|
||||
define Package/gst-plugins-base-decodebin/description
|
||||
gstreamer decodebin plugins
|
||||
endef
|
||||
|
||||
define Build/Configure
|
||||
$(call Build/Configure/Default, \
|
||||
--disable-pango \
|
||||
--disable-gnome_vfs \
|
||||
--disable-examples \
|
||||
--disable-cdparanoia \
|
||||
@ -69,12 +157,12 @@ define Build/InstallDev
|
||||
|
||||
$(INSTALL_DIR) $(1)/usr/lib/
|
||||
$(CP) \
|
||||
$(PKG_INSTALL_DIR)/usr/lib/*.{so*,a,la} \
|
||||
$(PKG_INSTALL_DIR)/usr/lib/*.{so*,la} \
|
||||
$(1)/usr/lib/
|
||||
|
||||
$(INSTALL_DIR) $(1)/usr/lib/gstreamer-0.10
|
||||
$(CP) \
|
||||
$(PKG_INSTALL_DIR)/usr/lib/gstreamer-0.10/*.{so*,a,la} \
|
||||
$(PKG_INSTALL_DIR)/usr/lib/gstreamer-0.10/*.{so*,la} \
|
||||
$(1)/usr/lib/gstreamer-0.10/
|
||||
|
||||
$(INSTALL_DIR) $(1)/usr/lib/pkgconfig/
|
||||
@ -83,16 +171,28 @@ define Build/InstallDev
|
||||
$(1)/usr/lib/pkgconfig/
|
||||
endef
|
||||
|
||||
define Package/gst-plugins-base/install
|
||||
$(INSTALL_DIR) $(1)/usr/lib/
|
||||
$(CP) \
|
||||
$(PKG_INSTALL_DIR)/usr/lib/*.so* \
|
||||
$(1)/usr/lib/
|
||||
|
||||
$(INSTALL_DIR) $(1)/usr/lib/gstreamer-0.10
|
||||
$(CP) \
|
||||
$(PKG_INSTALL_DIR)/usr/lib/gstreamer-0.10/*.so* \
|
||||
$(1)/usr/lib/gstreamer-0.10
|
||||
define Package/gst-plugins-base-libs/install
|
||||
$(INSTALL_DIR) $(1)/usr/lib
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/*.so* $(1)/usr/lib
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,gst-plugins-base))
|
||||
define BuildPlugin
|
||||
define Package/gst-plugins-base-$(1)/install
|
||||
$(INSTALL_DIR) $$(1)/usr/lib/gstreamer-0.10
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/gstreamer-0.10/libgst$(1).so \
|
||||
$$(1)/usr/lib/gstreamer-0.10/
|
||||
endef
|
||||
|
||||
$$(eval $$(call BuildPackage,gst-plugins-base-$(1)))
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPlugin,ogg))
|
||||
$(eval $(call BuildPlugin,vorbis))
|
||||
$(eval $(call BuildPlugin,theora))
|
||||
$(eval $(call BuildPlugin,alsa))
|
||||
$(eval $(call BuildPlugin,app))
|
||||
$(eval $(call BuildPlugin,audioconvert))
|
||||
$(eval $(call BuildPlugin,gio))
|
||||
$(eval $(call BuildPlugin,typefindfunctions))
|
||||
$(eval $(call BuildPlugin,decodebin))
|
||||
$(eval $(call BuildPackage,gst-plugins-base-libs))
|
||||
|
@ -1,8 +1,7 @@
|
||||
diff --git a/Makefile.in b/Makefile.in
|
||||
index a09b06c..d2a920d 100644
|
||||
--- a/Makefile.in
|
||||
+++ b/Makefile.in
|
||||
@@ -359,7 +359,6 @@ SUBDIRS = \
|
||||
diff -u --recursive gst-plugins-base-0.10.25-vanilla/Makefile.in gst-plugins-base-0.10.25/Makefile.in
|
||||
--- gst-plugins-base-0.10.25-vanilla/Makefile.in 2009-11-14 22:55:44.146292714 -0500
|
||||
+++ gst-plugins-base-0.10.25/Makefile.in 2009-11-14 22:56:11.830296238 -0500
|
||||
@@ -397,7 +397,6 @@
|
||||
gst-libs \
|
||||
gst sys $(SUBDIRS_EXT) \
|
||||
tools \
|
||||
@ -10,11 +9,11 @@ index a09b06c..d2a920d 100644
|
||||
docs \
|
||||
po \
|
||||
common \
|
||||
@@ -371,7 +370,6 @@ DIST_SUBDIRS = \
|
||||
@@ -409,7 +408,6 @@
|
||||
gst-libs \
|
||||
gst sys ext \
|
||||
tools \
|
||||
- tests \
|
||||
po \
|
||||
common \
|
||||
m4 \
|
||||
m4
|
||||
|
@ -1,36 +1,37 @@
|
||||
diff -urN gst-plugins-base-0.10.21/Makefile.am gst-plugins-base-0.10.21.new/Makefile.am
|
||||
--- gst-plugins-base-0.10.21/Makefile.am 2007-12-18 00:41:14.000000000 +0100
|
||||
+++ gst-plugins-base-0.10.21.new/Makefile.am 2009-03-11 10:23:14.000000000 +0100
|
||||
@@ -11,14 +11,12 @@
|
||||
diff -u --recursive gst-plugins-base-0.10.25-vanilla/Makefile.am gst-plugins-base-0.10.25/Makefile.am
|
||||
--- gst-plugins-base-0.10.25-vanilla/Makefile.am 2009-11-14 22:55:44.260292712 -0500
|
||||
+++ gst-plugins-base-0.10.25/Makefile.am 2009-11-14 22:57:07.407292800 -0500
|
||||
@@ -12,14 +12,12 @@
|
||||
gst sys $(SUBDIRS_EXT) \
|
||||
tools \
|
||||
tests \
|
||||
- docs \
|
||||
po \
|
||||
common \
|
||||
m4 \
|
||||
pkgconfig
|
||||
m4
|
||||
|
||||
DIST_SUBDIRS = \
|
||||
pkgconfig \
|
||||
- docs \
|
||||
gst-libs \
|
||||
gst sys ext \
|
||||
tools \
|
||||
diff -urN gst-plugins-base-0.10.21/Makefile.in gst-plugins-base-0.10.21.new/Makefile.in
|
||||
--- gst-plugins-base-0.10.21/Makefile.in 2009-03-11 10:22:56.000000000 +0100
|
||||
+++ gst-plugins-base-0.10.21.new/Makefile.in 2009-03-11 10:23:08.000000000 +0100
|
||||
@@ -359,14 +359,12 @@
|
||||
diff -u --recursive gst-plugins-base-0.10.25-vanilla/Makefile.in gst-plugins-base-0.10.25/Makefile.in
|
||||
--- gst-plugins-base-0.10.25-vanilla/Makefile.in 2009-11-14 23:01:05.051383435 -0500
|
||||
+++ gst-plugins-base-0.10.25/Makefile.in 2009-11-14 23:00:35.186350079 -0500
|
||||
@@ -397,14 +397,12 @@
|
||||
gst-libs \
|
||||
gst sys $(SUBDIRS_EXT) \
|
||||
tools \
|
||||
- docs \
|
||||
po \
|
||||
common \
|
||||
m4 \
|
||||
pkgconfig
|
||||
m4
|
||||
|
||||
DIST_SUBDIRS = \
|
||||
pkgconfig \
|
||||
- docs \
|
||||
gst-libs \
|
||||
gst sys ext \
|
||||
tools \
|
||||
Only in gst-plugins-base-0.10.25/: Makefile.in.orig
|
||||
|
16
multimedia/gst-plugins-base/patches/030-no_shave-make.patch
Normal file
16
multimedia/gst-plugins-base/patches/030-no_shave-make.patch
Normal file
@ -0,0 +1,16 @@
|
||||
diff -u --recursive gst-plugins-base-0.10.25-vanilla/common/shave-libtool.in gst-plugins-base-0.10.25/common/shave-libtool.in
|
||||
--- gst-plugins-base-0.10.25-vanilla/common/shave-libtool.in 2009-11-15 07:25:57.034292287 -0500
|
||||
+++ gst-plugins-base-0.10.25/common/shave-libtool.in 2009-11-15 07:26:23.829341026 -0500
|
||||
@@ -41,12 +41,9 @@
|
||||
|
||||
case "$mode" in
|
||||
compile)
|
||||
- # shave will be called and print the actual CC/CXX/LINK line
|
||||
- preserved_args="$preserved_args --shave-mode=$mode"
|
||||
pass_though=1
|
||||
;;
|
||||
link)
|
||||
- preserved_args="$preserved_args --shave-mode=$mode"
|
||||
Q=" LINK "
|
||||
;;
|
||||
*)
|
Loading…
x
Reference in New Issue
Block a user