mrd6: remove invasive stuff from patch 001 and rename it, Makefile cleanup

git-svn-id: svn://svn.openwrt.org/openwrt/packages@8601 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
nico 2007-09-03 16:07:32 +00:00
parent 1ecf77a71c
commit 6dce3393a8
2 changed files with 15 additions and 26 deletions

View File

@ -11,14 +11,10 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=mrd6
PKG_VERSION:=0.9.5
PKG_RELEASE:=1
PKG_MD5SUM:=24a08cf1407000d628a272b08a415dda
PKG_SOURCE_URL:=http://hng.av.it.pt/mrd6/download/
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_CAT:=zcat
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
PKG_MD5SUM:=24a08cf1407000d628a272b08a415dda
PKG_BUILD_DEPENDS:=libnotimpl
@ -29,13 +25,6 @@ define Package/mrd6
CATEGORY:=IPv6
DEPENDS:=@LINUX_2_6 +uclibcxx
TITLE:=IPv6 multicast routing daemon
DESCRIPTION:=Multicast is becoming a major component in next generation\\\
networks, used in several scenarios, from video broadcasting\\\
to multimedia conferencing. In order to be implemented, new\\\
technology needs supporting hardware and software across a set\\\
of devices and systems. MRD6 is an implementation of a modular\\\
IPv6 Multicast Routing Framework for the Linux operating system\\\
and provides MLDv2 (as well as MLDv1), PIM-SM and MBGP support.\\\
URL:=http://artemis.av.it.pt/mrd6/
endef
@ -43,17 +32,26 @@ define Package/mrd6/conffiles
/etc/mrd6.conf
endef
define Package/mrd6/description
Multicast is becoming a major component in next generation networks, used
in several scenarios, from video broadcasting to multimedia conferencing.
In order to be implemented, new technology needs supporting hardware and
software across a set of devices and systems. MRD6 is an implementation of
a modular IPv6 Multicast Routing Framework for the Linux operating system
and provides MLDv2 (as well as MLDv1), PIM-SM and MBGP support.
endef
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR)/src \
$(TARGET_CONFIGURE_OPTS) \
OPTIMIZE=yes \
SPACE_OPTIMIZE=yes \
FULL_STATIC=no \
CFLAGS="$(TARGET_CFLAGS) -DNO_INET6_OPTION" \
CXX="$(TARGET_CROSS)g++" \
CC="$(TARGET_CC)" \
STAGING_DIR="$(STAGING_DIR)" \
CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS) -DNO_INET6_OPTION -fno-builtin -fno-rtti" \
LDFLAGS="$(TARGET_LDFLAGS) -nodefaultlibs -luClibc++ -Wl,-Bstatic,-lstdc++,-Bdynamic -ldl -lm -lnotimpl" \
MODULE_CXX="\$$$$(CC) -shared \$$$$(CXXFLAGS) \$$$$(LDFLAGS)" \
DESTDIR="$(PKG_INSTALL_DIR)" \
PREFIX=/usr/ \
PREFIX="/usr/" \
install
endef

View File

@ -10,12 +10,3 @@ diff -urN mrd6-0.9.5/src/Makefile mrd6-0.9.5.new/src/Makefile
ifeq ($(OPTIMIZE),yes)
ifeq ($(SPACE_OPTIMIZE),yes)
@@ -97,7 +97,7 @@
endif
endif
-LDFLAGS += -lm
+LDFLAGS += -L$(STAGING_DIR)/usr/lib -lnotimpl -lm
ifeq ($(PLATFORM),OS_LINUX)
LDFLAGS += -ldl
endif