From 6eb53794b85603498383770460d32f2c0a47a0f3 Mon Sep 17 00:00:00 2001
From: lars <lars@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Date: Sun, 23 Nov 2008 15:42:22 +0000
Subject: [PATCH] Add xauth package.

git-svn-id: svn://svn.openwrt.org/openwrt/packages@13330 3c298f89-4303-0410-b956-a3cf2f4a3e73
---
 Xorg/app/xauth/Makefile | 39 +++++++++++++++++++++++++++++++++++++++
 1 file changed, 39 insertions(+)
 create mode 100644 Xorg/app/xauth/Makefile

diff --git a/Xorg/app/xauth/Makefile b/Xorg/app/xauth/Makefile
new file mode 100644
index 000000000..92a1bd6eb
--- /dev/null
+++ b/Xorg/app/xauth/Makefile
@@ -0,0 +1,39 @@
+#
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=xauth
+PKG_RELEASE:=1
+PKG_VERSION:=1.0.3
+PKG_SOURCE_URL:=http://xorg.freedesktop.org/releases/X11R7.4/src/app
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_BUILD_DIR=$(BUILD_DIR)/Xorg/$(_CATEGORY)/$(PKG_NAME)-$(PKG_VERSION)/
+
+include $(INCLUDE_DIR)/package.mk
+
+PKG_INSTALL:=1
+
+TARGET_LDFLAGS+=-Wl,-rpath-link=$(STAGING_DIR)/usr/lib
+
+define Package/xauth
+  SECTION:=xorg-app
+  CATEGORY:=Xorg
+  SUBMENU:=app
+  DEPENDS:=+libX11 +libXau +libXext +libXmuu
+  TITLE:=xauth
+  URL:=http://xorg.freedesktop.org/
+endef
+
+define Package/xauth/install
+	$(INSTALL_DIR) $(1)/usr/bin
+	$(INSTALL_BIN) \
+		$(PKG_INSTALL_DIR)/usr/bin/* \
+		$(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,xauth))