creating new section "phone" and adding fso (freesmartphone.org) DBus API reference implementation

git-svn-id: svn://svn.openwrt.org/openwrt/packages@13867 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
mirko 2009-01-05 00:39:20 +00:00
parent d86c5b94b0
commit 6eb8fc0eb4
2 changed files with 89 additions and 0 deletions

55
phone/fso/Makefile Normal file
View File

@ -0,0 +1,55 @@
#
# Copyright (C) 2006 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
include $(TOPDIR)/rules.mk
PKG_NAME:=fso
PKG_VERSION:=20090103
PKG_REV:=cbddf72db7ee7f06c5863bce6d4055652e66b25b
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=git://git.freesmartphone.org/framework.git
PKG_SOURCE_PROTO:=git
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
PKG_SOURCE_VERSION:=$(PKG_REV)
PKG_BUILD_DEPENDS:=cython python
include $(INCLUDE_DIR)/package.mk
-include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
define Package/fso
SECTION:=phone
CATEGORY:=Phone
TITLE:=freesmartphone.org DBus API reference implementation
DEPENDS:=python-core +dbus
URL:=http://www.freesmartphone.org
endef
define Package/fso/description
freesmartphone.org is a collaboration platform for open source and open discussion software projects working on interoperability and shared technology for Linux-based SmartPhones
endef
define Build/Compile
$(call Build/Compile/PyMod,,install --prefix="$(PKG_INSTALL_DIR)/usr")
endef
define Package/fso/install
$(INSTALL_DIR) $(1)$(PYTHON_PKG_DIR) $(1)/usr/bin $(1)/etc
$(CP) \
$(PKG_INSTALL_DIR)$(PYTHON_PKG_DIR)/* \
$(1)$(PYTHON_PKG_DIR)
$(CP) \
$(PKG_INSTALL_DIR)/usr/bin/* \
$(1)/usr/bin/
$(CP) \
$(PKG_INSTALL_DIR)/etc/* \
$(1)/etc/
endef
$(eval $(call BuildPackage,fso))

View File

@ -0,0 +1,34 @@
diff -ruN fso-20090103.orig/setup.py fso-20090103/setup.py
--- fso-20090103.orig/setup.py 2009-01-04 22:23:14.000000000 +0100
+++ fso-20090103/setup.py 2009-01-05 01:22:17.000000000 +0100
@@ -23,18 +23,18 @@
packages = packages,
scripts = [ "framework/frameworkd", "tools/cli-framework" ],
data_files = [
- ("../../etc/dbus-1/system.d", ["etc/dbus-1/system.d/frameworkd.conf"] ),
- ("../../etc/freesmartphone/opreferences/schema/", ["etc/freesmartphone/opreferences/schema/phone.yaml"]),
- ("../../etc/freesmartphone/opreferences/schema/", ["etc/freesmartphone/opreferences/schema/profiles.yaml"]),
- ("../../etc/freesmartphone/opreferences/schema/", ["etc/freesmartphone/opreferences/schema/rules.yaml"]),
- ("../../etc/freesmartphone/opreferences/conf/profiles/", ["etc/freesmartphone/opreferences/conf/profiles/default.yaml"]),
- ("../../etc/freesmartphone/opreferences/conf/phone", ["etc/freesmartphone/opreferences/conf/phone/default.yaml"]),
- ("../../etc/freesmartphone/opreferences/conf/phone", ["etc/freesmartphone/opreferences/conf/phone/silent.yaml"]),
- ("../../etc/freesmartphone/opreferences/conf/rules", ["etc/freesmartphone/opreferences/conf/rules/default.yaml"]),
- ("../../etc/freesmartphone/opreferences/conf/rules", ["etc/freesmartphone/opreferences/conf/rules/silent.yaml"]),
- ("../../etc/freesmartphone/oevents", ["etc/freesmartphone/oevents/rules.yaml"]),
- ("../../etc/freesmartphone/persist", ["etc/freesmartphone/persist/README"]),
- ("../../etc/freesmartphone/ogsmd", ["etc/freesmartphone/ogsmd/networks.tab"]),
+ ("../etc/dbus-1/system.d", ["etc/dbus-1/system.d/frameworkd.conf"] ),
+ ("../etc/freesmartphone/opreferences/schema/", ["etc/freesmartphone/opreferences/schema/phone.yaml"]),
+ ("../etc/freesmartphone/opreferences/schema/", ["etc/freesmartphone/opreferences/schema/profiles.yaml"]),
+ ("../etc/freesmartphone/opreferences/schema/", ["etc/freesmartphone/opreferences/schema/rules.yaml"]),
+ ("../etc/freesmartphone/opreferences/conf/profiles/", ["etc/freesmartphone/opreferences/conf/profiles/default.yaml"]),
+ ("../etc/freesmartphone/opreferences/conf/phone", ["etc/freesmartphone/opreferences/conf/phone/default.yaml"]),
+ ("../etc/freesmartphone/opreferences/conf/phone", ["etc/freesmartphone/opreferences/conf/phone/silent.yaml"]),
+ ("../etc/freesmartphone/opreferences/conf/rules", ["etc/freesmartphone/opreferences/conf/rules/default.yaml"]),
+ ("../etc/freesmartphone/opreferences/conf/rules", ["etc/freesmartphone/opreferences/conf/rules/silent.yaml"]),
+ ("../etc/freesmartphone/oevents", ["etc/freesmartphone/oevents/rules.yaml"]),
+ ("../etc/freesmartphone/persist", ["etc/freesmartphone/persist/README"]),
+ ("../etc/freesmartphone/ogsmd", ["etc/freesmartphone/ogsmd/networks.tab"]),
("freesmartphone/examples/", getDir( "examples" ) ),
]
)