[packages] peerguardian: libnetfilter-queue-libipq has been dropped upstream, switch back to libipq

git-svn-id: svn://svn.openwrt.org/openwrt/packages@24531 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
jow 2010-12-13 00:36:29 +00:00
parent 21bfc6048e
commit 6f2a630787
3 changed files with 3 additions and 7 deletions

View File

@ -25,7 +25,7 @@ include $(INCLUDE_DIR)/package.mk
define Package/peerguardian define Package/peerguardian
SECTION:=net SECTION:=net
CATEGORY:=Network CATEGORY:=Network
DEPENDS:= +libncurses +libpthread +libnetfilter-queue DEPENDS:=@BROKEN +libncurses +libpthread +libnetfilter-queue
TITLE:=PeerGuardian for Linux TITLE:=PeerGuardian for Linux
URL:=http://phoenixlabs.org/ URL:=http://phoenixlabs.org/
endef endef

View File

@ -5,7 +5,7 @@
peerguardnf_SOURCES=Main.cpp PeerGuard.cpp BlockList.cpp Blocker_Linux.cpp Blocker_BSD.cpp HttpServer.cpp HttpRequest.cpp sha1.cpp peerguardnf_SOURCES=Main.cpp PeerGuard.cpp BlockList.cpp Blocker_Linux.cpp Blocker_BSD.cpp HttpServer.cpp HttpRequest.cpp sha1.cpp
pgtext_SOURCES=pgtext.cpp pgtext_SOURCES=pgtext.cpp
-peerguardnf_LDADD=-lipq -lpthread -peerguardnf_LDADD=-lipq -lpthread
+peerguardnf_LDADD=-lnetfilter_queue_libipq -lnetfilter_queue -lnfnetlink -lpthread +peerguardnf_LDADD=-lipq -lnetfilter_queue -lnfnetlink -lpthread
pgtext_LDADD=-lncurses -lpthread pgtext_LDADD=-lncurses -lpthread
peerguardnf_LDFLAGS=$(all_includes) -I/usr/include/libipq peerguardnf_LDFLAGS=$(all_includes) -I/usr/include/libipq
AM_CPPFLAGS=$(ALL_INCLUDES) -I/usr/include/libipq AM_CPPFLAGS=$(ALL_INCLUDES) -I/usr/include/libipq
@ -16,7 +16,7 @@
peerguardnf_SOURCES = Main.cpp PeerGuard.cpp BlockList.cpp Blocker_Linux.cpp Blocker_BSD.cpp HttpServer.cpp HttpRequest.cpp sha1.cpp peerguardnf_SOURCES = Main.cpp PeerGuard.cpp BlockList.cpp Blocker_Linux.cpp Blocker_BSD.cpp HttpServer.cpp HttpRequest.cpp sha1.cpp
pgtext_SOURCES = pgtext.cpp pgtext_SOURCES = pgtext.cpp
-peerguardnf_LDADD = -lipq -lpthread -peerguardnf_LDADD = -lipq -lpthread
+peerguardnf_LDADD = -lnetfilter_queue_libipq -lnetfilter_queue -lnfnetlink -lpthread +peerguardnf_LDADD = -lipq -lnetfilter_queue -lnfnetlink -lpthread
pgtext_LDADD = -lncurses -lpthread pgtext_LDADD = -lncurses -lpthread
peerguardnf_LDFLAGS = $(all_includes) peerguardnf_LDFLAGS = $(all_includes)
AM_CPPFLAGS = $(ALL_INCLUDES) AM_CPPFLAGS = $(ALL_INCLUDES)

View File

@ -1,5 +1,3 @@
diff --git a/Main.cpp b/Main.cpp
index 0a5ae59..0c5274c 100755
--- a/Main.cpp --- a/Main.cpp
+++ b/Main.cpp +++ b/Main.cpp
@@ -25,6 +25,7 @@ @@ -25,6 +25,7 @@
@ -10,8 +8,6 @@ index 0a5ae59..0c5274c 100755
using namespace PG; using namespace PG;
using namespace std; using namespace std;
diff --git a/PeerGuard.h b/PeerGuard.h
index 3d0d31c..7e1d0f7 100755
--- a/PeerGuard.h --- a/PeerGuard.h
+++ b/PeerGuard.h +++ b/PeerGuard.h
@@ -24,6 +24,7 @@ @@ -24,6 +24,7 @@