Fix lua plugin compilation
git-svn-id: svn://svn.openwrt.org/openwrt/packages@10225 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
232b2bd983
commit
7129b1e304
@ -9,12 +9,12 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=weechat
|
PKG_NAME:=weechat
|
||||||
PKG_VERSION:=0.2.5
|
PKG_VERSION:=0.2.6
|
||||||
PKG_RELEASE:=2
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||||
PKG_SOURCE_URL:=http://weechat.flashtux.org/download/
|
PKG_SOURCE_URL:=http://weechat.flashtux.org/download/
|
||||||
PKG_MD5SUM:=42f96620c3b2fd3dca9768d9ce16dd06
|
PKG_MD5SUM:=ccdecf663b0050a23049acb4b9a76193
|
||||||
|
|
||||||
PKG_FIXUP = libtool
|
PKG_FIXUP = libtool
|
||||||
|
|
||||||
@ -78,15 +78,18 @@ CONFIGURE_ARGS+= \
|
|||||||
--disable-perl \
|
--disable-perl \
|
||||||
--disable-python \
|
--disable-python \
|
||||||
--disable-ruby \
|
--disable-ruby \
|
||||||
|
LUACONFIG="" \
|
||||||
|
|
||||||
CONFIGURE_VARS+= \
|
CONFIGURE_VARS+= \
|
||||||
LDFLAGS="$$$$LDFLAGS -L$(STAGING_DIR)/usr/lib/libiconv/lib" \
|
LDFLAGS="$$$$LDFLAGS -L$(STAGING_DIR)/usr/lib/libiconv/lib" \
|
||||||
|
|
||||||
ifndef ($(SDK)$(CONFIG_PACKAGE_weechat-mod-lua),)
|
ifneq ($(SDK)$(CONFIG_PACKAGE_weechat-mod-lua),)
|
||||||
CONFIGURE_ARGS+= \
|
CONFIGURE_ARGS+= \
|
||||||
--enable-lua \
|
--enable-lua \
|
||||||
--with-lua-inc="$(STAGING_DIR)/usr/include" \
|
--with-lua-inc="$(STAGING_DIR)/usr/include" \
|
||||||
--with-lua-lib="$(STAGING_DIR)/usr/lib"
|
--with-lua-lib="$(STAGING_DIR)/usr/lib" \
|
||||||
|
LUA_CFLAGS="-I$(STAGING_DIR)/usr/include/"
|
||||||
|
LUA_LFLAGS="-L$(STAGING_DIR)/usr/lib -llualib50 -llua50"
|
||||||
CONFIGURE_VARS+= \
|
CONFIGURE_VARS+= \
|
||||||
LIBS="-ldl -lm"
|
LIBS="-ldl -lm"
|
||||||
else
|
else
|
||||||
@ -95,7 +98,11 @@ else
|
|||||||
endif
|
endif
|
||||||
|
|
||||||
define Build/Compile
|
define Build/Compile
|
||||||
$(MAKE) -C $(PKG_BUILD_DIR) DESTDIR="$(PKG_INSTALL_DIR)" all install
|
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||||
|
$(LUA_FLAGS) \
|
||||||
|
DESTDIR="$(PKG_INSTALL_DIR)" \
|
||||||
|
LUACONFIG="" \
|
||||||
|
all install
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Package/weechat/install
|
define Package/weechat/install
|
||||||
|
18
net/weechat/patches/003-lua_flags.patch
Normal file
18
net/weechat/patches/003-lua_flags.patch
Normal file
@ -0,0 +1,18 @@
|
|||||||
|
diff -urN weechat-0.2.6/configure weechat-0.2.6.new/configure
|
||||||
|
--- weechat-0.2.6/configure 2007-09-05 16:16:21.000000000 +0200
|
||||||
|
+++ weechat-0.2.6.new/configure 2008-01-20 16:29:38.000000000 +0100
|
||||||
|
@@ -30180,14 +30180,6 @@
|
||||||
|
test -n "$LUACONFIG" && break
|
||||||
|
done
|
||||||
|
|
||||||
|
- if test "x$LUACONFIG" != "x" ; then
|
||||||
|
- { echo "$as_me:$LINENO: checking for Lua headers and librairies with lua-config" >&5
|
||||||
|
-echo $ECHO_N "checking for Lua headers and librairies with lua-config... $ECHO_C" >&6; }
|
||||||
|
- echo
|
||||||
|
- LUA_CFLAGS=`$LUACONFIG --include`
|
||||||
|
- LUA_LFLAGS=`$LUACONFIG --libs`
|
||||||
|
- LUA_VERSION="5.0.x"
|
||||||
|
- fi
|
||||||
|
fi
|
||||||
|
|
||||||
|
if test "x$LUA_CFLAGS" = "x" -o "x$LUA_LFLAGS" = "x" ; then
|
Loading…
x
Reference in New Issue
Block a user