Port bitlbee to -ng

git-svn-id: svn://svn.openwrt.org/openwrt/packages@4351 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
florian 2006-07-31 14:15:59 +00:00
parent 359e90d6a2
commit 72dd829577
3 changed files with 188 additions and 0 deletions

87
net/bitlbee/Makefile Normal file
View File

@ -0,0 +1,87 @@
# Copyright (C) 2006 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
# $Id$
include $(TOPDIR)/rules.mk
PKG_NAME:=bitlbee
PKG_VERSION:=1.0.1
PKG_RELEASE:=1
PKG_MD5SUM:=a4d7daa9b64898dd41a3a6d104692d9a
PKG_SOURCE_URL:=http://get.bitlbee.org/src \
http://get.bitlbee.be/src \
http://get.us.bitlbee.org/src \
http://ftp.snt.utwente.nl/pub/software/bitlbee/src
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_CAT:=zcat
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
PKG_BUILDDEP:=openssl glib libiconv
include $(INCLUDE_DIR)/package.mk
define Package/bitlbee
SECTION:=net
CATEGORY:=Network
DEPENDS:=+libopenssl +glib +libiconv
TITLE:=IRC gateway to IM chat networks
DESCRIPTION:=IRC gateway to IM chat networks
URL:=http://www.bitlbee.org/
endef
define Package/bitlbee/conffiles
/etc/bitlbee/motd.txt
/etc/bitlbee/bitlbee.conf
/etc/init.d/S55bitlbee
endef
define Build/Configure
(cd $(PKG_BUILD_DIR); \
$(TARGET_CONFIGURE_OPTS) \
CFLAGS="$(TARGET_CFLAGS)" \
CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
STAGING_DIR="$(STAGING_DIR)" \
STRIP="$(STRIP)" \
./configure \
--prefix=/usr/ \
--bindir=/usr/sbin/ \
--etcdir=/etc/bitlbee/ \
--datadir=/usr/share/bitlbee/ \
--config=/var/lib/bitlbee/ \
--arch=OpenWrt \
--cpu="$(ARCH)" \
--debug=0 \
--strip=1 \
--sizeopt=1 \
--ipv6=1 \
--ssl=openssl \
--glib1=1 \
--glib1prefix="$(STAGING_DIR)/usr" \
);
endef
define Build/Compile
@echo 'CFLAGS+="-I$(STAGING_DIR)/usr/include/iconv"' >> \
$(PKG_BUILD_DIR)/Makefile.settings
@echo 'LFLAGS+="-L$(STAGING_DIR)/usr/lib/iconv"' >> \
$(PKG_BUILD_DIR)/Makefile.settings
$(MAKE) -C $(PKG_BUILD_DIR)
endef
define Package/bitlbee/install
$(MAKE) -C $(PKG_BUILD_DIR) \
DESTDIR="$(1)" install-etc install-bin
$(MAKE) -C $(PKG_BUILD_DIR)/doc/user-guide \
DESTDIR="$(1)" install
install -d -m0755 $(1)/etc/init.d
install -m0755 ./files/S55bitlbee $(1)/etc/init.d/S55bitlbee
endef
$(eval $(call BuildPackage,bitlbee))

3
net/bitlbee/files/S55bitlbee Executable file
View File

@ -0,0 +1,3 @@
#!/bin/sh
mkdir -p /var/lib/bitlbee
bitlbee -D

View File

@ -0,0 +1,98 @@
diff -Nur bitlbee-1.0.1-orig/configure bitlbee-1.0.1/configure
--- bitlbee-1.0.1-orig/configure 2006-01-14 16:14:05.000000000 +0100
+++ bitlbee-1.0.1/configure 2006-03-06 18:30:19.000000000 +0100
@@ -21,9 +21,12 @@
debug=0
strip=1
+sizeopt=0
ipv6=1
ssl=auto
+glib1=0
+
arch=`uname -s`
cpu=`uname -m`
@@ -52,11 +55,18 @@
--debug=0/1 Disable/enable debugging $debug
--strip=0/1 Disable/enable binary stripping $strip
+--sizeopt=0/1 Disable/enable size optimization $sizeopt
+
+--arch=... Describe Operating System ?! $arch
+--cpu=... Describe CPU $cpu
--ipv6=0/1 IPv6 socket support $ipv6
--ssl=... SSL library to use (gnutls, nss, openssl, bogus, auto)
$ssl
+--glib1=0/1 Force usage of glib1 even if glib2 is present
+--glib1prefix=...
+
EOF
exit;
fi
@@ -110,8 +120,13 @@
echo 'CFLAGS=-g' >> Makefile.settings
echo 'DEBUG=1' >> Makefile.settings
echo '#define DEBUG' >> config.h
+ if [ "$sizeopt" = "1" ]; then
+ echo "Warning: won't optimize for size since debug is on."
+ fi
+elif [ "$sizeopt" = "1" ]; then
+ echo 'CFLAGS=-Os' >> Makefile.settings
else
- echo 'CFLAGS=-O3' >> Makefile.settings
+ echo 'CFLAGS=-O2' >> Makefile.settings
fi
echo CFLAGS+=-I`pwd` -I`pwd`/protocols -I. >> Makefile.settings
@@ -138,24 +153,33 @@
exit 1;
fi
-if type pkg-config > /dev/null 2>/dev/null && pkg-config glib-2.0; then
+if [ "$glib1" != "1" ] && \
+ type pkg-config > /dev/null 2>/dev/null && pkg-config glib-2.0; then
cat<<EOF>>Makefile.settings
EFLAGS+=`pkg-config --libs glib-2.0`
CFLAGS+=`pkg-config --cflags glib-2.0`
EOF
echo '#define GLIB2' >> config.h
-elif type glib-config > /dev/null 2> /dev/null; then
+elif [ "x$glib1prefix" = "x" ] && \
+ type glib-config > /dev/null 2> /dev/null; then
cat<<EOF>>Makefile.settings
EFLAGS+=`glib-config --libs`
CFLAGS+=`glib-config --cflags`
EOF
echo '#define GLIB1' >> config.h
+elif [ "x$glib1prefix" != "x" ] && \
+ type "$glib1prefix/bin/glib-config" > /dev/null 2> /dev/null; then
+ cat<<EOF>>Makefile.settings
+EFLAGS+=`$glib1prefix/bin/glib-config --prefix=$glib1prefix --libs`
+CFLAGS+=`$glib1prefix/bin/glib-config --prefix=$glib1prefix --cflags`
+EOF
+ echo '#define GLIB1' >> config.h
else
echo 'Cannot find glib development libraries, aborting. (Install libglib-dev?)'
exit 1;
fi
-if [ -r /usr/include/iconv.h ]; then
+if [ -r "$STAGING_DIR/usr/include/iconv.h" ]; then
:;
elif [ -r /usr/local/include/iconv.h ]; then
echo CFLAGS+=-I/usr/local/include >> Makefile.settings;
@@ -360,6 +384,10 @@
CYGWIN* )
echo 'Cygwin is not officially supported.'
;;
+OpenWrt )
+ echo 'EFLAGS+=-liconv' >> Makefile.settings;
+ echo "CFLAGS+=\"-I$STAGING_DIR/usr/include\"" >> Makefile.settings;
+;;
* )
echo 'We haven'\''t tested BitlBee on many platforms yet, yours is untested. YMMV.'
echo 'Please report any problems at http://bugs.bitlbee.org/.'