[package] update miredo to 1.1.6 (#5204)

git-svn-id: svn://svn.openwrt.org/openwrt/packages@16083 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
florian 2009-05-26 14:40:17 +00:00
parent 877d372ab3
commit 7342aaea47
2 changed files with 12 additions and 12 deletions

View File

@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=miredo
PKG_VERSION:=1.0.0
PKG_VERSION:=1.1.6
PKG_RELEASE:=1
PKG_SOURCE_URL:=http://www.remlab.net/files/miredo/
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_MD5SUM:=b5a51cb98732decc2ada96b2caee5d3c
PKG_MD5SUM:=bf49c1ddc068746760787d0cf76e40de
include $(INCLUDE_DIR)/package.mk
@ -53,6 +53,7 @@ CONFIGURE_ARGS += \
--enable-teredo-relay \
--enable-teredo-server \
--enable-miredo-user=root \
--without-Judy \
CONFIGURE_VARS += \
CPPFLAGS="$$$$CPPFLAGS -I$(STAGING_DIR)/usr/include/uClibc++" \

View File

@ -1,13 +1,12 @@
Index: miredo-1.0.0/libteredo/maintain.c
===================================================================
--- miredo-1.0.0.orig/libteredo/maintain.c 2007-12-30 16:39:41.032377076 +0100
+++ miredo-1.0.0/libteredo/maintain.c 2007-12-30 16:39:54.569148495 +0100
@@ -62,7 +62,7 @@
#define PROBE_SYMMETRIC 3
#define NOT_RUNNING (-1)
diff -urN miredo-1.1.6/libteredo/maintain.c miredo-1.1.6.new/libteredo/maintain.c
--- miredo-1.1.6/libteredo/maintain.c 2009-04-13 11:15:15.000000000 +0200
+++ miredo-1.1.6.new/libteredo/maintain.c 2009-05-26 16:37:14.000000000 +0200
@@ -59,7 +59,7 @@
-#if (_POSIX_CLOCK_SELECTION - 0 >= 0) && (_POSIX_MONOTONIC_CLOCK - 0 >= 0)
+#if (_POSIX_CLOCK_SELECTION - 0 >= 0) && (_POSIX_MONOTONIC_CLOCK - 0 >= 0) && !defined(__UCLIBC__)
static inline void gettime (struct timespec *now)
{
if (clock_gettime (CLOCK_MONOTONIC, now))
-#if (_POSIX_CLOCK_SELECTION - 0 >= 0) && (_POSIX_MONOTONIC_CLOCK - 0 >= 0)
+#if (_POSIX_CLOCK_SELECTION - 0 >= 0) && (_POSIX_MONOTONIC_CLOCK - 0 >= 0) && !defined(__UCLIBC__)
if (clock_gettime (CLOCK_MONOTONIC, now) == 0)
return;
#else