[packages] curl: update to v7.21.7 (CVE-2011-2192)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@29480 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
8245ab81e8
commit
73835c66c4
@ -8,7 +8,7 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=curl
|
||||
PKG_VERSION:=7.21.3
|
||||
PKG_VERSION:=7.21.7
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
@ -19,7 +19,7 @@ PKG_SOURCE_URL:=http://curl.haxx.se/download/ \
|
||||
ftp://ftp.planetmirror.com/pub/curl/ \
|
||||
http://www.mirrormonster.com/curl/download/ \
|
||||
http://curl.mirrors.cyberservers.net/download/
|
||||
PKG_MD5SUM:=5b57fee22090b5c43a6886fdd35af2ce
|
||||
PKG_MD5SUM:=5f6d50c4d4ee38c57fe37e3cff75adbd
|
||||
|
||||
PKG_FIXUP:=libtool
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
|
@ -1,87 +0,0 @@
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -19786,17 +19786,6 @@ $as_echo "no" >&6; }
|
||||
fi
|
||||
rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
|
||||
fi
|
||||
-
|
||||
- if test "$OPENSSL_ENABLED" = "1"; then
|
||||
- if test -n "$LIB_OPENSSL"; then
|
||||
-
|
||||
- LD_LIBRARY_PATH="$LD_LIBRARY_PATH:$LIB_OPENSSL"
|
||||
- export LD_LIBRARY_PATH
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: Added $LIB_OPENSSL to LD_LIBRARY_PATH" >&5
|
||||
-$as_echo "$as_me: Added $LIB_OPENSSL to LD_LIBRARY_PATH" >&6;}
|
||||
- fi
|
||||
- fi
|
||||
-
|
||||
fi
|
||||
|
||||
|
||||
@@ -20252,21 +20241,6 @@ else
|
||||
CPPFLAGS="$CLEANCPPFLAGS"
|
||||
|
||||
fi
|
||||
-
|
||||
-
|
||||
- if test "x$USE_GNUTLS" = "xyes"; then
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: detected GnuTLS version $version" >&5
|
||||
-$as_echo "$as_me: detected GnuTLS version $version" >&6;}
|
||||
-
|
||||
- if test -n "$gtlslib"; then
|
||||
-
|
||||
- LD_LIBRARY_PATH="$LD_LIBRARY_PATH:$gtlslib"
|
||||
- export LD_LIBRARY_PATH
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: Added $gtlslib to LD_LIBRARY_PATH" >&5
|
||||
-$as_echo "$as_me: Added $gtlslib to LD_LIBRARY_PATH" >&6;}
|
||||
- fi
|
||||
- fi
|
||||
-
|
||||
fi
|
||||
|
||||
fi
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -1497,19 +1497,6 @@ if test X"$OPT_SSL" != Xno; then
|
||||
AC_MSG_RESULT([no])
|
||||
])
|
||||
fi
|
||||
-
|
||||
- if test "$OPENSSL_ENABLED" = "1"; then
|
||||
- if test -n "$LIB_OPENSSL"; then
|
||||
- dnl when the ssl shared libs were found in a path that the run-time
|
||||
- dnl linker doesn't search through, we need to add it to LD_LIBRARY_PATH
|
||||
- dnl to prevent further configure tests to fail due to this
|
||||
-
|
||||
- LD_LIBRARY_PATH="$LD_LIBRARY_PATH:$LIB_OPENSSL"
|
||||
- export LD_LIBRARY_PATH
|
||||
- AC_MSG_NOTICE([Added $LIB_OPENSSL to LD_LIBRARY_PATH])
|
||||
- fi
|
||||
- fi
|
||||
-
|
||||
fi
|
||||
|
||||
dnl **********************************************************************
|
||||
@@ -1717,22 +1704,6 @@ if test "$OPENSSL_ENABLED" != "1"; then
|
||||
LIBS="$CLEANLIBS"
|
||||
CPPFLAGS="$CLEANCPPFLAGS"
|
||||
])
|
||||
-
|
||||
- if test "x$USE_GNUTLS" = "xyes"; then
|
||||
- AC_MSG_NOTICE([detected GnuTLS version $version])
|
||||
-
|
||||
- if test -n "$gtlslib"; then
|
||||
- dnl when shared libs were found in a path that the run-time
|
||||
- dnl linker doesn't search through, we need to add it to
|
||||
- dnl LD_LIBRARY_PATH to prevent further configure tests to fail
|
||||
- dnl due to this
|
||||
-
|
||||
- LD_LIBRARY_PATH="$LD_LIBRARY_PATH:$gtlslib"
|
||||
- export LD_LIBRARY_PATH
|
||||
- AC_MSG_NOTICE([Added $gtlslib to LD_LIBRARY_PATH])
|
||||
- fi
|
||||
- fi
|
||||
-
|
||||
fi
|
||||
|
||||
fi dnl GNUTLS not disabled
|
@ -1,22 +1,22 @@
|
||||
--- a/Makefile.am
|
||||
+++ b/Makefile.am
|
||||
@@ -37,7 +37,7 @@ EXTRA_DIST = CHANGES COPYING maketgz Mak
|
||||
@@ -41,7 +41,7 @@ EXTRA_DIST = CHANGES COPYING maketgz Mak
|
||||
bin_SCRIPTS = curl-config
|
||||
|
||||
SUBDIRS = lib src
|
||||
-DIST_SUBDIRS = $(SUBDIRS) tests include packages docs
|
||||
+DIST_SUBDIRS = $(SUBDIRS) include packages
|
||||
SUBDIRS = lib src include
|
||||
-DIST_SUBDIRS = $(SUBDIRS) tests packages docs
|
||||
+DIST_SUBDIRS = $(SUBDIRS) packages
|
||||
|
||||
pkgconfigdir = $(libdir)/pkgconfig
|
||||
pkgconfig_DATA = libcurl.pc
|
||||
--- a/Makefile.in
|
||||
+++ b/Makefile.in
|
||||
@@ -312,7 +312,7 @@ EXTRA_DIST = CHANGES COPYING maketgz Mak
|
||||
@@ -326,7 +326,7 @@ EXTRA_DIST = CHANGES COPYING maketgz Mak
|
||||
|
||||
bin_SCRIPTS = curl-config
|
||||
SUBDIRS = lib src
|
||||
-DIST_SUBDIRS = $(SUBDIRS) tests include packages docs
|
||||
+DIST_SUBDIRS = $(SUBDIRS) include packages
|
||||
SUBDIRS = lib src include
|
||||
-DIST_SUBDIRS = $(SUBDIRS) tests packages docs
|
||||
+DIST_SUBDIRS = $(SUBDIRS) packages
|
||||
pkgconfigdir = $(libdir)/pkgconfig
|
||||
pkgconfig_DATA = libcurl.pc
|
||||
all: all-recursive
|
||||
|
@ -1,22 +1,7 @@
|
||||
--- a/lib/ssluse.c
|
||||
+++ b/lib/ssluse.c
|
||||
@@ -1454,10 +1454,12 @@ ossl_connect_step1(struct connectdata *c
|
||||
req_method = TLSv1_client_method();
|
||||
use_sni(TRUE);
|
||||
break;
|
||||
+#ifndef OPENSSL_NO_SSL2
|
||||
case CURL_SSLVERSION_SSLv2:
|
||||
req_method = SSLv2_client_method();
|
||||
use_sni(FALSE);
|
||||
break;
|
||||
+#endif
|
||||
case CURL_SSLVERSION_SSLv3:
|
||||
req_method = SSLv3_client_method();
|
||||
use_sni(FALSE);
|
||||
--- a/src/main.c
|
||||
+++ b/src/main.c
|
||||
@@ -888,7 +888,9 @@ static void help(void)
|
||||
" -y/--speed-time Time needed to trig speed-limit abort. Defaults to 30",
|
||||
@@ -936,7 +936,9 @@ static void help(void)
|
||||
"Time needed to trig speed-limit abort. Defaults to 30",
|
||||
" --ssl Try SSL/TLS (FTP, IMAP, POP3, SMTP)",
|
||||
" --ssl-reqd Require SSL/TLS (FTP, IMAP, POP3, SMTP)",
|
||||
+#ifndef OPENSSL_NO_SSL2
|
||||
@ -25,7 +10,7 @@
|
||||
" -3/--sslv3 Use SSLv3 (SSL)",
|
||||
" --stderr <file> Where to redirect stderr. - means stdout",
|
||||
" --tcp-nodelay Use the TCP_NODELAY option",
|
||||
@@ -2470,10 +2472,12 @@ static ParameterError getparameter(char
|
||||
@@ -2535,10 +2537,12 @@ static ParameterError getparameter(char
|
||||
/* TLS version 1 */
|
||||
config->ssl_version = CURL_SSLVERSION_TLSv1;
|
||||
break;
|
||||
|
Loading…
x
Reference in New Issue
Block a user