[packages] add dbus-glib
git-svn-id: svn://svn.openwrt.org/openwrt/packages@9108 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
18ddb1e5b7
commit
74b92fc0fc
85
libs/dbus-glib/Makefile
Normal file
85
libs/dbus-glib/Makefile
Normal file
@ -0,0 +1,85 @@
|
||||
#
|
||||
# Copyright (C) 2007 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
# $Id$
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=dbus-glib
|
||||
PKG_VERSION:=0.74
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://dbus.freedesktop.org/releases/dbus-glib/
|
||||
PKG_MD5SUM:=
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
|
||||
define Package/libdbus-glib
|
||||
SECTION:=libs
|
||||
CATEGORY:=Libraries
|
||||
TITLE:=D-Bus Glib bindings
|
||||
URL:=http://dbus.freedesktop.org/doc/dbus-glib/
|
||||
DEPENDS:= +dbus +glib2 +libiconv +libintl
|
||||
endef
|
||||
|
||||
|
||||
CONFIGURE_ARGS += \
|
||||
--enable-shared \
|
||||
--enable-static \
|
||||
--disable-tests \
|
||||
--disable-xml-docs \
|
||||
--disable-doxygen-docs \
|
||||
|
||||
CONFIGURE_VARS+= \
|
||||
ac_cv_func_posix_getpwnam_r="yes" \
|
||||
ac_cv_have_abstract_sockets="yes" \
|
||||
CPPFLAGS="$$$$CPPFLAGS -I$(STAGING_DIR)/usr/lib/libiconv/include" \
|
||||
CPPFLAGS="$$$$CPPFLAGS -I$(STAGING_DIR)/usr/lib/libintl/include" \
|
||||
LDFLAGS="$$$$LDFLAGS -L$(STAGING_DIR)/usr/lib/libiconv/lib" \
|
||||
LDFLAGS="$$$$LDFLAGS -L$(STAGING_DIR)/usr/lib/libintl/lib" \
|
||||
|
||||
|
||||
define Build/Compile
|
||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||
DESTDIR="$(PKG_INSTALL_DIR)" \
|
||||
all install
|
||||
endef
|
||||
|
||||
define Build/InstallDev
|
||||
mkdir -p $(STAGING_DIR)/usr/include/dbus-1.0/dbus
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/include/dbus-1.0/dbus/dbus-glib{,-error-enum,-lowlevel}.h \
|
||||
$(PKG_INSTALL_DIR)/usr/include/dbus-1.0/dbus/dbus-gtype-specialized.h \
|
||||
$(STAGING_DIR)/usr/include//dbus-1.0/dbus/
|
||||
mkdir -p $(STAGING_DIR)/usr/lib
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libdbus-glib-1.{a,so*} \
|
||||
$(STAGING_DIR)/usr/lib/
|
||||
mkdir -p $(STAGING_DIR)/usr/lib/pkgconfig
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/dbus-glib-1.pc \
|
||||
$(STAGING_DIR)/usr/lib/pkgconfig/
|
||||
$(SED) 's,^includedir=.*,includedir=$(STAGING_DIR)/usr/include,g' \
|
||||
$(STAGING_DIR)/usr/lib/pkgconfig/dbus-glib-1.pc
|
||||
$(SED) 's,^libdir=.*,libdir=$(STAGING_DIR)/usr/lib,g' \
|
||||
$(STAGING_DIR)/usr/lib/pkgconfig/dbus-glib-1.pc
|
||||
endef
|
||||
|
||||
define Build/UninstallDev
|
||||
rm -rf $(STAGING_DIR)/usr/include/dbus-1.0/dbus/dbus-glib{,-error-enum,-lowlevel}.h \
|
||||
$(STAGING_DIR)/usr/include/dbus-1.0/dbus/dbus-gtype-specialized.h \
|
||||
$(STAGING_DIR)/usr/lib/libdbus-glib-1.{a,so*} \
|
||||
$(STAGING_DIR)/usr/lib/pkgconfig/dbus-glib-1.pc
|
||||
endef
|
||||
|
||||
|
||||
define Package/libdbus-glib/install
|
||||
$(INSTALL_DIR) $(1)/usr/lib
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libdbus-glib-1.so.* $(1)/usr/lib/
|
||||
endef
|
||||
|
||||
|
||||
$(eval $(call BuildPackage,libdbus-glib))
|
||||
|
26
libs/dbus-glib/patches/001-cross.patch
Normal file
26
libs/dbus-glib/patches/001-cross.patch
Normal file
@ -0,0 +1,26 @@
|
||||
Index: dbus-glib-0.74/dbus/Makefile.in
|
||||
===================================================================
|
||||
--- dbus-glib-0.74.orig/dbus/Makefile.in 2007-10-03 09:03:44.000000000 +0200
|
||||
+++ dbus-glib-0.74/dbus/Makefile.in 2007-10-03 09:03:45.000000000 +0200
|
||||
@@ -292,7 +292,7 @@
|
||||
target_vendor = @target_vendor@
|
||||
top_builddir = @top_builddir@
|
||||
top_srcdir = @top_srcdir@
|
||||
-SUBDIRS = . examples
|
||||
+SUBDIRS = .
|
||||
INCLUDES = \
|
||||
-I$(top_srcdir) \
|
||||
-I$(top_builddir) \
|
||||
Index: dbus-glib-0.74/Makefile.in
|
||||
===================================================================
|
||||
--- dbus-glib-0.74.orig/Makefile.in 2007-10-03 09:04:15.000000000 +0200
|
||||
+++ dbus-glib-0.74/Makefile.in 2007-10-03 09:04:26.000000000 +0200
|
||||
@@ -261,7 +261,7 @@
|
||||
top_builddir = @top_builddir@
|
||||
top_srcdir = @top_srcdir@
|
||||
GLIB_PC = dbus-glib-1.pc
|
||||
-SUBDIRS = dbus tools test doc
|
||||
+SUBDIRS = dbus
|
||||
DIST_SUBDIRS = dbus tools test doc m4
|
||||
pkgconfigdir = $(libdir)/pkgconfig
|
||||
pkgconfig_DATA = $(GLIB_PC)
|
Loading…
x
Reference in New Issue
Block a user