tctool: include unistd.h for close()

We were failing the build due to a missing prototype for close().

Signed-off-by: Florian Fainelli <florian@openwrt.org>

git-svn-id: svn://svn.openwrt.org/openwrt/packages@39921 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
florian 2014-03-13 16:52:10 +00:00
parent dca4c13608
commit 75097a215d
4 changed files with 24 additions and 7 deletions

View File

@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=tctool
PKG_VERSION:=0.9.7
PKG_RELEASE:=2
PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).zip
PKG_SOURCE_URL:=http://download2.berlios.de/speedmodem50b

View File

@ -1,7 +1,6 @@
diff -ur tctool.old/src/Makefile tctool/src/Makefile
--- tctool.old/src/Makefile 2007-01-03 02:32:24.000000000 +0100
+++ tctool/src/Makefile 2007-09-18 19:15:03.068155702 +0200
@@ -31,16 +31,16 @@
--- a/src/Makefile
+++ b/src/Makefile
@@ -31,16 +31,16 @@ MAINOBJ := if.o interface.o etherStream
EXAMPLE := example
EXOBJ := if.o interface.o etherStream.o etherStreambuf.o tcStream.o tcStreambuf.o tcRtsDump.o tcRtsDumpbuf.o

View File

@ -1,5 +1,3 @@
diff --git a/src/tctool.cpp b/src/tctool.cpp
index bbab13f..9ce8e5c 100644
--- a/src/tctool.cpp
+++ b/src/tctool.cpp
@@ -33,6 +33,7 @@

View File

@ -0,0 +1,20 @@
--- a/src/etherStreambuf.cpp
+++ b/src/etherStreambuf.cpp
@@ -28,6 +28,7 @@
#include "etherStreambuf.h"
#include <stdio.h>
+#include <unistd.h>
namespace tc {
etherStreambuf::etherStreambuf() {
--- a/src/tcStreambuf.cpp
+++ b/src/tcStreambuf.cpp
@@ -30,6 +30,7 @@
// this is for the udp-part...
#include <netdb.h> // gethostbyname hostent
#include <arpa/inet.h> // inet_ntoa
+#include <unistd.h>
namespace tc {
char tcStreambuf::tcPktType::confirmation(char pktType) {