bemused: fix build by including more include files
Signed-off-by: Russell Senior <russell@personaltelco.net> git-svn-id: svn://svn.openwrt.org/openwrt/packages@40675 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
201678b4e7
commit
75604d039f
@ -1,5 +1,5 @@
|
|||||||
#
|
#
|
||||||
# Copyright (C) 2008-2011 OpenWrt.org
|
# Copyright (C) 2008-2014 OpenWrt.org
|
||||||
#
|
#
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
# See /LICENSE for more information.
|
# See /LICENSE for more information.
|
||||||
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||||||
|
|
||||||
PKG_NAME:=bemused-mpd
|
PKG_NAME:=bemused-mpd
|
||||||
PKG_VERSION:=r062
|
PKG_VERSION:=r062
|
||||||
PKG_RELEASE:=4
|
PKG_RELEASE:=5
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=http://download.origo.ethz.ch/bemused-lnx-mpdhack/526
|
PKG_SOURCE_URL:=http://download.origo.ethz.ch/bemused-lnx-mpdhack/526
|
||||||
|
@ -1,11 +1,22 @@
|
|||||||
diff -urN bemused-mpd-r062/main.cpp bemused-mpd-r062.new/main.cpp
|
--- a/main.cpp
|
||||||
--- bemused-mpd-r062/main.cpp 2008-02-23 08:01:38.000000000 +0100
|
+++ b/main.cpp
|
||||||
+++ bemused-mpd-r062.new/main.cpp 2010-03-29 13:00:07.000000000 +0200
|
@@ -16,6 +16,9 @@
|
||||||
@@ -16,6 +16,7 @@
|
|
||||||
***************************************************************************/
|
***************************************************************************/
|
||||||
|
|
||||||
#include <stdlib.h>
|
#include <stdlib.h>
|
||||||
+#include <stdio.h>
|
+#include <stdio.h>
|
||||||
|
+#include <getopt.h>
|
||||||
|
+#include <unistd.h>
|
||||||
#include <iostream>
|
#include <iostream>
|
||||||
|
|
||||||
#include "BemusedServerDlg.h"
|
#include "BemusedServerDlg.h"
|
||||||
|
--- a/BemusedServerDlg.cpp
|
||||||
|
+++ b/BemusedServerDlg.cpp
|
||||||
|
@@ -28,6 +28,7 @@
|
||||||
|
#include <cerrno>
|
||||||
|
#include <csignal>
|
||||||
|
|
||||||
|
+#include <unistd.h>
|
||||||
|
#include <sys/types.h>
|
||||||
|
#include <sys/stat.h>
|
||||||
|
#include <dirent.h>
|
||||||
|
@ -1,7 +1,5 @@
|
|||||||
Index: bemused-mpd-r062/Makefile
|
--- a/Makefile
|
||||||
===================================================================
|
+++ b/Makefile
|
||||||
--- bemused-mpd-r062.orig/Makefile 2008-03-31 09:43:54.000000000 +0200
|
|
||||||
+++ bemused-mpd-r062/Makefile 2011-03-06 14:19:07.933096517 +0100
|
|
||||||
@@ -1,8 +1,15 @@
|
@@ -1,8 +1,15 @@
|
||||||
-SHELL = /bin/sh
|
-SHELL = /bin/sh
|
||||||
+LDLIBS = -lbluetooth -lglib -liconv
|
+LDLIBS = -lbluetooth -lglib -liconv
|
||||||
@ -24,10 +22,8 @@ Index: bemused-mpd-r062/Makefile
|
|||||||
+ $(CXX) $(CXXFLAGS) $(CPPFLAGS) $(LDFLAGS) $^ $(LDLIBS) -o $@
|
+ $(CXX) $(CXXFLAGS) $(CPPFLAGS) $(LDFLAGS) $^ $(LDLIBS) -o $@
|
||||||
+
|
+
|
||||||
+all: bemusedlinuxserver
|
+all: bemusedlinuxserver
|
||||||
Index: bemused-mpd-r062/libmpdclient.h
|
--- a/libmpdclient.h
|
||||||
===================================================================
|
+++ b/libmpdclient.h
|
||||||
--- bemused-mpd-r062.orig/libmpdclient.h 2008-04-28 23:03:52.000000000 +0200
|
|
||||||
+++ bemused-mpd-r062/libmpdclient.h 2011-03-06 14:15:34.821307043 +0100
|
|
||||||
@@ -68,11 +68,10 @@
|
@@ -68,11 +68,10 @@
|
||||||
#define MPD_ACK_ERROR_EXIST 56
|
#define MPD_ACK_ERROR_EXIST 56
|
||||||
|
|
||||||
@ -55,10 +51,8 @@ Index: bemused-mpd-r062/libmpdclient.h
|
|||||||
+#endif
|
+#endif
|
||||||
|
|
||||||
#endif
|
#endif
|
||||||
Index: bemused-mpd-r062/mpdctrl.c
|
--- a/mpdctrl.c
|
||||||
===================================================================
|
+++ b/mpdctrl.c
|
||||||
--- bemused-mpd-r062.orig/mpdctrl.c 2008-04-28 23:03:52.000000000 +0200
|
|
||||||
+++ bemused-mpd-r062/mpdctrl.c 2011-03-06 14:15:34.821307043 +0100
|
|
||||||
@@ -59,6 +59,9 @@
|
@@ -59,6 +59,9 @@
|
||||||
|
|
||||||
#define ERROR_DISPLAY 5
|
#define ERROR_DISPLAY 5
|
||||||
|
Loading…
x
Reference in New Issue
Block a user