libiconv-full: move to trunk and add myself as maintainer
git-svn-id: svn://svn.openwrt.org/openwrt/packages@33711 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
c771aec6c1
commit
75eb293515
@ -1,86 +0,0 @@
|
|||||||
#
|
|
||||||
# Copyright (C) 2006-2009 OpenWrt.org
|
|
||||||
#
|
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
|
||||||
# See /LICENSE for more information.
|
|
||||||
#
|
|
||||||
|
|
||||||
include $(TOPDIR)/rules.mk
|
|
||||||
|
|
||||||
PKG_NAME:=libiconv-full
|
|
||||||
PKG_VERSION:=1.11.1
|
|
||||||
PKG_RELEASE:=1
|
|
||||||
|
|
||||||
PKG_SOURCE:=libiconv-$(PKG_VERSION).tar.gz
|
|
||||||
PKG_SOURCE_URL:=@GNU/libiconv
|
|
||||||
PKG_MD5SUM:=d42b97f6ef5dd0ba4469d520ed732fed
|
|
||||||
PKG_BUILD_DIR:=$(BUILD_DIR)/libiconv-$(PKG_VERSION)
|
|
||||||
|
|
||||||
PKG_FIXUP:=patch-libtool
|
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
|
||||||
|
|
||||||
define Package/libiconv-full/Default
|
|
||||||
URL:=http://www.gnu.org/software/libiconv/
|
|
||||||
TITLE:=Character set conversion
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/libiconv-full
|
|
||||||
$(call Package/libiconv-full/Default)
|
|
||||||
SECTION:=libs
|
|
||||||
CATEGORY:=Libraries
|
|
||||||
TITLE+= library
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/libcharset
|
|
||||||
$(call Package/libiconv-full/Default)
|
|
||||||
SECTION:=libs
|
|
||||||
CATEGORY:=Libraries
|
|
||||||
TITLE+= library
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/iconv
|
|
||||||
$(call Package/libiconv-full/Default)
|
|
||||||
DEPENDS:=+libiconv-full +libcharset
|
|
||||||
SECTION:=utils
|
|
||||||
CATEGORY:=Utilities
|
|
||||||
TITLE+= utility
|
|
||||||
endef
|
|
||||||
|
|
||||||
TARGET_CFLAGS += $(FPIC) -DUSE_DOS
|
|
||||||
|
|
||||||
CONFIGURE_ARGS += \
|
|
||||||
--enable-shared \
|
|
||||||
--enable-static \
|
|
||||||
--disable-rpath \
|
|
||||||
--enable-relocatable
|
|
||||||
|
|
||||||
define Build/Compile
|
|
||||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
|
||||||
CC="$(TARGET_CC)" \
|
|
||||||
DESTDIR="$(PKG_INSTALL_DIR)" \
|
|
||||||
install
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Build/InstallDev
|
|
||||||
$(INSTALL_DIR) $(1)/usr/lib/libiconv-full/include
|
|
||||||
$(CP) $(PKG_INSTALL_DIR)/usr/include/iconv.h $(1)/usr/lib/libiconv-full/include/
|
|
||||||
|
|
||||||
$(INSTALL_DIR) $(1)/usr/lib/libiconv-full/lib
|
|
||||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libcharset.{a,so*} $(1)/usr/lib/libiconv-full/lib/
|
|
||||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libiconv.{a,so*} $(1)/usr/lib/libiconv-full/lib/
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/libcharset/install
|
|
||||||
$(INSTALL_DIR) $(1)/usr/lib
|
|
||||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libcharset.so* $(1)/usr/lib/
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/libiconv-full/install
|
|
||||||
$(INSTALL_DIR) $(1)/usr/lib
|
|
||||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libiconv.so* $(1)/usr/lib/
|
|
||||||
endef
|
|
||||||
|
|
||||||
$(eval $(call BuildPackage,libcharset))
|
|
||||||
$(eval $(call BuildPackage,libiconv-full))
|
|
||||||
$(eval $(call BuildPackage,iconv))
|
|
File diff suppressed because it is too large
Load Diff
File diff suppressed because it is too large
Load Diff
@ -1,31 +0,0 @@
|
|||||||
--- /dev/null
|
|
||||||
+++ b/Makefile.am
|
|
||||||
@@ -0,0 +1,2 @@
|
|
||||||
+ACLOCAL_AMFLAGS = -I m4
|
|
||||||
+SUBDIRS = .
|
|
||||||
--- /dev/null
|
|
||||||
+++ b/libcharset/Makefile.am
|
|
||||||
@@ -0,0 +1 @@
|
|
||||||
+ACLOCAL_AMFLAGS = -I m4
|
|
||||||
--- a/configure.ac
|
|
||||||
+++ b/configure.ac
|
|
||||||
@@ -54,7 +54,7 @@ AC_ISC_POSIX
|
|
||||||
|
|
||||||
dnl checks for installer options
|
|
||||||
|
|
||||||
-AC_RELOCATABLE
|
|
||||||
+gl_RELOCATABLE
|
|
||||||
|
|
||||||
AC_ARG_ENABLE([extra-encodings],
|
|
||||||
[AC_HELP_STRING([--enable-extra-encodings],
|
|
||||||
--- a/libcharset/configure.ac
|
|
||||||
+++ b/libcharset/configure.ac
|
|
||||||
@@ -41,7 +41,7 @@ AC_CANONICAL_HOST
|
|
||||||
|
|
||||||
dnl checks for installer options
|
|
||||||
|
|
||||||
-AC_RELOCATABLE_LIBRARY
|
|
||||||
+gl_RELOCATABLE_LIBRARY
|
|
||||||
|
|
||||||
dnl checks for programs
|
|
||||||
|
|
@ -1,17 +0,0 @@
|
|||||||
Make iconv 1.11.x link correctly with libtool2 - argument "-Xcompiler" ensures "-shared" is passed to $(CC) when used as linker. Otherwise $(CC) tries to create an executable and fails while looking for a main()-function
|
|
||||||
|
|
||||||
diff -ruN libiconv-1.11.1/lib/Makefile.in libiconv-1.11.1.mod/lib/Makefile.in
|
|
||||||
--- libiconv-1.11.1/lib/Makefile.in 2006-07-14 15:18:42.000000000 +0200
|
|
||||||
+++ libiconv-1.11.1.mod/lib/Makefile.in 2010-12-01 20:47:57.000000000 +0100
|
|
||||||
@@ -70,9 +70,9 @@
|
|
||||||
|
|
||||||
preloadable_libiconv_linux.so : $(SOURCES)
|
|
||||||
if test -n "@GCC@"; then \
|
|
||||||
- $(LIBTOOL_LINK) $(CC) $(LDFLAGS) $(INCLUDES) $(CFLAGS) $(CPPFLAGS) $(DEFS) -fPIC -DPIC -DLIBICONV_PLUG $(SOURCES) -shared -o preloadable_libiconv_linux.so; \
|
|
||||||
+ $(LIBTOOL_LINK) $(CC) $(LDFLAGS) $(INCLUDES) $(CFLAGS) $(CPPFLAGS) $(DEFS) -fPIC -DPIC -DLIBICONV_PLUG $(SOURCES) -Xcompiler -shared -o preloadable_libiconv_linux.so; \
|
|
||||||
else \
|
|
||||||
- $(LIBTOOL_LINK) $(CC) $(LDFLAGS) $(INCLUDES) $(CFLAGS) $(CPPFLAGS) $(DEFS) -KPIC -DPIC -DLIBICONV_PLUG $(SOURCES) -shared -o preloadable_libiconv_linux.so; \
|
|
||||||
+ $(LIBTOOL_LINK) $(CC) $(LDFLAGS) $(INCLUDES) $(CFLAGS) $(CPPFLAGS) $(DEFS) -KPIC -DPIC -DLIBICONV_PLUG $(SOURCES) -Xcompiler -shared -o preloadable_libiconv_linux.so; \
|
|
||||||
fi
|
|
||||||
|
|
||||||
preloadable_libiconv_solaris.so : $(SOURCES)
|
|
Loading…
x
Reference in New Issue
Block a user