[packages] samba3: add missing patches from previous update commit, refresh series
git-svn-id: svn://svn.openwrt.org/openwrt/packages@29351 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
d014159f03
commit
75fc5f5cf3
File diff suppressed because it is too large
Load Diff
@ -42,241 +42,3 @@
|
||||
/* first set the signal handler */
|
||||
if(linux_set_lease_sighandler(fd) == -1)
|
||||
return -1;
|
||||
--- a/source/configure
|
||||
+++ b/source/configure
|
||||
@@ -37206,194 +37206,6 @@ fi
|
||||
rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
|
||||
|
||||
#
|
||||
-#
|
||||
-#
|
||||
-case "$host_os" in
|
||||
- *linux*)
|
||||
- # glibc <= 2.3.2 has a broken getgrouplist
|
||||
- if test "$cross_compiling" = yes; then
|
||||
- { { $as_echo "$as_me:$LINENO: error: in \`$ac_pwd':" >&5
|
||||
-$as_echo "$as_me: error: in \`$ac_pwd':" >&2;}
|
||||
-{ { $as_echo "$as_me:$LINENO: error: cannot run test program while cross compiling
|
||||
-See \`config.log' for more details." >&5
|
||||
-$as_echo "$as_me: error: cannot run test program while cross compiling
|
||||
-See \`config.log' for more details." >&2;}
|
||||
- { (exit 1); exit 1; }; }; }
|
||||
-else
|
||||
- cat >conftest.$ac_ext <<_ACEOF
|
||||
-/* confdefs.h. */
|
||||
-_ACEOF
|
||||
-cat confdefs.h >>conftest.$ac_ext
|
||||
-cat >>conftest.$ac_ext <<_ACEOF
|
||||
-/* end confdefs.h. */
|
||||
-
|
||||
-#include <unistd.h>
|
||||
-#include <sys/utsname.h>
|
||||
-main() {
|
||||
- /* glibc up to 2.3 has a broken getgrouplist */
|
||||
-#if defined(__GLIBC__) && defined(__GLIBC_MINOR__)
|
||||
- int libc_major = __GLIBC__;
|
||||
- int libc_minor = __GLIBC_MINOR__;
|
||||
-
|
||||
- if (libc_major < 2)
|
||||
- exit(1);
|
||||
- if ((libc_major == 2) && (libc_minor <= 3))
|
||||
- exit(1);
|
||||
-#endif
|
||||
- exit(0);
|
||||
-}
|
||||
-
|
||||
-_ACEOF
|
||||
-rm -f conftest$ac_exeext
|
||||
-if { (ac_try="$ac_link"
|
||||
-case "(($ac_try" in
|
||||
- *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
|
||||
- *) ac_try_echo=$ac_try;;
|
||||
-esac
|
||||
-eval ac_try_echo="\"\$as_me:$LINENO: $ac_try_echo\""
|
||||
-$as_echo "$ac_try_echo") >&5
|
||||
- (eval "$ac_link") 2>&5
|
||||
- ac_status=$?
|
||||
- $as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
||||
- (exit $ac_status); } && { ac_try='./conftest$ac_exeext'
|
||||
- { (case "(($ac_try" in
|
||||
- *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
|
||||
- *) ac_try_echo=$ac_try;;
|
||||
-esac
|
||||
-eval ac_try_echo="\"\$as_me:$LINENO: $ac_try_echo\""
|
||||
-$as_echo "$ac_try_echo") >&5
|
||||
- (eval "$ac_try") 2>&5
|
||||
- ac_status=$?
|
||||
- $as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
||||
- (exit $ac_status); }; }; then
|
||||
- linux_getgrouplist_ok=yes
|
||||
-else
|
||||
- $as_echo "$as_me: program exited with status $ac_status" >&5
|
||||
-$as_echo "$as_me: failed program was:" >&5
|
||||
-sed 's/^/| /' conftest.$ac_ext >&5
|
||||
-
|
||||
-( exit $ac_status )
|
||||
-linux_getgrouplist_ok=no
|
||||
-fi
|
||||
-rm -rf conftest.dSYM
|
||||
-rm -f core *.core core.conftest.* gmon.out bb.out conftest$ac_exeext conftest.$ac_objext conftest.$ac_ext
|
||||
-fi
|
||||
-
|
||||
-
|
||||
- if test x"$linux_getgrouplist_ok" = x"yes"; then
|
||||
-
|
||||
-cat >>confdefs.h <<\_ACEOF
|
||||
-#define HAVE_GETGROUPLIST 1
|
||||
-_ACEOF
|
||||
-
|
||||
- fi
|
||||
- ;;
|
||||
- *)
|
||||
-
|
||||
-for ac_func in getgrouplist
|
||||
-do
|
||||
-as_ac_var=`$as_echo "ac_cv_func_$ac_func" | $as_tr_sh`
|
||||
-{ $as_echo "$as_me:$LINENO: checking for $ac_func" >&5
|
||||
-$as_echo_n "checking for $ac_func... " >&6; }
|
||||
-if { as_var=$as_ac_var; eval "test \"\${$as_var+set}\" = set"; }; then
|
||||
- $as_echo_n "(cached) " >&6
|
||||
-else
|
||||
- cat >conftest.$ac_ext <<_ACEOF
|
||||
-/* confdefs.h. */
|
||||
-_ACEOF
|
||||
-cat confdefs.h >>conftest.$ac_ext
|
||||
-cat >>conftest.$ac_ext <<_ACEOF
|
||||
-/* end confdefs.h. */
|
||||
-/* Define $ac_func to an innocuous variant, in case <limits.h> declares $ac_func.
|
||||
- For example, HP-UX 11i <limits.h> declares gettimeofday. */
|
||||
-#define $ac_func innocuous_$ac_func
|
||||
-
|
||||
-/* System header to define __stub macros and hopefully few prototypes,
|
||||
- which can conflict with char $ac_func (); below.
|
||||
- Prefer <limits.h> to <assert.h> if __STDC__ is defined, since
|
||||
- <limits.h> exists even on freestanding compilers. */
|
||||
-
|
||||
-#ifdef __STDC__
|
||||
-# include <limits.h>
|
||||
-#else
|
||||
-# include <assert.h>
|
||||
-#endif
|
||||
-
|
||||
-#undef $ac_func
|
||||
-
|
||||
-/* Override any GCC internal prototype to avoid an error.
|
||||
- Use char because int might match the return type of a GCC
|
||||
- builtin and then its argument prototype would still apply. */
|
||||
-#ifdef __cplusplus
|
||||
-extern "C"
|
||||
-#endif
|
||||
-char $ac_func ();
|
||||
-/* The GNU C library defines this for functions which it implements
|
||||
- to always fail with ENOSYS. Some functions are actually named
|
||||
- something starting with __ and the normal name is an alias. */
|
||||
-#if defined __stub_$ac_func || defined __stub___$ac_func
|
||||
-choke me
|
||||
-#endif
|
||||
-
|
||||
-int
|
||||
-main ()
|
||||
-{
|
||||
-return $ac_func ();
|
||||
- ;
|
||||
- return 0;
|
||||
-}
|
||||
-_ACEOF
|
||||
-rm -f conftest.$ac_objext conftest$ac_exeext
|
||||
-if { (ac_try="$ac_link"
|
||||
-case "(($ac_try" in
|
||||
- *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
|
||||
- *) ac_try_echo=$ac_try;;
|
||||
-esac
|
||||
-eval ac_try_echo="\"\$as_me:$LINENO: $ac_try_echo\""
|
||||
-$as_echo "$ac_try_echo") >&5
|
||||
- (eval "$ac_link") 2>conftest.er1
|
||||
- ac_status=$?
|
||||
- grep -v '^ *+' conftest.er1 >conftest.err
|
||||
- rm -f conftest.er1
|
||||
- cat conftest.err >&5
|
||||
- $as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
||||
- (exit $ac_status); } && {
|
||||
- test -z "$ac_c_werror_flag" ||
|
||||
- test ! -s conftest.err
|
||||
- } && test -s conftest$ac_exeext && {
|
||||
- test "$cross_compiling" = yes ||
|
||||
- $as_test_x conftest$ac_exeext
|
||||
- }; then
|
||||
- eval "$as_ac_var=yes"
|
||||
-else
|
||||
- $as_echo "$as_me: failed program was:" >&5
|
||||
-sed 's/^/| /' conftest.$ac_ext >&5
|
||||
-
|
||||
- eval "$as_ac_var=no"
|
||||
-fi
|
||||
-
|
||||
-rm -rf conftest.dSYM
|
||||
-rm -f core conftest.err conftest.$ac_objext conftest_ipa8_conftest.oo \
|
||||
- conftest$ac_exeext conftest.$ac_ext
|
||||
-fi
|
||||
-ac_res=`eval 'as_val=${'$as_ac_var'}
|
||||
- $as_echo "$as_val"'`
|
||||
- { $as_echo "$as_me:$LINENO: result: $ac_res" >&5
|
||||
-$as_echo "$ac_res" >&6; }
|
||||
-as_val=`eval 'as_val=${'$as_ac_var'}
|
||||
- $as_echo "$as_val"'`
|
||||
- if test "x$as_val" = x""yes; then
|
||||
- cat >>confdefs.h <<_ACEOF
|
||||
-#define `$as_echo "HAVE_$ac_func" | $as_tr_cpp` 1
|
||||
-_ACEOF
|
||||
-
|
||||
-fi
|
||||
-done
|
||||
-
|
||||
- ;;
|
||||
-esac
|
||||
-
|
||||
-#
|
||||
# stat64 family may need <sys/stat.h> on some systems, notably ReliantUNIX
|
||||
#
|
||||
|
||||
--- a/source/configure.in
|
||||
+++ b/source/configure.in
|
||||
@@ -1384,38 +1384,6 @@ AC_TRY_COMPILE([
|
||||
AC_DEFINE(HAVE_PRCTL, 1, [Whether prctl is available]),[])
|
||||
|
||||
#
|
||||
-#
|
||||
-#
|
||||
-case "$host_os" in
|
||||
- *linux*)
|
||||
- # glibc <= 2.3.2 has a broken getgrouplist
|
||||
- AC_TRY_RUN([
|
||||
-#include <unistd.h>
|
||||
-#include <sys/utsname.h>
|
||||
-main() {
|
||||
- /* glibc up to 2.3 has a broken getgrouplist */
|
||||
-#if defined(__GLIBC__) && defined(__GLIBC_MINOR__)
|
||||
- int libc_major = __GLIBC__;
|
||||
- int libc_minor = __GLIBC_MINOR__;
|
||||
-
|
||||
- if (libc_major < 2)
|
||||
- exit(1);
|
||||
- if ((libc_major == 2) && (libc_minor <= 3))
|
||||
- exit(1);
|
||||
-#endif
|
||||
- exit(0);
|
||||
-}
|
||||
-], [linux_getgrouplist_ok=yes], [linux_getgrouplist_ok=no])
|
||||
- if test x"$linux_getgrouplist_ok" = x"yes"; then
|
||||
- AC_DEFINE(HAVE_GETGROUPLIST, 1, [Have good getgrouplist])
|
||||
- fi
|
||||
- ;;
|
||||
- *)
|
||||
- AC_CHECK_FUNCS(getgrouplist)
|
||||
- ;;
|
||||
-esac
|
||||
-
|
||||
-#
|
||||
# stat64 family may need <sys/stat.h> on some systems, notably ReliantUNIX
|
||||
#
|
||||
|
||||
|
@ -1,8 +1,6 @@
|
||||
Index: samba-3.0.37/source/Makefile.in
|
||||
===================================================================
|
||||
--- samba-3.0.37.orig/source/Makefile.in 2009-09-30 14:21:56.000000000 +0200
|
||||
+++ samba-3.0.37/source/Makefile.in 2011-04-03 20:35:19.000000000 +0200
|
||||
@@ -92,7 +92,7 @@
|
||||
--- a/source/Makefile.in
|
||||
+++ b/source/Makefile.in
|
||||
@@ -92,7 +92,7 @@ INSTALLPERMS = 0755
|
||||
# or in smb.conf (see smb.conf(5))
|
||||
LOGFILEBASE = @logfilebase@
|
||||
CONFIGFILE = $(CONFIGDIR)/smb.conf
|
||||
@ -11,11 +9,9 @@ Index: samba-3.0.37/source/Makefile.in
|
||||
|
||||
# This is where smbpasswd et al go
|
||||
PRIVATEDIR = @privatedir@
|
||||
Index: samba-3.0.37/source/configure
|
||||
===================================================================
|
||||
--- samba-3.0.37.orig/source/configure 2009-09-30 15:08:58.000000000 +0200
|
||||
+++ samba-3.0.37/source/configure 2011-04-03 20:35:20.000000000 +0200
|
||||
@@ -1536,8 +1536,8 @@
|
||||
--- a/source/configure
|
||||
+++ b/source/configure
|
||||
@@ -1536,8 +1536,8 @@ Optional Packages:
|
||||
--with-fhs Use FHS-compliant paths (default=no)
|
||||
--with-privatedir=DIR Where to put smbpasswd ($ac_default_prefix/private)
|
||||
--with-rootsbindir=DIR Which directory to use for root sbin ($ac_default_prefix/sbin)
|
||||
@ -26,7 +22,7 @@ Index: samba-3.0.37/source/configure
|
||||
--with-swatdir=DIR Where to put SWAT files ($ac_default_prefix/swat)
|
||||
--with-configdir=DIR Where to put configuration files ($libdir)
|
||||
--with-logfilebase=DIR Where to put log files ($VARDIR)
|
||||
@@ -2295,8 +2295,8 @@
|
||||
@@ -2295,8 +2295,8 @@ fi
|
||||
|
||||
|
||||
rootsbindir="\${SBINDIR}"
|
||||
|
@ -1,8 +1,6 @@
|
||||
Index: samba-3.0.37/source/Makefile.in
|
||||
===================================================================
|
||||
--- samba-3.0.37.orig/source/Makefile.in 2011-08-08 23:40:18.004444730 +0200
|
||||
+++ samba-3.0.37/source/Makefile.in 2011-08-08 23:40:19.054444730 +0200
|
||||
@@ -538,10 +538,7 @@
|
||||
--- a/source/Makefile.in
|
||||
+++ b/source/Makefile.in
|
||||
@@ -538,10 +538,7 @@ TESTPARM_OBJ = utils/testparm.o \
|
||||
|
||||
PASSWD_UTIL_OBJ = utils/passwd_util.o
|
||||
|
||||
@ -14,10 +12,8 @@ Index: samba-3.0.37/source/Makefile.in
|
||||
|
||||
PDBEDIT_OBJ = utils/pdbedit.o $(PASSWD_UTIL_OBJ) $(PARAM_OBJ) $(PASSDB_OBJ) \
|
||||
$(LIBSAMBA_OBJ) $(LIB_NONSMBD_OBJ) $(GROUPDB_OBJ) \
|
||||
Index: samba-3.0.37/source/utils/owrt_smbpasswd.c
|
||||
===================================================================
|
||||
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
|
||||
+++ samba-3.0.37/source/utils/owrt_smbpasswd.c 2011-08-08 23:40:19.064444730 +0200
|
||||
--- /dev/null
|
||||
+++ b/source/utils/owrt_smbpasswd.c
|
||||
@@ -0,0 +1,195 @@
|
||||
+/*
|
||||
+ * Copyright (C) John Crispin <blogic@openwrt.org>
|
||||
|
@ -1,8 +1,6 @@
|
||||
Index: samba-3.0.24/source/lib/ms_fnmatch.c
|
||||
===================================================================
|
||||
--- samba-3.0.24.orig/source/lib/ms_fnmatch.c 2008-08-11 11:08:03.000000000 +0200
|
||||
+++ samba-3.0.24/source/lib/ms_fnmatch.c 2008-08-11 11:11:33.000000000 +0200
|
||||
@@ -153,6 +153,10 @@
|
||||
--- a/source/lib/ms_fnmatch.c
|
||||
+++ b/source/lib/ms_fnmatch.c
|
||||
@@ -153,6 +153,10 @@ int ms_fnmatch(const char *pattern, cons
|
||||
int ret, count, i;
|
||||
struct max_n *max_n = NULL;
|
||||
|
||||
|
@ -1,8 +1,6 @@
|
||||
Index: samba-3.0.24/source/lib/popt_common.c
|
||||
===================================================================
|
||||
--- samba-3.0.24.orig/source/lib/popt_common.c 2008-08-11 11:25:26.000000000 +0200
|
||||
+++ samba-3.0.24/source/lib/popt_common.c 2008-08-11 11:26:03.000000000 +0200
|
||||
@@ -54,7 +54,7 @@
|
||||
--- a/source/lib/popt_common.c
|
||||
+++ b/source/lib/popt_common.c
|
||||
@@ -54,7 +54,7 @@ static void set_logfile(poptContext con,
|
||||
else
|
||||
pname++;
|
||||
|
||||
|
@ -1,9 +1,7 @@
|
||||
|
||||
Index: samba-3.0.37/source/configure
|
||||
===================================================================
|
||||
--- samba-3.0.37.orig/source/configure 2011-04-03 20:35:20.000000000 +0200
|
||||
+++ samba-3.0.37/source/configure 2011-04-03 20:36:51.000000000 +0200
|
||||
@@ -22548,6 +22548,17 @@
|
||||
--- a/source/configure
|
||||
+++ b/source/configure
|
||||
@@ -22548,6 +22548,17 @@ rm -f conftest.err conftest.$ac_ext
|
||||
{ $as_echo "$as_me:$LINENO: result: $ac_header_preproc" >&5
|
||||
$as_echo "$ac_header_preproc" >&6; }
|
||||
|
||||
|
12
net/samba3/patches/200-fix-configure.patch
Normal file
12
net/samba3/patches/200-fix-configure.patch
Normal file
@ -0,0 +1,12 @@
|
||||
Get rid of error due to cross compilation, as glibc version in OpenWRT is high enough
|
||||
--- a/source/configure
|
||||
+++ b/source/configure
|
||||
@@ -37222,7 +37222,7 @@ rm -f core conftest.err conftest.$ac_obj
|
||||
case "$host_os" in
|
||||
*linux*)
|
||||
# glibc <= 2.3.2 has a broken getgrouplist
|
||||
- if test "$cross_compiling" = yes; then
|
||||
+ if test "false" = yes; then
|
||||
{ { $as_echo "$as_me:$LINENO: error: in \`$ac_pwd':" >&5
|
||||
$as_echo "$as_me: error: in \`$ac_pwd':" >&2;}
|
||||
{ { $as_echo "$as_me:$LINENO: error: cannot run test program while cross compiling
|
76
net/samba3/patches/500-remove_avm_smaller.patch
Normal file
76
net/samba3/patches/500-remove_avm_smaller.patch
Normal file
@ -0,0 +1,76 @@
|
||||
--- a/source/Makefile.in
|
||||
+++ b/source/Makefile.in
|
||||
@@ -291,7 +291,7 @@ SECRETS_OBJ = passdb/secrets.o passdb/ma
|
||||
LIBNMB_OBJ = libsmb/unexpected.o libsmb/namecache.o libsmb/nmblib.o \
|
||||
libsmb/namequery.o libsmb/conncache.o libads/dns.o
|
||||
|
||||
-LIBSAMBA_OBJ = libsmb/nterr.o libsmb/dcerpc_err.o libsmb/smbdes.o \
|
||||
+LIBSAMBA_OBJ = libsmb/nterr.o $(if $(OWRT_SMALLER),,libsmb/dcerpc_err.o) libsmb/smbdes.o \
|
||||
libsmb/smbencrypt.o libsmb/ntlm_check.o \
|
||||
libsmb/ntlmssp.o libsmb/ntlmssp_parse.o libsmb/ntlmssp_sign.o
|
||||
|
||||
@@ -323,35 +323,35 @@ REGISTRY_OBJ = registry/reg_frontend.o r
|
||||
registry/reg_db.o registry/reg_eventlog.o registry/reg_shares.o \
|
||||
registry/reg_util.o registry/reg_dynamic.o registry/reg_perfcount.o
|
||||
|
||||
-RPC_LSA_OBJ = rpc_server/srv_lsa.o rpc_server/srv_lsa_nt.o
|
||||
+RPC_LSA_OBJ = $(if $(OWRT_SMALLER),,rpc_server/srv_lsa.o rpc_server/srv_lsa_nt.o)
|
||||
|
||||
-RPC_NETLOG_OBJ = rpc_server/srv_netlog.o rpc_server/srv_netlog_nt.o
|
||||
+RPC_NETLOG_OBJ = $(if $(OWRT_SMALLER),,rpc_server/srv_netlog.o rpc_server/srv_netlog_nt.o)
|
||||
|
||||
-RPC_SAMR_OBJ = rpc_server/srv_samr.o rpc_server/srv_samr_nt.o \
|
||||
- rpc_server/srv_samr_util.o
|
||||
+RPC_SAMR_OBJ = $(if $(OWRT_SMALLER),,rpc_server/srv_samr.o rpc_server/srv_samr_nt.o \
|
||||
+ rpc_server/srv_samr_util.o)
|
||||
|
||||
REGFIO_OBJ = registry/regfio.o
|
||||
|
||||
-RPC_REG_OBJ = rpc_server/srv_reg.o rpc_server/srv_reg_nt.o $(REGFIO_OBJ)
|
||||
+RPC_REG_OBJ = $(if $(OWRT_SMALLER),,rpc_server/srv_reg.o rpc_server/srv_reg_nt.o $(REGFIO_OBJ))
|
||||
|
||||
-RPC_LSA_DS_OBJ = rpc_server/srv_lsa_ds.o rpc_server/srv_lsa_ds_nt.o
|
||||
+RPC_LSA_DS_OBJ = $(if $(OWRT_SMALLER),,rpc_server/srv_lsa_ds.o rpc_server/srv_lsa_ds_nt.o)
|
||||
|
||||
RPC_SVC_OBJ = rpc_server/srv_srvsvc.o rpc_server/srv_srvsvc_nt.o
|
||||
|
||||
RPC_WKS_OBJ = librpc/gen_ndr/srv_wkssvc.o rpc_server/srv_wkssvc_nt.o
|
||||
|
||||
-RPC_SVCCTL_OBJ = rpc_server/srv_svcctl.o rpc_server/srv_svcctl_nt.o \
|
||||
+RPC_SVCCTL_OBJ = $(if $(OWRT_SMALLER),, rpc_server/srv_svcctl.o) rpc_server/srv_svcctl_nt.o \
|
||||
services/svc_spoolss.o services/svc_rcinit.o services/services_db.o \
|
||||
services/svc_netlogon.o services/svc_winreg.o \
|
||||
services/svc_wins.o
|
||||
|
||||
-RPC_NTSVCS_OBJ = rpc_server/srv_ntsvcs.o rpc_server/srv_ntsvcs_nt.o
|
||||
+RPC_NTSVCS_OBJ = $(if $(OWRT_SMALLER),,rpc_server/srv_ntsvcs.o rpc_server/srv_ntsvcs_nt.o)
|
||||
|
||||
-RPC_DFS_OBJ = rpc_server/srv_dfs.o rpc_server/srv_dfs_nt.o
|
||||
+RPC_DFS_OBJ = $(if $(OWRT_SMALLER),,rpc_server/srv_dfs.o rpc_server/srv_dfs_nt.o)
|
||||
|
||||
-RPC_SPOOLSS_OBJ = rpc_server/srv_spoolss.o rpc_server/srv_spoolss_nt.o
|
||||
+RPC_SPOOLSS_OBJ = $(if $(OWRT_SMALLER),,rpc_server/srv_spoolss.o rpc_server/srv_spoolss_nt.o)
|
||||
|
||||
-RPC_EVENTLOG_OBJ = rpc_server/srv_eventlog.o rpc_server/srv_eventlog_nt.o rpc_server/srv_eventlog_lib.o
|
||||
+RPC_EVENTLOG_OBJ = $(if $(OWRT_SMALLER),,rpc_server/srv_eventlog.o rpc_server/srv_eventlog_nt.o rpc_server/srv_eventlog_lib.o)
|
||||
|
||||
RPC_PIPE_OBJ = rpc_server/srv_pipe_hnd.o \
|
||||
rpc_server/srv_pipe.o rpc_server/srv_lsa_hnd.o
|
||||
@@ -431,7 +431,7 @@ PLAINTEXT_AUTH_OBJ = auth/pampass.o auth
|
||||
|
||||
SLCACHE_OBJ = libsmb/samlogon_cache.o
|
||||
|
||||
-DCUTIL_OBJ = libsmb/namequery_dc.o libsmb/trustdom_cache.o libsmb/trusts_util.o
|
||||
+DCUTIL_OBJ = libsmb/namequery_dc.o $(if $(OWRT_SMALLER),,libsmb/trustdom_cache.o libsmb/trusts_util.o)
|
||||
|
||||
AUTH_BUILTIN_OBJ = auth/auth_builtin.o
|
||||
AUTH_DOMAIN_OBJ = auth/auth_domain.o
|
||||
@@ -468,7 +468,7 @@ SMBD_OBJ_SRV = smbd/files.o smbd/chgpass
|
||||
smbd/change_trust_pw.o smbd/fake_file.o \
|
||||
smbd/ntquotas.o $(AFS_OBJ) smbd/msdfs.o \
|
||||
$(AFS_SETTOKEN_OBJ) smbd/aio.o smbd/statvfs.o \
|
||||
- smbd/dmapi.o $(MANGLE_OBJ) @VFS_STATIC@
|
||||
+ $(if $(OWRT_SMALLER),,smbd/dmapi.o) $(MANGLE_OBJ) @VFS_STATIC@
|
||||
|
||||
SMBD_OBJ_BASE = $(PARAM_OBJ) $(SMBD_OBJ_SRV) $(LIBSMB_OBJ) \
|
||||
$(RPC_SERVER_OBJ) $(RPC_PARSE_OBJ) $(SECRETS_OBJ) \
|
47
net/samba3/patches/510-remove-printing.patch
Normal file
47
net/samba3/patches/510-remove-printing.patch
Normal file
@ -0,0 +1,47 @@
|
||||
--- a/source/Makefile.in
|
||||
+++ b/source/Makefile.in
|
||||
@@ -319,7 +319,7 @@ LIBMSRPC_GEN_OBJ = librpc/gen_ndr/cli_wk
|
||||
|
||||
REGOBJS_OBJ = registry/reg_objects.o
|
||||
|
||||
-REGISTRY_OBJ = registry/reg_frontend.o registry/reg_cachehook.o registry/reg_printing.o \
|
||||
+REGISTRY_OBJ = registry/reg_frontend.o registry/reg_cachehook.o $(if $(OWRT_NO_PRINTING),,registry/reg_printing.o) \
|
||||
registry/reg_db.o registry/reg_eventlog.o registry/reg_shares.o \
|
||||
registry/reg_util.o registry/reg_dynamic.o registry/reg_perfcount.o
|
||||
|
||||
@@ -349,7 +349,7 @@ RPC_NTSVCS_OBJ = $(if $(OWRT_SMALLER),,r
|
||||
|
||||
RPC_DFS_OBJ = $(if $(OWRT_SMALLER),,rpc_server/srv_dfs.o rpc_server/srv_dfs_nt.o)
|
||||
|
||||
-RPC_SPOOLSS_OBJ = $(if $(OWRT_SMALLER),,rpc_server/srv_spoolss.o rpc_server/srv_spoolss_nt.o)
|
||||
+RPC_SPOOLSS_OBJ = $(if $(OWRT_SMALLER)$(OWRT_NO_PRINTING),,rpc_server/srv_spoolss.o rpc_server/srv_spoolss_nt.o)
|
||||
|
||||
RPC_EVENTLOG_OBJ = $(if $(OWRT_SMALLER),,rpc_server/srv_eventlog.o rpc_server/srv_eventlog_nt.o rpc_server/srv_eventlog_lib.o)
|
||||
|
||||
@@ -463,7 +463,7 @@ SMBD_OBJ_SRV = smbd/files.o smbd/chgpass
|
||||
smbd/vfs.o smbd/statcache.o \
|
||||
smbd/posix_acls.o lib/sysacls.o $(SERVER_MUTEX_OBJ) \
|
||||
smbd/process.o smbd/service.o smbd/error.o \
|
||||
- printing/printfsp.o lib/sysquotas.o lib/sysquotas_linux.o \
|
||||
+ $(if $(OWRT_NO_PRINTING),,printing/printfsp.o) lib/sysquotas.o lib/sysquotas_linux.o \
|
||||
lib/sysquotas_xfs.o lib/sysquotas_4A.o \
|
||||
smbd/change_trust_pw.o smbd/fake_file.o \
|
||||
smbd/ntquotas.o $(AFS_OBJ) smbd/msdfs.o \
|
||||
@@ -480,13 +480,13 @@ SMBD_OBJ_BASE = $(PARAM_OBJ) $(SMBD_OBJ_
|
||||
$(REGISTRY_OBJ) $(POPT_LIB_OBJ) \
|
||||
$(BUILDOPT_OBJ) $(SMBLDAP_OBJ)
|
||||
|
||||
-PRINTING_OBJ = printing/pcap.o printing/print_svid.o printing/print_aix.o \
|
||||
+PRINTING_OBJ = $(if $(OWRT_NO_PRINTING),,printing/pcap.o printing/print_svid.o printing/print_aix.o \
|
||||
printing/print_cups.o printing/print_generic.o \
|
||||
printing/lpq_parse.o printing/load.o \
|
||||
- printing/print_iprint.o printing/print_test.o
|
||||
+ printing/print_iprint.o printing/print_test.o)
|
||||
|
||||
-PRINTBASE_OBJ = printing/notify.o printing/printing_db.o
|
||||
-PRINTBACKEND_OBJ = printing/printing.o printing/nt_printing.o $(PRINTBASE_OBJ)
|
||||
+PRINTBASE_OBJ = $(if $(OWRT_NO_PRINTING),,printing/notify.o printing/printing_db.o)
|
||||
+PRINTBACKEND_OBJ = $(if $(OWRT_NO_PRINTING),,printing/printing.o printing/nt_printing.o $(PRINTBASE_OBJ))
|
||||
|
||||
SMBD_OBJ = $(SMBD_OBJ_BASE) $(SMBD_OBJ_MAIN)
|
||||
NMBD_OBJ1 = nmbd/asyncdns.o nmbd/nmbd.o nmbd/nmbd_become_dmb.o \
|
Loading…
x
Reference in New Issue
Block a user