ptlib: update to 2.10.9

Signed-off-by: Florian Fainelli <florian@openwrt.org>

git-svn-id: svn://svn.openwrt.org/openwrt/packages@34633 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
florian 2012-12-11 16:58:09 +00:00
parent 32c1ef0e63
commit 763b27cba4
2 changed files with 11 additions and 14 deletions

View File

@ -7,14 +7,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=ptlib
PKG_VERSION:=2.2.1
PKG_RELEASE:=2
PKG_VERSION:=2.10.9
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-src.tar.bz2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=@SF/opalvoip
PKG_MD5SUM:=dc266ba315e130b304854592e6388725
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)_$(PKG_VERSION)
PKG_MD5SUM:=
include $(INCLUDE_DIR)/package.mk

View File

@ -1,13 +1,12 @@
diff --git a/src/ptclib/sockagg.cxx b/src/ptclib/sockagg.cxx
index a8f89d2..c1960f6 100644
--- a/src/ptclib/sockagg.cxx
+++ b/src/ptclib/sockagg.cxx
@@ -38,6 +38,7 @@
diff -urN ptlib-2.10.9/src/ptclib/socks.cxx ptlib-2.10.9.new/src/ptclib/socks.cxx
--- ptlib-2.10.9/src/ptclib/socks.cxx 2012-11-26 11:44:52.000000000 +0100
+++ ptlib-2.10.9.new/src/ptclib/socks.cxx 2012-12-11 15:55:41.320940496 +0100
@@ -34,6 +34,8 @@
#include <ptclib/socks.h>
#include <ptlib.h>
#include <ptclib/sockagg.h>
-
+#include <algorithm>
+
#define new PNEW
#define SOCKS_VERSION_4 ((BYTE)4)