[package] fix pcapsipdump compilation failure (#6983)

git-svn-id: svn://svn.openwrt.org/openwrt/packages@20576 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
florian 2010-03-29 11:03:25 +00:00
parent 7729971bf7
commit 765871e787
2 changed files with 14 additions and 2 deletions

View File

@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=pcapsipdump
PKG_VERSION:=0.1.4
PKG_RELEASE:=1
PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SF/psipdump
@ -30,7 +30,7 @@ define Package/pcapsipdump/description
fashion similar to "tcpdump -w" (format is exactly the same), but one file per sip session
(even if there is thousands of concurrect SIP sessions).
endef
define Build/Compile
$(TARGET_CONFIGURE_OPTS) \
$(MAKE) -C $(PKG_BUILD_DIR) \

View File

@ -0,0 +1,12 @@
diff -urN pcapsipdump-0.1.4/pcapsipdump.h pcapsipdump-0.1.4.new/pcapsipdump.h
--- pcapsipdump-0.1.4/pcapsipdump.h 2007-05-11 20:40:49.000000000 +0200
+++ pcapsipdump-0.1.4.new/pcapsipdump.h 2010-03-29 09:52:20.000000000 +0200
@@ -35,7 +35,7 @@
#elif defined (__BIG_ENDIAN)
uint8_t version:4,
ihl:4;
-#elif
+#else
#error Endian not defined
#endif
uint8_t tos;