Update aiccu (#913)

git-svn-id: svn://svn.openwrt.org/openwrt/packages@5589 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
florian 2006-11-19 22:30:19 +00:00
parent cdb052169e
commit 768fa96082
3 changed files with 90 additions and 2 deletions

View File

@ -9,12 +9,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=aiccu
PKG_VERSION:=2005.01.31
PKG_VERSION:=2006.07.25
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.sixxs.net/archive/sixxs/aiccu/unix
PKG_MD5SUM:=7c3da5feab3d59fb5a99a45203e0ca56
PKG_MD5SUM:=0df76e92eb34f4ce8aa3cfcf6896f271
PKG_CAT:=zcat
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)

View File

@ -0,0 +1,18 @@
diff -Nru aiccu.old/unix-console/Makefile aiccu/unix-console/Makefile
--- aiccu.old/unix-console/Makefile 2006-07-25 12:20:48.000000000 +0300
+++ aiccu/unix-console/Makefile 2006-11-04 00:44:03.000000000 +0200
@@ -37,12 +37,10 @@
# This is a console client
CFLAGS += -D AICCU_CONSOLE
-# GnuTLS Support ?
+# GnuTLS Support ? Removed for OpenWRT.
# Used by TIC to secure that communication
-# Currently defaultly builds only on Linux, but other platforms might easily also support it
ifeq ($(shell uname | grep -c "Linux"),1)
-CFLAGS += -D _LINUX -D AICCU_GNUTLS
-LDFLAGS += -lgnutls
+CFLAGS += -D _LINUX
endif
# Linux

View File

@ -0,0 +1,70 @@
diff -Nru aiccu.old/common/dn_skipname.c aiccu/common/dn_skipname.c
--- aiccu.old/common/dn_skipname.c 1970-01-01 02:00:00.000000000 +0200
+++ aiccu/common/dn_skipname.c 2006-11-04 00:50:23.000000000 +0200
@@ -0,0 +1,51 @@
+#include <errno.h>
+#include <resolv.h>
+
+/* Ripped from glibc 2.4 sources. */
+
+/*
+ * ns_name_skip(ptrptr, eom)
+ * Advance *ptrptr to skip over the compressed name it points at.
+ * return:
+ * 0 on success, -1 (with errno set) on failure.
+ */
+int ns_name_skip(const u_char **ptrptr, const u_char *eom)
+{
+ const u_char *cp;
+ u_int n;
+
+ cp = *ptrptr;
+ while (cp < eom && (n = *cp++) != 0)
+ {
+ /* Check for indirection. */
+ switch (n & NS_CMPRSFLGS) {
+ case 0: /* normal case, n == len */
+ cp += n;
+ continue;
+ case NS_CMPRSFLGS: /* indirection */
+ cp++;
+ break;
+ default: /* illegal type */
+ errno = EMSGSIZE;
+ return (-1);
+ }
+ break;
+ }
+ if (cp > eom)
+ {
+ errno = EMSGSIZE;
+ return (-1);
+ }
+ *ptrptr = cp;
+ return (0);
+}
+
+int dn_skipname(const u_char *ptr, const u_char *eom)
+{
+ const u_char *saveptr = ptr;
+
+ if(ns_name_skip(&ptr, eom) == -1)
+ return (-1);
+ return (ptr - saveptr);
+}
+
diff -Nru aiccu.old/unix-console/Makefile aiccu/unix-console/Makefile
--- aiccu.old/unix-console/Makefile 2006-11-04 00:51:20.000000000 +0200
+++ aiccu/unix-console/Makefile 2006-11-04 00:48:51.000000000 +0200
@@ -10,9 +10,9 @@
# $Date: 2006-07-25 09:20:48 $
# **********************************************************/
-SRCS = main.c ../common/tun.c ../common/aiccu.c ../common/hash_md5.c ../common/hash_sha1.c ../common/common.c ../common/heartbeat.c ../common/tic.c ../common/ayiya.c ../common/aiccu_test.c ../common/resolver.c
+SRCS = main.c ../common/tun.c ../common/aiccu.c ../common/hash_md5.c ../common/hash_sha1.c ../common/common.c ../common/heartbeat.c ../common/tic.c ../common/ayiya.c ../common/aiccu_test.c ../common/resolver.c ../common/dn_skipname.c
INCS = ../common/tun.h ../common/aiccu.h ../common/hash_md5.h ../common/hash_sha1.h ../common/common.h ../common/heartbeat.h ../common/tic.h ../common/ayiya.h ../common/resolver.h
-OBJS = main.o ../common/tun.o ../common/aiccu.o ../common/hash_md5.o ../common/hash_sha1.o ../common/common.o ../common/heartbeat.o ../common/tic.o ../common/ayiya.o ../common/aiccu_test.o ../common/resolver.o
+OBJS = main.o ../common/tun.o ../common/aiccu.o ../common/hash_md5.o ../common/hash_sha1.o ../common/common.o ../common/heartbeat.o ../common/tic.o ../common/ayiya.o ../common/aiccu_test.o ../common/resolver.o ../common/dn_skipname.o
# New features not fully implemented and thus disabled for now
#CFLAGS += -D NEWSTUFF_TSP -D NEWSTUFF_TEEPEE