[packages] ipmitool: fix autoreconf

git-svn-id: svn://svn.openwrt.org/openwrt/packages@24599 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
jow 2010-12-15 09:42:56 +00:00
parent 24690377fb
commit 76a0b7c0c4

View File

@ -10,3 +10,35 @@
else else
cat >conftest.$ac_ext <<_ACEOF cat >conftest.$ac_ext <<_ACEOF
/* confdefs.h. */ /* confdefs.h. */
--- a/configure.in
+++ b/configure.in
@@ -489,29 +489,6 @@ AC_ARG_ENABLE([file-security],
fi], [])
-AC_TRY_RUN([
- #include <stdio.h>
-
- struct packstruct {
- unsigned char t0 :5;
- unsigned char t1 :5;
- unsigned char t2 :5;
- unsigned char t3 :5;
- unsigned char t4 :4;
- } __attribute__ ((packed));
-
- int
- main(int argc, char ** argv)
- {
- if(sizeof(struct packstruct) != 3)
- return(1);
- else
- return(0);
- }
- ],[],[AC_DEFINE(HAVE_PRAGMA_PACK,[1],[Define to 1 if you need to use #pragma pack instead of __attribute__ ((packed))])]
-)
-
-
dnl Generate files for build
AC_CONFIG_FILES([Makefile
doc/Makefile