Add fxload (#1093)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@5920 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
3a36658269
commit
77849cc9fe
48
utils/fxload/Makefile
Normal file
48
utils/fxload/Makefile
Normal file
@ -0,0 +1,48 @@
|
||||
#
|
||||
# Copyright (C) 2006 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=fxload
|
||||
PKG_VERSION:=2002_04_11
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=@SF/linux-hotplug
|
||||
PKG_MD5SUM:=cafd71a5bff0c57bcd248273b2541c05
|
||||
PKG_CAT:=zcat
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/fxload
|
||||
SECTION:=utils
|
||||
CATEGORY:=Utilities
|
||||
DEPENDS:=@USB_SUPPORT +udev
|
||||
TITLE:=Downloading firmware into EZ-USB microcontrollers
|
||||
URL:=http://linux-hotplug.sourceforge.net/
|
||||
endef
|
||||
|
||||
define Build/Compile
|
||||
$(call Build/Compile/Default,
|
||||
DESTDIR="$(PKG_INSTALL_DIR)" \
|
||||
CC="$(TARGET_CC)" \
|
||||
CROSS="$(TARGET_CROSS)" \
|
||||
EXTRA_CFLAGS="$(TARGET_CFLAGS)" \
|
||||
)
|
||||
endef
|
||||
|
||||
define Package/fxload/install
|
||||
$(INSTALL_DIR) $(1)/sbin
|
||||
$(CP) $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/sbin/
|
||||
$(INSTALL_DIR) $(1)/usr/share/usb
|
||||
$(CP) $(PKG_BUILD_DIR)/a3load.hex $(1)/usr/share/usb
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,fxload))
|
18
utils/fxload/patches/010-compile_fix.patch
Normal file
18
utils/fxload/patches/010-compile_fix.patch
Normal file
@ -0,0 +1,18 @@
|
||||
--- fxload-2002_04_11/ezusb.c.old 2006-12-18 18:51:26.000000000 -0700
|
||||
+++ fxload-2002_04_11/ezusb.c 2006-12-18 18:51:59.000000000 -0700
|
||||
@@ -29,8 +29,14 @@
|
||||
# include <sys/ioctl.h>
|
||||
|
||||
# include <linux/version.h>
|
||||
-# include <linux/usb.h>
|
||||
+typedef unsigned long kernel_ulong_t;
|
||||
+
|
||||
+#ifndef BITS_PER_LONG
|
||||
+#define BITS_PER_LONG 32
|
||||
+#endif
|
||||
+
|
||||
# include <linux/usbdevice_fs.h>
|
||||
+# include <linux/usb.h>
|
||||
|
||||
# include "ezusb.h"
|
||||
|
Loading…
x
Reference in New Issue
Block a user