[packages] orbit2:

- remove braindead AC_TRY_RUN test
	- remove private libtool copy
	- fake the GTK doc check macro


git-svn-id: svn://svn.openwrt.org/openwrt/packages@24354 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
jow 2010-12-08 18:30:29 +00:00
parent 9155006a61
commit 782535ee62
4 changed files with 6687 additions and 2 deletions

View File

@ -16,7 +16,9 @@ HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/ORBit2-$(PKG_VERSION)
PKG_SOURCE:=ORBit2-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=@GNOME/ORBit2/2.14
#PKG_MD5SUM:=d7fb9eb41e8196f1aacf2f08375ae555
PKG_FIXUP:=libtool
PKG_REMOVE_FILES:=ltmain.sh
include $(INCLUDE_DIR)/host-build.mk
include $(INCLUDE_DIR)/package.mk

File diff suppressed because it is too large Load Diff

View File

@ -0,0 +1,10 @@
--- a/acinclude.m4
+++ b/acinclude.m4
@@ -228,3 +228,7 @@ AC_DEFUN([AX_CFLAGS_GCC_OPTION],[ifelse(
AC_DEFUN([AX_CXXFLAGS_GCC_OPTION],[ifelse(m4_bregexp([$2],[-]),-1,
[AX_CXXFLAGS_GCC_OPTION_NEW($@)],[AX_CXXFLAGS_GCC_OPTION_OLD($@)])])
+
+
+dnl fake GTK Doc check
+AC_DEFUN([GTK_DOC_CHECK],[AM_CONDITIONAL(ENABLE_GTK_DOC,false)])

View File

@ -1,5 +1,3 @@
diff --git a/configure b/configure
index bd8d550..74c5330 100755
--- a/configure
+++ b/configure
@@ -24219,7 +24219,7 @@ if test "$cross_compiling" = yes; then
@ -11,3 +9,30 @@ index bd8d550..74c5330 100755
else
cat >conftest.$ac_ext <<_ACEOF
/* confdefs.h. */
--- a/configure.in
+++ b/configure.in
@@ -196,24 +196,6 @@ dnl This generates warnings from autocon
AC_C_BIGENDIAN
-dnl
-dnl So many people with broken linking setups asked about this
-dnl it turned out to be necessary to check for this.
-dnl
-dofus_save_libs="$LIBS"
-LIBS="$ORBIT_LIBS $LIBS"
-AC_TRY_RUN([ #include <stdio.h>
- main ()
- {
- return 0;
- } ],,
- AC_MSG_ERROR([
-Linking is badly borked on your system. Please ensure your library path is correct
-Check config.log for details - check near the end of the log above 'failed program was'
-Alternatively ensure that your /etc/ld.so.conf (and/or LD_LIBRARY_PATH) includes the
-prefix you're compiling on: '${prefix}' ]))
-LIBS="$dofus_save_libs"
-
orig_CPPFLAGS=$CPPFLAGS
CPPFLAGS="$CPPFLAGS $ORBIT_CFLAGS"
AC_CHECK_ALIGNOF(CORBA_octet)