aircrack-ng: moved to github

git-svn-id: svn://svn.openwrt.org/openwrt/packages@44317 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
jow 2015-02-07 22:00:12 +00:00
parent c1cda5985c
commit 790e17eb4d
2 changed files with 0 additions and 104 deletions

View File

@ -1,52 +0,0 @@
#
# Copyright (C) 2006-2011 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
include $(TOPDIR)/rules.mk
PKG_NAME:=aircrack-ng
PKG_VERSION:=1.1
PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://download.aircrack-ng.org/ \
http://archive.aircrack-ng.org/aircrack-ng/$(PKG_VERSION)/
PKG_MD5SUM:=f7a24ed8fad122c4187d06bfd6f998b4
PKG_BUILD_PARALLEL:=0
PKG_INSTALL:=1
include $(INCLUDE_DIR)/package.mk
define Package/aircrack-ng
SECTION:=net
CATEGORY:=Network
DEPENDS:=+libpthread +libopenssl +libpcap
TITLE:=next generation of aircrack with new features
URL:=http://www.aircrack-ng.org/
SUBMENU:=wireless
endef
define Package/aircrack-ng/description
Aircrack-ng is the next generation of aircrack with new features
endef
MAKE_FLAGS += \
CFLAGS="$(TARGET_CFLAGS) -Wall -Iinclude/ $(TARGET_CPPFLAGS) -D_REVISION=0" \
LDFLAGS="$(TARGET_LDFLAGS)" \
OSNAME=Linux \
prefix="/usr" \
sqlite="false" \
unstable="true"
define Package/aircrack-ng/install
$(INSTALL_DIR) $(1)/usr/bin
$(CP) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
$(INSTALL_DIR) $(1)/usr/sbin
$(CP) $(PKG_INSTALL_DIR)/usr/sbin/* $(1)/usr/sbin/
endef
$(eval $(call BuildPackage,aircrack-ng))

View File

@ -1,52 +0,0 @@
--- a/src/aireplay-ng.c
+++ b/src/aireplay-ng.c
@@ -200,7 +200,9 @@ char usage[] =
"\n"
" Miscellaneous options:\n"
"\n"
-" -R : disable /dev/rtc usage\n"
+" -R : disable /dev/rtc usage\n"
+" --ignore-negative-one : if the interface's channel can't be determined,\n"
+" ignore the mismatch, needed for unpatched cfg80211\n"
"\n"
" Attack modes (numbers can still be used):\n"
"\n"
@@ -268,6 +270,7 @@ struct options
int bittest;
int nodetect;
+ int ignore_negative_one;
int rtc;
}
opt;
@@ -715,6 +718,13 @@ int attack_check(uchar* bssid, char* ess
iface_chan = wi_get_channel(wi);
+ if(iface_chan == -1 && !opt.ignore_negative_one)
+ {
+ PCT; printf("Couldn't determine current channel for %s, you should either force the operation with --ignore-negative-one or apply a kernel patch\n",
+ wi_get_ifname(wi));
+ return -1;
+ }
+
if(bssid != NULL)
{
ap_chan = wait_for_beacon(bssid, capa, essid);
@@ -723,7 +733,7 @@ int attack_check(uchar* bssid, char* ess
PCT; printf("No such BSSID available.\n");
return -1;
}
- if(ap_chan != iface_chan)
+ if((ap_chan != iface_chan) && (iface_chan != -1 || !opt.ignore_negative_one))
{
PCT; printf("%s is on channel %d, but the AP uses channel %d\n", wi_get_ifname(wi), iface_chan, ap_chan);
return -1;
@@ -5765,6 +5775,7 @@ int main( int argc, char *argv[] )
{"help", 0, 0, 'H'},
{"fast", 0, 0, 'F'},
{"bittest", 0, 0, 'B'},
+ {"ignore-negative-one", 0, &opt.ignore_negative_one, 1},
{0, 0, 0, 0 }
};