[packages] ndisc:
- update to v0.9.9 - fix compilation by providing dummy WIFCONTINUED() macro - package rdnssd DNS discovery deamon git-svn-id: svn://svn.openwrt.org/openwrt/packages@21772 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
eccac92356
commit
79248ce0e6
@ -1,5 +1,5 @@
|
||||
#
|
||||
# Copyright (C) 2006 OpenWrt.org
|
||||
# Copyright (C) 2006-2010 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
@ -8,9 +8,9 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=ndisc6
|
||||
PKG_VERSION:=0.9.8
|
||||
PKG_VERSION:=0.9.9
|
||||
PKG_RELEASE:=1
|
||||
PKG_MD5SUM:=cb8d70564b8d40aae95e19592c6be183
|
||||
PKG_MD5SUM:=aab2209fa7bf6b02ed2f49e7b8e9fa18
|
||||
|
||||
PKG_SOURCE_URL:=http://www.remlab.net/files/ndisc6/
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
@ -56,6 +56,16 @@ define Package/tcptraceroute6/description
|
||||
A TCP/IPv6-based traceroute implementation
|
||||
endef
|
||||
|
||||
define Package/rdnssd
|
||||
$(call Package/ndisc)
|
||||
TITLE:=DNS server discovery deamon
|
||||
endef
|
||||
|
||||
define Package/rdnssd/description
|
||||
A recursive DNS server discovery daemon gathering
|
||||
information through stateless IPv6 autoconfiguration (RFC5006)
|
||||
endef
|
||||
|
||||
|
||||
define Build/Compile
|
||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||
@ -79,6 +89,12 @@ define Package/tcptraceroute6/install
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/tcptraceroute6 $(1)/usr/bin/
|
||||
endef
|
||||
|
||||
define Package/rdnssd/install
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/rdnssd/rdnssd $(1)/usr/bin/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,ndisc6))
|
||||
$(eval $(call BuildPackage,rdisc6))
|
||||
$(eval $(call BuildPackage,tcptraceroute6))
|
||||
$(eval $(call BuildPackage,rdnssd))
|
||||
|
@ -1,6 +1,5 @@
|
||||
diff -urN ndisc6-0.9.8/src/trace-tcp.c ndisc6-0.9.8.new/src/trace-tcp.c
|
||||
--- ndisc6-0.9.8/src/trace-tcp.c 2008-05-01 14:52:28.000000000 +0200
|
||||
+++ ndisc6-0.9.8.new/src/trace-tcp.c 2009-04-17 15:39:54.000000000 +0200
|
||||
--- a/src/trace-tcp.c
|
||||
+++ b/src/trace-tcp.c
|
||||
@@ -24,6 +24,7 @@
|
||||
|
||||
#undef _GNU_SOURCE
|
||||
@ -9,9 +8,8 @@ diff -urN ndisc6-0.9.8/src/trace-tcp.c ndisc6-0.9.8.new/src/trace-tcp.c
|
||||
|
||||
#include <string.h>
|
||||
#include <inttypes.h>
|
||||
diff -urN ndisc6-0.9.8/src/trace-udp.c ndisc6-0.9.8.new/src/trace-udp.c
|
||||
--- ndisc6-0.9.8/src/trace-udp.c 2008-05-01 14:52:28.000000000 +0200
|
||||
+++ ndisc6-0.9.8.new/src/trace-udp.c 2009-04-17 15:40:36.000000000 +0200
|
||||
--- a/src/trace-udp.c
|
||||
+++ b/src/trace-udp.c
|
||||
@@ -24,6 +24,7 @@
|
||||
|
||||
#undef _GNU_SOURCE
|
||||
|
@ -1,7 +1,6 @@
|
||||
diff -urN ndisc6-0.9.8/rdnssd/Makefile.am ndisc6-0.9.8.new/rdnssd/Makefile.am
|
||||
--- ndisc6-0.9.8/rdnssd/Makefile.am 2008-05-01 14:52:28.000000000 +0200
|
||||
+++ ndisc6-0.9.8.new/rdnssd/Makefile.am 2009-04-17 15:47:51.000000000 +0200
|
||||
@@ -27,7 +27,8 @@
|
||||
--- a/rdnssd/Makefile.am
|
||||
+++ b/rdnssd/Makefile.am
|
||||
@@ -27,7 +27,8 @@ conf_SCRIPTS = merge-hook
|
||||
# rdnssd
|
||||
rdnssd_SOURCES = rdnssd.c rdnssd.h \
|
||||
icmp.c \
|
||||
@ -11,10 +10,9 @@ diff -urN ndisc6-0.9.8/rdnssd/Makefile.am ndisc6-0.9.8.new/rdnssd/Makefile.am
|
||||
rdnssd_LDADD = $(LIBRT) \
|
||||
@top_builddir@/compat/libcompat.a
|
||||
|
||||
diff -urN ndisc6-0.9.8/rdnssd/Makefile.in ndisc6-0.9.8.new/rdnssd/Makefile.in
|
||||
--- ndisc6-0.9.8/rdnssd/Makefile.in 2008-05-01 14:52:45.000000000 +0200
|
||||
+++ ndisc6-0.9.8.new/rdnssd/Makefile.in 2009-04-17 15:47:39.000000000 +0200
|
||||
@@ -58,7 +58,7 @@
|
||||
--- a/rdnssd/Makefile.in
|
||||
+++ b/rdnssd/Makefile.in
|
||||
@@ -58,7 +58,7 @@ CONFIG_CLEAN_FILES =
|
||||
am__installdirs = "$(DESTDIR)$(sbindir)" "$(DESTDIR)$(confdir)"
|
||||
sbinPROGRAMS_INSTALL = $(INSTALL_PROGRAM)
|
||||
PROGRAMS = $(sbin_PROGRAMS)
|
||||
@ -23,7 +21,7 @@ diff -urN ndisc6-0.9.8/rdnssd/Makefile.in ndisc6-0.9.8.new/rdnssd/Makefile.in
|
||||
rdnssd_OBJECTS = $(am_rdnssd_OBJECTS)
|
||||
am__DEPENDENCIES_1 =
|
||||
rdnssd_DEPENDENCIES = $(am__DEPENDENCIES_1) \
|
||||
@@ -211,7 +211,8 @@
|
||||
@@ -213,7 +213,8 @@ conf_SCRIPTS = merge-hook
|
||||
# rdnssd
|
||||
rdnssd_SOURCES = rdnssd.c rdnssd.h \
|
||||
icmp.c \
|
||||
@ -33,7 +31,7 @@ diff -urN ndisc6-0.9.8/rdnssd/Makefile.in ndisc6-0.9.8.new/rdnssd/Makefile.in
|
||||
|
||||
rdnssd_LDADD = $(LIBRT) \
|
||||
@top_builddir@/compat/libcompat.a
|
||||
@@ -334,6 +335,7 @@
|
||||
@@ -336,6 +337,7 @@ distclean-compile:
|
||||
|
||||
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/icmp.Po@am__quote@
|
||||
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/netlink.Po@am__quote@
|
||||
@ -41,9 +39,8 @@ diff -urN ndisc6-0.9.8/rdnssd/Makefile.in ndisc6-0.9.8.new/rdnssd/Makefile.in
|
||||
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/rdnssd.Po@am__quote@
|
||||
|
||||
.c.o:
|
||||
diff -urN ndisc6-0.9.8/rdnssd/strverscmp.c ndisc6-0.9.8.new/rdnssd/strverscmp.c
|
||||
--- ndisc6-0.9.8/rdnssd/strverscmp.c 1970-01-01 01:00:00.000000000 +0100
|
||||
+++ ndisc6-0.9.8.new/rdnssd/strverscmp.c 2009-04-17 15:46:24.000000000 +0200
|
||||
--- /dev/null
|
||||
+++ b/rdnssd/strverscmp.c
|
||||
@@ -0,0 +1,131 @@
|
||||
+/* Compare strings while treating digits characters numerically.
|
||||
+ Copyright (C) 1997, 2000, 2002, 2004 Free Software Foundation, Inc.
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- a/compat/fixups.h
|
||||
+++ b/compat/fixups.h
|
||||
@@ -50,13 +50,25 @@
|
||||
@@ -50,13 +50,25 @@ int inet6_rth_add (void *bp, const struc
|
||||
# define IPV6_RTHDR_TYPE_0 0
|
||||
#endif
|
||||
|
||||
|
14
ipv6/ndisc/patches/130-wifcontinued.patch
Normal file
14
ipv6/ndisc/patches/130-wifcontinued.patch
Normal file
@ -0,0 +1,14 @@
|
||||
--- a/src/isatapd.c
|
||||
+++ b/src/isatapd.c
|
||||
@@ -77,6 +77,11 @@
|
||||
#include <netinet/in.h>
|
||||
#include <netinet/icmp6.h>
|
||||
|
||||
+/* uclibc does not define WIFCONTINUED(), workaround */
|
||||
+#ifndef WIFCONTINUED
|
||||
+#define WIFCONTINUED(wstat) (0)
|
||||
+#endif
|
||||
+
|
||||
/* contains Protocol Constants for host and Node (RFCs 4861, 5214) */
|
||||
#include <isatapd.h>
|
||||
|
Loading…
x
Reference in New Issue
Block a user