Add kid (#2235)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@8515 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
b5dd4ff4f2
commit
794004048d
39
lang/kid/Makefile
Normal file
39
lang/kid/Makefile
Normal file
@ -0,0 +1,39 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=kid
|
||||
PKG_VERSION:=0.9.6
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://www.kid-templating.org/dist/0.9.6/dist
|
||||
PKG_MD5SUM:=31e7156698a6f214b4067afb9e13728f
|
||||
PKG_CAT:=zcat
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/kid
|
||||
SECTION:=lang
|
||||
CATEGORY:=Languages
|
||||
TITLE:=Kid
|
||||
DEPENDS:=+python
|
||||
DESCRIPTION:=\
|
||||
Kid is a simple template language for XML based vocabularies written in Python.
|
||||
URL=http://www.kid-templating.org/
|
||||
endef
|
||||
|
||||
define Build/Compile
|
||||
cd $(PKG_BUILD_DIR); \
|
||||
CFLAGS='-I$(STAGING_DIR)/usr/include' \
|
||||
LDFLAGS='$(TARGET_LDFLAGS) -L$(STAGING_DIR)/usr/lib' \
|
||||
$(STAGING_DIR)/usr/bin/hostpython ./setup.py install \
|
||||
--prefix=$(PKG_INSTALL_DIR)/usr
|
||||
endef
|
||||
|
||||
define Package/kid/install
|
||||
$(CP) -R $(PKG_INSTALL_DIR)/* $(1)
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,kid))
|
20
lang/kid/patches/000-setup.patch
Normal file
20
lang/kid/patches/000-setup.patch
Normal file
@ -0,0 +1,20 @@
|
||||
diff -urN kid-0.9.6_orig/setup.py kid-0.9.6/setup.py
|
||||
--- kid-0.9.6/setup.py 2007-07-16 13:02:49.000000000 +0200
|
||||
+++ kid-0.9.6/setup.py 2007-08-15 14:39:37.000000000 +0200
|
||||
@@ -1,15 +1,12 @@
|
||||
#!/usr/bin/env python
|
||||
|
||||
# bootstrap setuptools if necessary
|
||||
-from ez_setup import use_setuptools
|
||||
-use_setuptools()
|
||||
+from distutils.core import setup
|
||||
|
||||
import os
|
||||
|
||||
execfile(os.path.join("kid", "release.py"))
|
||||
|
||||
-from setuptools import setup, find_packages
|
||||
-
|
||||
setup(
|
||||
name="kid",
|
||||
version=version,
|
Loading…
x
Reference in New Issue
Block a user