[packages] olsrd: Version bump to 0.6.2
txtinfo plugin patch removed because now text is properly formatted, agreed with JoW quagga patch removed because problem was fixed upstream in quagga, agreed with acinonyx git-svn-id: svn://svn.openwrt.org/openwrt/packages@29131 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
1d7c9bae52
commit
7949f082b3
@ -8,12 +8,12 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=olsrd
|
||||
PKG_VERSION:=0.6.1
|
||||
PKG_RELEASE:=4
|
||||
PKG_VERSION:=0.6.2
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=http://www.olsr.org/releases/0.6
|
||||
PKG_MD5SUM:=a75fc9b6252df5b5f49f13418fafeff1
|
||||
PKG_MD5SUM:=1f55bbbaf0737364b53daaeecc2cd50c
|
||||
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
PKG_INSTALL:=1
|
||||
|
@ -1,20 +0,0 @@
|
||||
--- a/lib/txtinfo/src/olsrd_txtinfo.c
|
||||
+++ b/lib/txtinfo/src/olsrd_txtinfo.c
|
||||
@@ -562,7 +562,7 @@ ipc_print_gateway(struct autobuf *abuf)
|
||||
struct lqtextbuffer lqbuf;
|
||||
|
||||
// Status IP ETX Hopcount Uplink-Speed Downlink-Speed ipv4/ipv4-nat/- ipv6/- ipv6-prefix/-
|
||||
- abuf_puts(abuf, "Table: Gateways\n Gateway\tETX\tHopcnt\tUplink\tDownlnk\tIPv4\tIPv6\tPrefix\n");
|
||||
+ abuf_puts(abuf, "Table: Gateways\nGateway\tETX\tHopcnt\tUplink\tDownlnk\tIPv4\tIPv6\tPrefix\n");
|
||||
OLSR_FOR_ALL_GATEWAY_ENTRIES(gw) {
|
||||
char v4 = '-', v6 = '-';
|
||||
bool autoV4 = false, autoV6 = false;
|
||||
@@ -595,7 +595,7 @@ ipc_print_gateway(struct autobuf *abuf)
|
||||
v6type = IPV6;
|
||||
}
|
||||
|
||||
- abuf_appendf(abuf, "%c%c %s\t%s\t%d\t%u\t%u\t%s\t%s\t%s\n",
|
||||
+ abuf_appendf(abuf, "%c%c\t%s\t%s\t%d\t%u\t%u\t%s\t%s\t%s\n",
|
||||
v4, v6, olsr_ip_to_string(&buf, &gw->originator),
|
||||
get_linkcost_text(tc->path_cost, true, &lqbuf), tc->hops,
|
||||
gw->uplink, gw->downlink, v4type, v6type,
|
@ -1,29 +0,0 @@
|
||||
--- a/lib/quagga/src/quagga.c
|
||||
+++ b/lib/quagga/src/quagga.c
|
||||
@@ -2,7 +2,7 @@
|
||||
* OLSRd Quagga plugin
|
||||
*
|
||||
* Copyright (C) 2006-2008 Immo 'FaUl' Wehrenberg <immo@chaostreff-dortmund.de>
|
||||
- * Copyright (C) 2007-2010 Vasilis Tsiligiannis <acinonyxs@yahoo.gr>
|
||||
+ * Copyright (C) 2007-2011 Vasilis Tsiligiannis <acinonyxs@yahoo.gr>
|
||||
*
|
||||
* This program is free software; you can redistribute it and/or modify
|
||||
* it under the terms of the GNU General Public License version 2 as
|
||||
@@ -78,8 +78,6 @@ zebra_addroute(const struct rt_entry *r)
|
||||
(olsr_cnf->ip_version == AF_INET6 &&
|
||||
!memcmp(r->rt_best->rtp_nexthop.gateway.v6.s6_addr, r->rt_dst.prefix.v6.s6_addr, sizeof r->rt_best->rtp_nexthop.gateway.v6.s6_addr) &&
|
||||
route.prefixlen == 128)) {
|
||||
- return 0; /* Quagga BUG workaround: don't add routes with destination = gateway
|
||||
- see http://lists.olsr.org/pipermail/olsr-users/2006-June/001726.html */
|
||||
route.ifindex_num++;
|
||||
route.ifindex = olsr_malloc(sizeof *route.ifindex, "QUAGGA: New zebra route ifindex");
|
||||
*route.ifindex = r->rt_best->rtp_nexthop.iif_index;
|
||||
@@ -129,8 +127,6 @@ zebra_delroute(const struct rt_entry *r)
|
||||
(olsr_cnf->ip_version == AF_INET6 &&
|
||||
!memcmp(r->rt_nexthop.gateway.v6.s6_addr, r->rt_dst.prefix.v6.s6_addr, sizeof r->rt_nexthop.gateway.v6.s6_addr) &&
|
||||
route.prefixlen == 128)) {
|
||||
- return 0; /* Quagga BUG workaround: don't delete routes with destination = gateway
|
||||
- see http://lists.olsr.org/pipermail/olsr-users/2006-June/001726.html */
|
||||
route.ifindex_num++;
|
||||
route.ifindex = olsr_malloc(sizeof *route.ifindex, "QUAGGA: New zebra route ifindex");
|
||||
*route.ifindex = r->rt_nexthop.iif_index;
|
Loading…
x
Reference in New Issue
Block a user