ruby: fix unresolved getaddrinfo #9873 and update to 1.9.3p545

ruby fails to check wide_getaddrinfo, which is important only for
non-linux env.

Luiz Angelo Daros de Luca <luizluca@gmail.com>


git-svn-id: svn://svn.openwrt.org/openwrt/packages@40630 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
hauke 2014-05-01 15:28:46 +00:00
parent 9c36cbb4bb
commit 7aa10a3e3d
2 changed files with 12 additions and 3 deletions

View File

@ -15,14 +15,14 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=ruby
PKG_VERSION:=1.9.3-p484
PKG_VERSION:=1.9.3-p545
PKG_RELEASE:=1
PKG_LIBVER:=1.9
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=ftp://ftp.ruby-lang.org/pub/ruby/$(PKG_LIBVER)/
PKG_MD5SUM:=03f5b08804927ceabe5122cb90f5d0a9
PKG_MD5SUM:=4743c1dc48491070bae8fc8b423bc1a7
PKG_BUILD_DEPENDS:=ruby/host
PKG_INSTALL:=1
@ -212,7 +212,6 @@ CONFIGURE_ARGS += \
--enable-static \
--disable-rpath \
--enable-ipv6 \
--enable-wide-getaddrinfo \
--with-ruby-version=minor \
--with-iconv-dir=$(ICONV_PREFIX) \

View File

@ -0,0 +1,10 @@
--- a/ext/socket/extconf.rb 2013-02-14 23:20:13.581918676 -0200
+++ b/ext/socket/extconf.rb 2013-02-14 23:21:25.761918667 -0200
@@ -254,6 +254,7 @@
end
getaddr_info_ok = (enable_config("wide-getaddrinfo") && :wide) ||
+ (CROSS_COMPILING && :cross) ||
(checking_for("wide getaddrinfo") {try_run(<<EOF)} && :os)
#{cpp_include(headers)}
#include <stdlib.h>