[package] collectd: update to 4.10.6

Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>

git-svn-id: svn://svn.openwrt.org/openwrt/packages@31184 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
florian 2012-04-04 14:13:42 +00:00
parent fd90d0f7a8
commit 7b4de02e7c
6 changed files with 12 additions and 54 deletions

View File

@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=collectd
PKG_VERSION:=4.10.2
PKG_RELEASE:=6
PKG_VERSION:=4.10.6
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://collectd.org/files/
PKG_MD5SUM:=85d9d8d0a1327782661e3c89800aa70e
PKG_MD5SUM:=d446c399d839a32f2f581111d7256f8b
PKG_FIXUP:=autoreconf
PKG_REMOVE_FILES:=aclocal.m4 libltdl/aclocal.m4

View File

@ -1,8 +0,0 @@
--- a/version-gen.sh
+++ b/version-gen.sh
@@ -1,4 +1,4 @@
-#!/bin/sh
+#!/usr/bin/env bash
DEFAULT_VERSION="4.10.2.git"

View File

@ -17,7 +17,7 @@
/* consolidation_functions = */ NULL,
/* consolidation_functions_num = */ 0
};
@@ -1027,6 +1030,14 @@ static int rrd_config (const char *key,
@@ -1027,6 +1030,14 @@ static int rrd_config (const char *key,
free (value_copy);
}

View File

@ -2,7 +2,7 @@
+++ b/version-gen.sh
@@ -2,7 +2,7 @@
DEFAULT_VERSION="4.10.2.git"
DEFAULT_VERSION="4.10.6.git"
-VERSION="`git describe 2> /dev/null | sed -e 's/^collectd-//'`"
+#VERSION="`git describe 2> /dev/null | sed -e 's/^collectd-//'`"

View File

@ -1,34 +0,0 @@
--- a/src/modbus.c
+++ b/src/modbus.c
@@ -281,10 +281,8 @@ static int mb_init_connection (mb_host_t
modbus_set_debug (&host->connection, 1);
-#if 0
/* We'll do the error handling ourselves. */
modbus_set_error_handling (&host->connection, NOP_ON_ERROR);
-#endif
if ((host->port < 1) || (host->port > 65535))
host->port = MODBUS_TCP_DEFAULT_PORT;
@@ -293,10 +291,8 @@ static int mb_init_connection (mb_host_t
host->node, host->port);
modbus_init_tcp (&host->connection,
- /* host = */ host->node);
-#if 0
+ /* host = */ host->node,
/* port = */ host->port);
-#endif
status = modbus_connect (&host->connection);
if (status != 0)
@@ -325,7 +321,7 @@ static int mb_init_connection (mb_host_t
static int mb_read_data (mb_host_t *host, mb_slave_t *slave, /* {{{ */
mb_data_t *data)
{
- int values[2];
+ uint16_t values[2];
int values_num;
const data_set_t *ds;
int status;

View File

@ -1,6 +1,6 @@
--- a/configure.in
+++ b/configure.in
@@ -471,6 +471,9 @@ AC_CHECK_HEADERS(netinet/if_ether.h, [],
@@ -490,6 +490,9 @@ AC_CHECK_HEADERS(netinet/if_ether.h, [],
have_termios_h="no"
AC_CHECK_HEADERS(termios.h, [have_termios_h="yes"])
@ -10,7 +10,7 @@
#
# Checks for typedefs, structures, and compiler characteristics.
#
@@ -3985,6 +3988,7 @@ plugin_interface="no"
@@ -4006,6 +4009,7 @@ plugin_interface="no"
plugin_ipmi="no"
plugin_ipvs="no"
plugin_irq="no"
@ -18,7 +18,7 @@
plugin_libvirt="no"
plugin_load="no"
plugin_memory="no"
@@ -4292,6 +4296,7 @@ AC_PLUGIN([ipmi], [$plugin_ipmi],
@@ -4313,6 +4317,7 @@ AC_PLUGIN([ipmi], [$plugin_ipmi],
AC_PLUGIN([iptables], [$with_libiptc], [IPTables rule counters])
AC_PLUGIN([ipvs], [$plugin_ipvs], [IPVS connection statistics])
AC_PLUGIN([irq], [$plugin_irq], [IRQ statistics])
@ -26,7 +26,7 @@
AC_PLUGIN([java], [$with_java], [Embed the Java Virtual Machine])
AC_PLUGIN([libvirt], [$plugin_libvirt], [Virtual machine statistics])
AC_PLUGIN([load], [$plugin_load], [System load])
@@ -4570,6 +4575,7 @@ Configuration:
@@ -4591,6 +4596,7 @@ Configuration:
protobuf-c . . . . . $have_protoc_c
oracle . . . . . . . $with_oracle
python . . . . . . . $with_python
@ -34,7 +34,7 @@
Features:
daemon mode . . . . . $enable_daemon
@@ -4609,6 +4615,7 @@ Configuration:
@@ -4630,6 +4636,7 @@ Configuration:
iptables . . . . . . $enable_iptables
ipvs . . . . . . . . $enable_ipvs
irq . . . . . . . . . $enable_irq
@ -52,7 +52,7 @@
#@BUILD_PLUGIN_JAVA_TRUE@LoadPlugin java
#@BUILD_PLUGIN_LIBVIRT_TRUE@LoadPlugin libvirt
@BUILD_PLUGIN_LOAD_TRUE@@BUILD_PLUGIN_LOAD_TRUE@LoadPlugin load
@@ -372,6 +373,12 @@ FQDNLookup true
@@ -376,6 +377,12 @@ FQDNLookup true
# IgnoreSelected true
#</Plugin>
@ -249,7 +249,7 @@
+}
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -452,6 +452,15 @@ collectd_LDADD += "-dlopen" irq.la
@@ -454,6 +454,15 @@ collectd_LDADD += "-dlopen" irq.la
collectd_DEPENDENCIES += irq.la
endif